SafeExplosions

SafeExplosions

http://forums.bukkit.org/threads/45414/

Description

Continuation of AntiCreeper from scratch. Easy to configure. Extra features. Sorry to the creator of AntiCreeper v2.5 if you still wish to continue that plugin, inform me immediately and I will most probably halt the development of this plugin.

Features

  1. Everything AntiCreeper v2.5 has
  2. Using YAMLConfiguration
  3. Config to allow explosions below certain Y value
  4. Config to disable sound and effect
  5. Able to reload config in game
  6. Config to disable sound and effect

Permissions [PermissionBukkit, PEX, bPerms]

safeexplosions .* - Everything below
safeexplosions.admin - Use the /se commands

Configuration Defaults (plus comments)

TNT: true #Nerf TNT
CREEPERS: true #Nerf Creepers 
FIREBALLS: true #Nerf Ghast and other fireballs
Disable_Damage: false #Nerf to disable damage  
Disable_Sound: false #Nerf to disable sounds and effects  
Allow_Explosions_Below: 0 #Allow explosions when Y coordinates is below this integer  
Ignored_Worlds: #World names to ignore "nerfing"
  - lorem
  - ipsum
Disallow_Explosions_Everywhere_Worlds: #World names to disallow everywhere even below the Y value above
  - lorem2
  - ipsum2

Comments

  • To post a comment, please or register a new account.
Posts Quoted:
Reply
Clear All Quotes

About This Project

  • Project ID
    33805
  • Created
    Nov 13, 2011
  • Last Released File
    May 7, 2012
  • Total Downloads
    358,459
  • License

Categories

Members

Recent Files

Bukkit