EssentialsAPIBridge

Essentials API Bridge

This plugin allows plugins that work with Essentials/EssentialsX code to work with Bssentials version 3.x

 

Example:

Plugin A depends on the Essentials Economy for an item shop. Plugin A would fail on Bssentials as Bssentials is a replacement of Essentials & contains no Essentials code. Here's where the Essentials Bridge comes in, the bridge is the Essentials API classes but points to Bssentials instead of Essentials. Witch will allow Vault to register Essentials as being "Essentials" but when really it is registering the Bssentials API as the bridge is the Essentials API but instead of using Essentials files it uses Bssentials.

 

Less wordy Example:

if a plugin fails due to it can't find a class that contains

net.ess3.api

 or

com.earth2me.essentials

 and you're using Bssentials then this plugin will fix those errors.


Comments

  • To post a comment, please or register a new account.
Posts Quoted:
Reply
Clear All Quotes

About This Project

Categories

Members

Recent Files

Bukkit

  • 1.1
    Jul 10, 2019