MobCatcher

101 - Dispensers are buggy

What steps will reproduce the problem?
(For dispensers facing N/E/W/S)
1. Place a dispenser facing sideways; that is, not up or down.
2. Load a spawn egg (with this plugin installed of course.)
3. Fire the dispenser.
(For dispensers facing up/down)
1. Place a dispenser facing up or down.
2. Load a spawn egg.
3. Fire the dispenser.

What is the expected output? What do you see instead?
(For sideways dispensers)
I expect the spawn eggs to get fired in the direction that the dispenser faces. However, eggs get fired the wrong way/distance, usually behind the dispenser, to the left, too short/long, etc. No errors.
(For up/down dispensers)
I expect the dispenser to fire the spawn egg upwards or downwards, like any other projectile. Instead, nothing gets fired out (the dispenser does make a noise though), and an error is thrown in console (see below).

What versions MobCatcher, CraftBukkit, and Spout (if any) are you using?
No Spout, CB Build 1.5.1-R0.2, and version 3.8 of MobCatcher.

Have you previously had any older versions of MobCatcher on your server?
Yes. But I don't think this is relevant to the issue.

Do you have an error log of what happened?
Right here: http://pastebin.com/4jiaLVGq
This only applies to up/down dispensers.

Please provide any additional information below.
I tested this on my testing CB server, which was version 1.5.1-R0.2. The only plugins running were version 3.8 of MobCatcher, Vault, and Pail. I believe Bukkit changed something about projectiles and cardinal directions a few beta builds back, which could be the cause of this issue.

User When Change
Malikk65 Jun 05, 2013 at 03:02 UTC
Malikk65 May 07, 2013 at 04:48 UTC
CommodoreAlpha Apr 28, 2013 at 17:56 UTC Create

You must login to post a comment. Don't have an account? Register to get one!

  • 2 comments
  • Avatar of Malikk65 Malikk65 Jun 05, 2013 at 03:02 UTC - 0 likes

    Fixed in 3.10 for all directions.

    Thanks for the report

    My Plugins: MobCatcher, EpicGlass, Shield
    Donate!

  • Avatar of Malikk65 Malikk65 Apr 28, 2013 at 20:52 UTC - 0 likes

    That's because I had to do some hackish things to get this to work with the way dispensers used to work.

    While you're waiting for a fix, you might try disabling dispensers in your config file and it should spawn the eggs like normal.

  • 2 comments

Facts

Last updated
Jun 05, 2013
Reported
Apr 28, 2013
Status
Fixed - Developer made requested changes. QA should verify.
Type
Defect - A shortcoming, fault, or imperfection
Priority
Medium - Normal priority.
Votes
0

Reported by

Possible assignees