custom fuel & iron ore smelting aren't working #254

  • New
  • Defect
  • _ForgeUser9901927 created this issue Apr 5, 2016

    1. What steps will reproduce the problem ?

    Attempting to smelt Iron Ore with a custom fuel. I have the base recipe for smelting Iron Ore disabled and want to use only a select fuel sources, one being a custom fuel.

    2. Do you have an error log of what happened ?

    No error log was produced

    3. What is the expected output ? What do you see instead ?

    I expect Iron Ingots to smelt normally with my selected fuel sources. In the furnace UI, whenever I try to place any amount of Iron Ore into the cooking slot, with these conditions active, it places the Iron Ore back into my cursor's control like I never inserted the Iron Ore into the furnace UI.

    4. What version of RecipeManager and CraftBukkit are you using ?

    The latest version of RecipeManager and Spigot 1.9

    5. Did you use "rmreload" or "reload" commands in that server session ? If so, specify which.

    I regularly use /rmreload

    6. Provide additional information if appliable.

    I've attached the .txt file with my recipes so you can either use them to recreate the problem or point out what I'm doing incorrectly.

  • _ForgeUser9901927 added the tags New Defect Apr 5, 2016
  • _ForgeUser9901927 added an attachment Smelting_I.txt Apr 5, 2016


    <p>.txt file with the coding I'm attempting to use</p>

  • pIaybabe posted a comment Apr 5, 2016

    Hi natorai_shido.
    I has been using some of custom fuel and that is normaly what it shoud be.
    first you need to put the right fuel. If the fuel you put in doesn't correct.
    when you place iron it will back to your curser.

    try this if it work tell me
    & sulphur:0
    = iron_ingot

    But Im not sure that you have do something wrong 'cause I also have problme too.
    all flag don't work with smelting.

    can you try this for me? If it work plase tell me.
    = stone
    @name TEST

  • _ForgeUser9901927 posted a comment Apr 5, 2016

    <<reply 2775237>>

    Hi Playbabe
    Whenever I would attempt to smelt the iron, regardless of fuel in the furnace, and regardless of if I had vanilla iron smelt allowed or not(then overridden), it would still place the item back in my cursor.

    I tried your recipe and it didn't work for me. I also modified it to say:
    & coal
    = stone
    @name TEST
    Thinking because it's not an item that would normally be smelt-able that it required an affixed fuel, however that was unsuccessful as well.

    Edited Apr 5, 2016
  • pIaybabe posted a comment Apr 6, 2016

    @natorai_shido: Go

    see my tickets.

    All flag don't work on smelting now.
    Im finding that did this bug only happend to me?

    P.S. I have bad english.

  • _ForgeUser9901927 posted a comment Apr 6, 2016

    @pIaybabe: Go

    Actually at one point i was able to get my recipe to work, although only ever once:

    15 % 20
    & 263:0
    & 263.1
    & 289
    = 265:0:1
    @ingredientcondition 289 | name &fCoal Coke
    @explode nobreak | fire | power 1

    However after the explosion effect went off(without lighting stuff on fire, to my disappointment), it's seemed to be irrevocably broken, and I started having the current issue I am now. Thinking everything was fine, I tried adding:

    @holditem 359 | name &fTongs @explode false

    Though it seemed to not affect anything since smelting ceased working. I don't know if this helps anything, but have more information can't hurt?

    Edited Apr 6, 2016
  • _ForgeUser9901927 posted a comment Apr 6, 2016

    So having dinked around with it more, I realized my issue and was able to (sort of?) get smelting working again. Apparently for fuel recipes there are only allowed one input, one fuel source, and one output, as to not break the unwritten "One item, One recipe" rule. Alongside this being that you cant have two inputs to one output, similarly, you cant vary one input to two outputs (eg. iron ore makes iron or steel, dependent on fuel; doesn't work).

    It sucks to be so limited but I guess my ticket has fixed itself, so this can be marked as fixed.

To post a comment, please login or register a new account.