qTrade v1.3.1

Details

  • Filename
    qTrade.jar
  • Uploaded by
  • Uploaded
    Jan 28, 2012
  • Size
    7.51 KB
  • Downloads
    403
  • MD5
    b3acd8de439d3df2ac6c82846d7c7bf9

Supported Bukkit Versions

  • CB 1.1-R1

Changelog

v1.3.1

  • Replaced some incomplete checks

v1.3

  • Added economy support

    - Trade usage now "/trade <player> <item ID> <amount> OR /trade <player> <money> " (For example, /trade Loud $50)

    - Offer usage now "/offer <item ID> <amount> OR /offer <money>" (For example, /offer $50)

    - Requires Vault and an economy plugin, or economy support will be disabled (economy support is optional, it will be normal item trading otherwise)

    - Messages sent to players will be different if economy support is disabled

    - "use-economy" option now in config.yml (defaults to false)

    - Balance is checked before the trade is completed.

  • Added "qtrade.receive" permission, players must have this to receive trades

    - Trading a player who does not have this permission will give the sender an error

  • Added "trade-between-worlds" option in config (defaults to false)

  • Updated version in plugin.yml to "1.3" in stead of "1"

v1.1.2

  • Fixed the usage message on "/trade" to get rid of the error message

v1.1.1

  • Added a missing statement to check if the given argument is a valid item

v1.1

  • Added logging of completed trades
  • Added usage message on "/trade" (no arguments)

v1.0

  • Initial release
  • Only supports one stack of items at a time (fix planned, but not being worked on)
  • Enchantments will be lost upon trading (fix planned, hopefully soon)
  • Source is a huge unreadable mess :D