POI version 1.1.1 (CB 1.7.2 compatible)

Details

  • Filename
    PointsOfInterest.jar
  • Uploaded by
  • Uploaded
    Dec 31, 2013
  • Size
    394.70 KB
  • Downloads
    425
  • MD5
    636b872c7307c5f373fdfa2a210273f3

Supported Bukkit Versions

  • CB 1.7.2-R0.2

Changelog

It is highly recommended that you back up the entire plugins/PointsOfInterest directory before performing an update. There are special notes about updating from v0.5.3 or earlier in the "Installation Guide". See "Installation Guide" for notes about breaking changes.

Make sure to see the Installation Guide

Revision History

Version 1.1.1

Fixes library issue introduced with CB 1.7.2.

Version 1.1.0

Dynmap support is here!

This update will modify the database in a way that may not be compatible with older versions of the plugin! Please take care to back up the entire plugins/PointsOfInterest directory before performing this update.

  • Added Dynmap 1.8+ integration (map markers).
  • Added POI types. (Labels, Map marker icon config, permissions)
  • 4th line of POI signs now have a meaning (sets the POI type)
  • new "/poi types" action
  • added teleport to help system

Version 1.0.3

  • Fixed bad v1.0.2 build (missing dependencies)

Version 1.0.2 (Major Update!)

  • Improved permissions Breaking change
  • Add/Remove with signs
  • Command line add removed
  • Compass integration (Please report incompatibilities with other compass plugins)
  • Teleport implementation
  • Longer, multi-word names
  • Update to DB structure
  • Config "distanceThreshold" now only applies to area searches
  • Fixed incorrect cardinal directions

Version 0.6.7

  • Updated for compatibility with 1.2.5-R1.0

Version 0.6.5b

  • Fixed bad configuration template forcing plugin to always be in "lock down" mode. (Thanks to cbcore for reporting the issue in detail!)

Version 0.6.5

  • Added config option for putting plugin into "lock down" mode.
  • Added automatic "lock down" on initial install to allow for configuration before users can interact with plugin.
  • Added permission node (poi.lockdown.override) to grant a user ability to interact normally during a lockdown.

Version 0.6.0

  • Added permission-driven poi maximums
  • Fixed issue where unconfigured options would receive old values instead of default when config is reloaded via in-game command.
  • Removed support for "addRestrictedToOps" config option (default permissions now enforce this and can be overridden with a permissions plugin).
  • Merged config help into config file for improved usability (used to be in separate files).

Version 0.5.6

  • Updated Listeners to work with modern CB builds.

Version 0.5.5

  • Added permissions support
  • Added ability to reload the config file from in-game command (permission protected)
  • Added ability to remove POIs that belong to other players (permission protected)

Version 0.5.4

  • Added ability to reload the config file from the console.
  • Added database versioning

Version 0.5.3

  • General Code Mainentance

Version 0.5.2

  • Ability to add POIs is now optionally restricted to Ops. This new configuration defaults to true.
  • Sepatrated config file from config help (allows for plugin to automatically bring config file up to date while keeping old settings.
  • Failure to load or parse config file now disables the plugin - this keeps your citizens from running wild with default settings before you realize it. Error(s) will show up in the console to indicate this condition.

Version 0.5.1

  • Fixed issue with hardcoded distance threshold

Version 0.5

  • Initial release

Version 1.0.2 adds compass support.  This is a huge feature but may have conflicts with other compass-related plugins.  Please report any such conflicts and I will do my best to resolve them! Compass support can be turned off via the "crussell52.poi.compass" permission.