Commands are never triggered #5

  • New
  • Defect
Assigned to _ForgeUser10418065
  • _ForgeUser8988769 created this issue Mar 11, 2013

    What steps will reproduce the problem?
    1.Make purchase/receive ipn
    2.wait for db check/announcement

    What is the expected output? What do you see instead?
    commands should be triggered after announcement

    What version of the product are you using?

    Do you have an error log of what happened?

    Please provide any additional information below.
    I have tried changing values, but it seems like it is never finding the correct package.

  • _ForgeUser8988769 added the tags New Defect Mar 11, 2013
  • _ForgeUser8988769 added an attachment config.yml Mar 11, 2013


    <p>Obole config</p>

  • _ForgeUser8988769 added an attachment db.png Mar 11, 2013


    <p>DB entry</p>

  • _ForgeUser8988769 posted a comment Mar 11, 2013

    Also, if needed, I did make some edits on ipn.php to satisfy my use case, but the information that makes it to the DB seems to be what the plugin is looking for, so that should not play a role. Otherwise, I can post the ipn.php. The changes were in order to automatically detect my sandbox account and act accordingly (too lazy to constantly change the variable manually.) Also, I found that $custom was not receiving the minecraft username (I send on a input type="hidden" based on what I have on the website as their mc name.) I had to use $option_selection1 to input the minecraft name.

    Thinking that perhaps there was something wrong with the minecraft name, I tried using a broadcast command to check if any command was being issued. It never fired either.

  • _ForgeUser8424764 removed their assignment Mar 11, 2013
  • _ForgeUser8424764 assigned issue to _ForgeUser10418065 Mar 11, 2013
  • _ForgeUser10418065 posted a comment Mar 15, 2013

    Your package name ('1','7','00'...) are not good your package name must be the same as package price.

  • _ForgeUser8988769 posted a comment Mar 16, 2013

    <<reply 1332935>>

    That is in fact the problem. Perhaps you should change the sample config file to make this more apparent, maybe instead of:

    '5': #package name


    '5': #package name (must be the same as the price)

    One other problem, I seem to have in this configuration. My prices as you can see are #.99, however if I make the name 0.99 or .99, it will not work. When I download the config it has had all decimals exploded and creates this format:

    * '4':
    *    '99':
    *      price: '4.99'
    *      expires: '7'
    *      commands:
    *      - pex user %player group set VIP
    *      - economy give %player 500.00
    *      - neverbreak %player true
    *      - msg %player Thanks for becoming a VIP!
    *      onlineCommands:
    *      - 'msg %player VIP Status: True!'
    *      - neverbreak %player true
    *      expirescommands:
    *      - pex user %player group set Member
    *      - neverbreak %player false

    can I also suggest that you change the package name to equate to the "item_name" var in the ipn file? This would allow multiple items to be the exact same price.

    I can work around the current issue by changing all price to the nearest whole dollar. Is this intended or should the decimal place be escaped by something? shows that '0.99' does indeed parse correctly for YAML.

To post a comment, please login or register a new account.