EnchantmentsPlus v4.0.0

Details

  • Filename
    enchantments-plus-4.0.0.jar
  • Uploaded by
  • Uploaded
    Jun 16, 2021
  • Size
    392.77 KB
  • Downloads
    804
  • MD5
    1459cee9630954639529b5156e73f35d

Supported Bukkit Versions

  • 1.17
  • 1.16

Changelog

Make sure to have Java 16 installed, following this release Java 16 will be required in order to run

Also make sure to reset the magicCompat.yml file as it was changed by this update, provided you want to use this in 1.17, otherwise DO NOT DELETE IT and keep your old one in tact.

Version support

  • 1.17 natively
  • 1.16.5 would work, but usage not recommended at all (requires custom magicCompat.yml)

Changes (since last release candidate):

Changes (since 3.1.6)

This is an API purge update as well as one introducing official 1.17 support (the old release also has 1.17 support, but you'd need to adjust the magicCompat.yml)

  • resolved issue with fire sometimes not working as intended
  • resolved #62 (Coreproect support fully introduced)
  • resolved #70
  • Most deprecated members purged
  • Reduced static abuse
  • Address potential memory leaks even further
  • resolved #68
  • Updated dependencies
  • You can now make use of tags within the magicCompat.yml
  • The magicCompat.yml was updated to meet 1.17 changes (still may require some adjustments)
  • resolved #72
  • Obscure Spectral feature got removed (it didn't work anyways)
  • resolved #74

Support

Got a question? Need help or want to discuss changes? Then feel free to contact me either via Spigotmc conversations, Internet Relay Chat or Github Issues and Discussions.