can't select pieces #73

  • Defect
  • Started
Assigned to desht_08
  • _ForgeUser12153760 created this issue Jul 27, 2014

    What steps will reproduce the problem?
    Run a 1.7.10 server, use latest dev build of ChessCraft, observe as pieces are not selectable.

    What is the expected output? What do you see instead?
    A selection box -> no selection box or moveability

    What version of the product are you using?
    latest dev build (built 16 days ago)

    Do you have an error log of what happened?
    No error showed.

    Please provide any additional information below.
    Console reports nothing of interest. Here's all chesscraft output anyway:

    [04:18:08] [Server thread/INFO]: [ChessCraft] Loading ChessCraft v2.5.2-SNAPSHOT
    [04:18:25] [Server thread/INFO]: [ChessCraft] Enabling ChessCraft v2.5.2-SNAPSHOT

    [04:19:21] [Server thread/INFO]: mcmonkey4eva issued server command: /warp chessboard
    [04:19:21] [Server thread/INFO]: ChessCraft: controller changed: now ChessCraft
    [04:19:26] [Server thread/WARN]: [WorldEdit] No compatible nms block class found.
    (I try to run the game at this point, then give up)
    [04:20:06] [Server thread/INFO]: ✱ [AI]jcab4 beat mcmonkey (resigned) in a game of Chess!
    [04:20:13] [Server thread/INFO]: mcmonkey4eva issued server command: /warp head
    [04:20:13] [Server thread/INFO]: ChessCraft: controller changed: now (none)
    [04:20:22] [Server thread/INFO]: [ChessCraft] Finished game auto-deleted.

    It's a block-tower type chessboard, medium sized... this all worked in prior versions.

    I realize this is information-lacking. Nothing I've given is very useful to finding the error, so I ask - what can I do to get sufficient additional information to diagnose this issue?

  • _ForgeUser12153760 added the tags New Defect Jul 27, 2014
  • desht_08 posted a comment Jul 28, 2014

    Thanks for the report. Unfortunately, it's not something I can reproduce here. Some things to try:

    • Do /chess set debug_level 2 and then try to select a piece. You should see a message like [ChessCraft] Player desht waved at block CraftBlock{chunk=CraftChunk{x=-1z=19},x=-1,y=71,z=312,type=IRON_BLOCK,data=0} - please let me know if you do. Do /chess set debug_level 0 to turn off debug messages.
    • Do you have WorldEdit installed, and if so, which version? I've had problem reports with 6.0 snapshots (although I'm running a 6.0 snapshot here without problems). 5.6.3 should work fine with CB 1.7.10.
    • Have you verified that the wand_item config setting matches the item you're holding? (The default is 'air' meaning you need to be empty-handed. You can set it to '*' to make it not care what you're holding).
    • Can I see your full server startup log? Would be good to know just which other plugins and which versions you're running. This has to be a plugin conflict of some kind given that several people are seeing this behaviour but I'm not.
  • _ForgeUser12153760 posted a comment Jul 30, 2014

    I set debug_level 2 and got tons of output, however it's completely silent when I try to click.

    I have worldedit v5.6.2 + AsyncWorldEdit

    The wand_item is air, and I'm clicking with an empty hand.

    Here's a semi-complete log from what I had in post, including startup (some irrelevant startup details snipped out)

  • desht_08 posted a comment Jul 31, 2014

    Nailed it! Turned out it was a introduced by me a couple of commits ago, so actually had nothing to do with the CB 1.7.10 upgrade. Oops.

    Anyway, build #69 should work fine. And I'm just uploading that build as v2.5.2 now.

  • desht_08 removed a tag New Jul 31, 2014
  • desht_08 added a tag Started Jul 31, 2014
  • _ForgeUser12153760 posted a comment Jul 31, 2014

    Awesome! #69 fixed it! Thank you.

To post a comment, please login or register a new account.