Multiverse 2 Logo

Multiverse Portals Resources:

Latest Awesome Build is 2.4-AB

Development builds of this project can be acquired at the provided continuous integration server.
These builds have not been approved by the BukkitDev staff.
Use them at your own risk.

About MV2

Multiverse was created at the dawn of Bukkit multiworld support. It has since then grown into a complete world management solution including special treatment of your nether worlds with NetherPortals.

In the second delivery of Multiverse, we've broken it up into several smaller plugins that are each feature packed but *not bloated*! Multiverse provides the easiest to use world management solution for your Minecraft server, big or small, and with great addons like Portals and NetherPortals, what's not to love!

Multiverse is back! Is your server, a Multiverse?

Multiverse-Portals Features

What's an "Awesome Build"

You can think of this like Bukkit's RB system, but we don't want to create confusion, so instead of calling ours a Recommended Build also, we're going with "Awesome Build" or AB. Awesome Builds are ones that we've put some more testing into, and should be very stable. Unfortunately, due to lack of developers able to work on the Multiverse suite, and the inability to achieve the normal Awesome Build quality level, we have discontinued our Awesome Builds until further notice. Our beta builds available on this site are fairly stable so don't disregard them!

WorldEdit changed it's API back in April, we haven't made an official version since then that uses the new API.

If you are using WorldEdit 6.x use this

You must login to post a comment. Don't have an account? Register to get one!

  • Avatar of marubal21 marubal21 Oct 01, 2015 at 22:55 UTC - 0 likes

    Os it possible to have 1 portal that has multiple destinations? Hoping it would randomly send players to any of the multiple destinations.

  • Avatar of games647 games647 Oct 01, 2015 at 18:02 UTC - 0 likes

    @Maxie_Z: Go

    Please read the update page. It looks like your WorldEdit version isn't compatible to Multiverse portals. Try to update WorldEdit.

    Star if you like these projects
    FastLogin - Automatically skips offline authentification (auth plugin) if the player has a paid account
    ScoreboardStats - Fast custom scoreboard with optional pvpstats tracking
    mcCombatLevel - Display a level based on your mcMMO skills
    mcMMOExtras - Show the progress of your mcMMO skills

  • Avatar of Maxie_Z Maxie_Z Sep 26, 2015 at 18:49 UTC - 0 likes

    Help. I am having a problem

    Take a look at my log:

    26.09 14:47:45 [Server] INFO Connection timed out 26.09 14:47:45 [Multicraft] Skipped 2 lines due to rate limit (30/s) 26.09 14:47:44 [Server] INFO at com.onarandombox.MultiversePortals.MultiversePortals.onCommand( [?:?] 26.09 14:47:44 [Server] INFO at com.pneumaticraft.commandhandler.multiverse.CommandHandler.locateAndRunCommand( [?:?] 26.09 14:47:44 [Server] INFO at com.pneumaticraft.commandhandler.multiverse.CommandHandler.locateAndRunCommand( [?:?] 26.09 14:47:44 [Server] INFO at com.pneumaticraft.commandhandler.multiverse.CommandHandler.processFoundCommands( [?:?] 26.09 14:47:44 [Server] INFO at com.pneumaticraft.commandhandler.multiverse.CommandHandler.checkAndRunCommand( [?:?] 26.09 14:47:44 [Server] INFO at com.onarandombox.MultiversePortals.commands.CreateCommand.runCommand( [?:?] 26.09 14:47:44 [Server] INFO at com.onarandombox.MultiversePortals.PortalPlayerSession.getSelectedRegion( [?:?] 26.09 14:47:44 [Server] INFO Caused by: java.lang.NoSuchMethodError: com.sk89q.worldedit.LocalSession.getSelectionWorld()Lcom/sk89q/worldedit/LocalWorld; 26.09 14:47:44 [Server] INFO at Source) [?:1.8.0_60] 26.09 14:47:44 [Server] INFO at [spigot.jar:git-Spigot-2f787bd-ea28011] 26.09 14:47:44 [Server] INFO at net.minecraft.server.v1_8_R2.MinecraftServer.z( [spigot.jar:git-Spigot-2f787bd-ea28011] 26.09 14:47:44 [Server] INFO at net.minecraft.server.v1_8_R2.DedicatedServer.A( [spigot.jar:git-Spigot-2f787bd-ea28011] 26.09 14:47:44 [Server] INFO at net.minecraft.server.v1_8_R2.MinecraftServer.A( [spigot.jar:git-Spigot-2f787bd-ea28011] 26.09 14:47:44 [Server] INFO at net.minecraft.server.v1_8_R2.SystemUtils.a(SourceFile:60) [spigot.jar:git-Spigot-2f787bd-ea28011] 26.09 14:47:44 [Server] INFO at Source) [?:1.8.0_60] 26.09 14:47:44 [Server] INFO at java.util.concurrent.Executors$ Source) [?:1.8.0_60] 26.09 14:47:44 [Server] INFO at net.minecraft.server.v1_8_R2.PlayerConnectionUtils$ [spigot.jar:git-Spigot-2f787bd-ea28011] 26.09 14:47:44 [Server] INFO at net.minecraft.server.v1_8_R2.PacketPlayInChat.a( [spigot.jar:git-Spigot-2f787bd-ea28011] 26.09 14:47:44 [Server] INFO at net.minecraft.server.v1_8_R2.PacketPlayInChat.a( [spigot.jar:git-Spigot-2f787bd-ea28011] 26.09 14:47:44 [Server] INFO at net.minecraft.server.v1_8_R2.PlayerConnection.a( [spigot.jar:git-Spigot-2f787bd-ea28011] 26.09 14:47:44 [Server] INFO at net.minecraft.server.v1_8_R2.PlayerConnection.handleCommand( [spigot.jar:git-Spigot-2f787bd-ea28011] 26.09 14:47:44 [Server] INFO at org.bukkit.craftbukkit.v1_8_R2.CraftServer.dispatchCommand( [spigot.jar:git-Spigot-2f787bd-ea28011] 26.09 14:47:44 [Server] INFO at org.bukkit.command.SimpleCommandMap.dispatch( [spigot.jar:git-Spigot-2f787bd-ea28011] 26.09 14:47:44 [Server] INFO at org.bukkit.command.PluginCommand.execute( [spigot.jar:git-Spigot-2f787bd-ea28011] 26.09 14:47:44 [Server] INFO org.bukkit.command.CommandException: Unhandled exception executing command 'mvp' in plugin Multiverse-Portals v2.5-b699 26.09 14:47:44 [Server] ERROR null 26.09 14:47:44 [Server] INFO WEAPI

  • Avatar of 7evenSkies 7evenSkies Sep 24, 2015 at 14:58 UTC - 0 likes

    Oh dear, so what now? I'm also having the same problem like DrGlickenstine one too. I hope this fix fast :/ But can I use an older version one if there is problem in the latest? Will it cause any big problems if I use the older version one too? My Multiverse-Core is 2.5 version and it's working fine but just with my Multiverse-Portals 2.5 only.

  • Avatar of bdailey7280 bdailey7280 Sep 24, 2015 at 13:58 UTC - 0 likes

    @DrGlickenstine: Go

    The plugin has not been updated in a while. I will try to find plugin someone else fixed themselves and share with you.

  • Avatar of l0rdrav3n l0rdrav3n Sep 15, 2015 at 20:06 UTC - 0 likes

    Are the authors even listening here?

  • Avatar of DrGlickenstine DrGlickenstine Sep 11, 2015 at 04:53 UTC - 0 likes

    I have the same problem as others where I get the PlayerMoveEvent error in the console and portals do not work.

  • Avatar of OttDody OttDody Sep 01, 2015 at 14:10 UTC - 0 likes

    @Andrey2826: Go


  • Avatar of msfghjkdhfg msfghjkdhfg Aug 24, 2015 at 09:43 UTC - 0 likes




    1.8 et +

  • Avatar of TheKny TheKny Aug 23, 2015 at 15:42 UTC - 0 likes

    i need a version for liteloader


Date created
Aug 04, 2011
Last update
Sep 22, 2015
Development stage
BSD License
Curse link
Recent files



Required dependency
Optional dependency