AntiCreeper

AntiCreeper logo

AntiCreeper

  • Tired of rebuilding every building in your server, because those green things ruin them all the time?
  • Tired of filling in all the explosion-created holes? Wish you could tell people to do it themselves?
  • And also you hate the mods which make the creepers just walk around without doing anything to the players?
  • Do you have a nether paradise? Do you hate the fireball spitting ghasts or players exploding beds?
  • Too much grief with TNT?
  • Those missing or randomly placed blocks from endermen triggering your OCD?
  • Having fun with fireballs but don't like the fire? Or want creepers to burn stuff too?
  • That huge hole left by Wither boss got you down?
  • AntiCreeper config.yml too confusing for you?
  • Want to spawn an Enderdragon but don't like the wholesale destruction?

If You say yes to just one of the questions, then this plugin is for You!

This plugin by Filbert66, though its roots come from @Rothens.

Features

  • Cancels creeper environment-destroying behavior.
    • or optionally allows it but can leave 100% of destroyed blocks, allowing easy rebuilding.
    • and/or configure a height below which it is allowed, or alternatively above which it is allowed.
    • and/or define a list of blocks that are (the only/NOT) affected
    • and optionally disable sound & smoke or player damage, if you really want to
    • and selectively configure which entities receive damage or not.
  • Cancels TNT, Fireballs, Wither explosions, ender crystal (NEW), unknown explosions (from other plugins) with all of same options as for creepers, above
    • optional different configuration for wither skulls and TNT minecarts.
  • But can damage the players in all cases! (you can now control this, too)
  • Cancel various enderman behaviors, including block pickups, or just put-downs.
    • with configurable white/blacklist!
  • cancel damage caused by lightning (for you spell-makers out there).
  • disable Wither & Ender Dragon moving through and damaging blocks
    • both support configurable blocklists
  • Detailed configuration now available!
  • Kind of multi-world support; the same configuration applies to all listed worlds.
  • In-game commands to query, set, and save configuration items
    • allows testing config changes without making them permanent
    • save configs to disk without every manually editing config.yml.
  • disable exploding beds in the nether
  • Override explosion power to strengthen/weaken each explosion type
  • Option to throw destroyed blocks a distance based on distance from explosion center. Kinda fun, but can lag on chained TNT.
  • NEW in 4.15: Supports multiple languages on all player messages

mobGriefing rule not the same

I hope you see that this does much more than the mobGriefing game rule. Yes, it's almost the same as the default Anticreeper config, but not the same. See my comment on this for an equivalent Anticreeper config.

Anticreeper allows you to do more, including fine-tune what/who gets damaged from explosions, create protected block types, allow damage from one mob explosion but not another, and lastly but perhaps most significantly, nerf TNT damage which mobGriefing does nothing about!

Configuration Description & Hints

Please READ THIS FIRST before you post here with problems. click above link to view page

Still Not Working for you?

Most common error is misspelling your world name. Log into your world and execute these commands in game:

ac world
ac world on
ac save

First tells you if you had it on in that world. Second activates it, just to make sure. Third saves it so it sticks.

Commands and Permissions

Details about in-game commands and associated permissions are found here.

Statistics

Since 4.8 the plugin now sends statistics to mcstats.org. These are completely anonymous and help me as a plugin developer know how the plugin is being used. You can view the same data by clicking below. If you want to turn it off, simply edit plugins/PluginMetrics/config.yml and change opt-out: false to true

McStats image

Planned Features

Click here to have input into what I should do next.

Any donations are welcome and will inspire more features. :)

You must login to post a comment. Don't have an account? Register to get one!

  • Avatar of filbert66 filbert66 Feb 07, 2013 at 00:04 UTC - 0 likes

    @Psyrick: Go

    Added nerf_*.power. Have fun, but beware of setting TNT so big that you can't run away after setting it off! Early release can be

    Last edited Mar 28, 2013 by drtshock: Linking to unapproved download.

    My plugins: Anticreeper, AntiFire, BedCheck, Thor, Unbreakable Items, Enchantment Limiter. Contributor: Tree-Assist

    BFAK:67982,3d6540176e18ca75f0a204a87213d75a51e4b745f16c619b8fcef59ccfeab5cb

  • Avatar of whitechristmas whitechristmas Feb 06, 2013 at 02:43 UTC - 0 likes

    @filbert66: Go

    Perfect! Thank you very much filbert66. :)

  • Avatar of typxx typxx Feb 05, 2013 at 23:13 UTC - 0 likes

    @filbert66: Go

    Everything works fine, thank you :)

  • Avatar of filbert66 filbert66 Feb 05, 2013 at 17:54 UTC - 1 like

    @typxx: Go @WhiteChristmas

    I have prepared a Java 1.6 compiled version, called 4.6.1, which you can get here. Please let me know if it works for you.

  • Avatar of typxx typxx Feb 05, 2013 at 13:40 UTC - 0 likes

    Same problem here. I'm running my bukkit server on a friend's ubuntu 10.4 machine and you can't install java 7 / 1.7 there. A java 6 / 1.6 recompile would be awesome.

  • Avatar of whitechristmas whitechristmas Feb 05, 2013 at 08:39 UTC - 0 likes

    @filbert66: Go

    Good morning. I'm using:

    Java version 1.6.0_24

    Last edited Feb 05, 2013 by whitechristmas
  • Avatar of filbert66 filbert66 Feb 05, 2013 at 08:36 UTC - 0 likes

    @whitechristmas: Go

    Hmm... This version was compiled with Java 1.7.0_10; all previous are 1.6. I think that may be it. What version are you using? (run "java -version") I will recompile with 1.6 and post a bugfix version.

    Last edited Feb 05, 2013 by filbert66: confirmed problem is Java version
  • Avatar of filbert66 filbert66 Feb 05, 2013 at 08:32 UTC - 0 likes

    @Psyrick: Go

    Good idea. That'd be easy. I thought of it a long time ago but never got around to it.

  • Avatar of whitechristmas whitechristmas Feb 05, 2013 at 08:25 UTC - 0 likes

    Hi there.

    Just updated to latest version and received this error on server startup. Any ideas? Previous version worked fine with no errors. Thank you in advance.

    [SEVERE] Could not load 'plugins/AntiCreeper.jar' in folder 'plugins' org.bukkit.plugin.InvalidPluginException: java.lang.UnsupportedClassVersionError: net/anticreeper/Anticreeper : Unsupported major.minor version 51.0

    Last edited Feb 05, 2013 by whitechristmas
  • Avatar of Psyrick Psyrick Feb 05, 2013 at 06:38 UTC - 0 likes

    It's missing just one thing: Setting the blast radius! Whether you want more or less, a plugin like this needs the option. I have tried other plugins that offer such a feature, but none of them offer the option of incendiary explosions. When I run them together with this one, explosions no longer make fire. I'm not sure why that is, but I think it's better if all the relevant features are found in one plugin to avoid these compatibility issues. Since I got CreeperHeal to auto-repair explosion damage, I am really excited to have creepers let off terrifyingly HUGE fire-spreading explosions that light up the night while I won't have to worry about fixing the mess every time. Thank you so much for your work and I hope you will consider my suggestion.

    Cheers!

Facts

Date created
Aug 28, 2011
Categories
Last update
Mar 19, 2014
Development stage
Mature
Language
  • enUS
License
All Rights Reserved
Curse link
AntiCreeper
Downloads
463,091
Recent files

Authors