Error log, permissions not working. #31

  • New
  • Defect
Assigned to _ForgeUser7440577
  • _ForgeUser8667406 created this issue Jul 30, 2012

    What steps will reproduce the problem?

    What is the expected output? What do you see instead?

    What version of the product are you using?
    the newest version

    Do you have an error log of what happened?

    Please provide any additional information below.

    Here is the log:
    I HAVE changed the permissions in the config.yml to "bpermissions"
    I need this fixed ASAP people have figured out and our making warps everywhere!

  • _ForgeUser8667406 added the tags New Defect Jul 30, 2012
  • LigerXT5 posted a comment Jul 30, 2012

    If xwarp wasn't recently added, may I suggest reverting back to what the setting was before? If anything, leave it blank and xwarp will auto detect the perm plugin itself.

  • _ForgeUser8667406 posted a comment Jul 30, 2012
    No that didn't work, i left it blank and they can still make warps, they also have - -xwarp.warp.create.* in the permissions file.
  • LigerXT5 posted a comment Jul 30, 2012

    Just making certain, when you set the perm to blank, did it look like this: permissions: plugin: '' < two single quotes, no space.

    If I may suggest, get vault, it's a universal perm/econ plugin that helps all plugins communicate to the many economy/perm plugins. Think of it like a middle man/translator. If you have vault, just put plugin: 'vault'

  • _ForgeUser8667406 posted a comment Jul 30, 2012
    Yes thats how it is, if you want to double check: And i have always had vault. and i tried changing it to vault, but they can still make warps D:
  • _ForgeUser8667406 posted a comment Aug 1, 2012
    Any idea?
  • LigerXT5 posted a comment Aug 2, 2012

    Sorry for the delay, just got a new apartment and been moving out of the dorms and busy with other related RL stuff along side.

    Mind pasting, or send me a message, the perm config? There might be a confliction down the line from lower-ranked groups.

  • _ForgeUser8667406 posted a comment Aug 3, 2012
    I give all my users - -xwarp.warp.create.* and - -xwarp.warp.edit.*
  • LigerXT5 posted a comment Aug 3, 2012

    just now looking at your topic above, I don't think bpermissions support "- -x.y.z" permissions.
    Their form of removing perms, as by reading their FAQ, is using the ^, not the -.

    (quote from FAQ page at )

        - node.node   <- This is a positive node
        - ^node.node  <- This is a negative node
        groups: []

    Edited Aug 3, 2012
  • _ForgeUser8667406 posted a comment Aug 3, 2012
    Ok that worked, thank you so much, i had no idea about that page.
  • LigerXT5 posted a comment Aug 4, 2012

    @Gunnerrrrr: Go

    Not a problem. I try to help where and how I can.

To post a comment, please login or register a new account.