Limits, Warmups, Cooldowns, BOSEconomy #19


  • New
  • Defect
Open
Assigned to _ForgeUser7440577
  • _ForgeUser6833964 created this issue Mar 7, 2012

    I am having a few problems with getting the limits and warmups and cooldowns working.
    The warmup and cooldown and limit functions dont seem to be working, even though I followed the guides and have them set up in my PEX file. (Snippets of my permissions.yml file http://dev.bukkit.org/paste/4857/)

    Also it doesnt seem to be detecting BOSEconomy 0.7.3.1

    What version of the product are you using?
    3.1.6

    Do you have an error log of what happened?
    http://dev.bukkit.org/paste/4856/

    Please provide any additional information below.

  • _ForgeUser6833964 added the tags New Defect Mar 7, 2012
  • _ForgeUser6833964 posted a comment Mar 7, 2012

    On the permissions page on the github wiki, it also says that it should be set up as "xwarp.warp.timers.cooldown.public", while another page says warp.timers.cooldown.public, as you can see in my paste. Not sure which one I should be using, but both are not working. Also just tried giving the "xwarp.warp.timers.cooldown.public" permission node, just for the heck of it.

  • LigerXT5 posted a comment Mar 9, 2012

    I also have this issue as well. I use permex and ico6. Though I know ico6 is not supported as of yet (possible vault implementation?). The limits and timers do not seem to work. Also like to note I've tried with permissionsBukkit.

  • _ForgeUser6833964 posted a comment Mar 10, 2012

    I am using PEX, but I also have Vault. I have tried a few more configs and nothing works.

  • _ForgeUser8802505 posted a comment Apr 26, 2012

    Are you still having issues with limits/warmups/cooldowns with v3.1.7?

    I started using PEX on my server a few weeks ago as bPermissions seemed to have issues with several warp plugins (MyWarp, xWarp, NiftyWarp) and it took me a short while to get the right layout for the limits etc.

    This is only a guide for PEX, I don't know how other permission systems handle these.
    They do NOT go in info, they go under OPTIONS.

    So:
         options:
          xwarp.warp.prices.create.private '25'

    http://dev.bukkit.org/paste/5210/ <- Example, missing warmups as I don't use them, but you should be able to work them out.

    If you're still having issue after you've looked at the example, I'll be more than willing to help out.


    Edited Apr 26, 2012
  • LigerXT5 posted a comment Apr 26, 2012

    Its working now. this is what I have for one group:

        options:
          xwarp.warp.timers.cooldown.private: 8
          xwarp.warp.timers.cooldown.public: 8
          xwarp.warp.timers.cooldown.global: 8
          xwarp.warp.timers.warmup.private: 3
          xwarp.warp.timers.warmup.public: 3
          xwarp.warp.timers.warmup.global: 3
          xwarp.warp.limit.private: 15
          xwarp.warp.limit.public: 15
          xwarp.warp.limit.global: 15
          xwarp.warp.limit.total: 15
          xwarp.warp.price.create.private: 30
          xwarp.warp.price.create.public: 10
          xwarp.warp.price.create.global: 50
          xwarp.warp.price.to.private: 5
          xwarp.warp.price.to.public: 8
          xwarp.warp.price.to.global: 6.5
    
  • _ForgeUser6833964 posted a comment May 2, 2012

    Thanks for your help! I will test it in a bit. Do they get inherited?

  • _ForgeUser6833964 posted a comment May 3, 2012

    @MRT803: Go

    The new version won't load for me, java.lang.NoSuchMethodError. What do you put in the permissions field in the config? "PermissionsEx" or "PEX" or what?


To post a comment, please login or register a new account.