UpgradingCore

=== UpgradeCore ===

UpgradeCore Allows you to upgrade your weapons, armor, on the highest the upgrade highest the damage, which is configurable. A simple plugin that adds some Role Playing and some more items to die for! You get these items from configurable mobs.

Make Sure to read everything before asking questions already here answered.

_________________________

Features

  • Drops UpgradeCores from Mobs
  • You can upgrade your item to [+1, +2, +3, +4, +5, +6]
  • Super and Friendly Configuration
  • Chances to drop
  • Chances to upgrade
  • Upgrade Swords & Chestplates
  • Auto-Updater
  • More Items!

How to Install

It is super easy to install just paste the jar into your plugins folder, start the server and wait for the config to generate, after it setup the config to your liking and it's done!

How to Play / Use

The plugin is very simple. There are 3 kinds of UpgradeCores that drop out of mobs which are Configurable:

  • LOW
  • MEDIUM
  • HIGH
  • An UC.LOW allows you to use it on Wooden and Stone types.
  • An UC.MEDIUM allows you to use it on Iron and Gold types.
  • An UC.HIGH allows you to use it on Diamind type.

To use an item you open your inventory and right-click the upgrade, then it shall input on your chat that you are using and then you open your inventory again and right-click the item to upgrade it. If the item is succefull in it's upgrade it shall say you have upgrade it otherwise it shall say that you have failed the upgrade.

To Cancel an upgrade you just right-click an empty slot while in upgrade.

IMPORTANT

You can only upgrade Chestplate Armor for the moment being, adding the rest after sorting the rating of the defense

Commands

  • /getcore <low,medium,high> - Gives you an UpgradeCore.

Permissions

  • core.get: Allows you to use the /getcore command
  • core.drop.low: Drops UpgradeCores LOW
  • core.drop.medium: Drops UpgradeCores MEDIUM
  • core.drop.high: Drops UpgradeCores HIGH
  • core.use.low: Allows you to use UpgradeCores LOW
  • core.use.medium: Allows you to use UpgradeCores MEDIUM
  • core.use.high: Allows you to use UpgradeCores HIGH

Configuration

#Which Entities drop which upgrades cores
Entities:
  low:
  - ZOMBIE
  - SPIDER
  - CREEPER
  medium:
  - MAGMA_CUBE
  - GHAST
  - BLAZE
  high:
  - WITHER
  - WITCH
  - ENDER_DRAGON
#The chance of dropping the item!
upgrade-low-chance: 30.0
upgrade-medium-chance: 15.0
upgrade-high-chance: 5.0
#The Success Rate of upgrading to next tier.
Upgrading:
  SuccessRate:
    Lv1-Lv2: 100.0
    Lv2-Lv3: 80.0
    Lv3-Lv4: 50.0
    Lv4-Lv5: 25.0
    Lv5-Lv6: 5.0
#The Damage it add through each tier.
Plus-1-Damge: 0.5
Plus-2-Damge: 1
Plus-3-Damge: 1.5
Plus-4-Damge: 2
Plus-5-Damge: 2.5
Plus-6-Damge: 3
#The Defense it add through each tier. Only version  0.5 and above
Plus-1-Defense: 0.5
Plus-2-Defense: 1
Plus-3-Defense: 1.5
Plus-4-Defense: 2
Plus-5-Defense: 2.5
Plus-6-Defense: 3
#Messages that shows to players
Messages:
  # When a player has no permission, this is by default.
  no-permission: You do not have permission to use this item

Requirements

NONE

Videos

Soon

Pictures

http://i.imgur.com/kYhkYpR.png

Bugs/Crashes

Remember This plugins is new, so bugs are to be expected, if any submit a ticket or post a comment.

Metrics

This plugin utilises Hidendra's plugin metrics system, which means that the following information is collected and sent to mcstats.org:

  • A unique identifier
  • The server's version of Java
  • Whether the server is in offline or online mode
  • The plugin's version
  • The server's version
  • The OS version/name and architecture
  • The core count for the CPU
  • The number of players online
  • The Metrics version

Opting out of this service can be done by editing plugins/Plugin Metrics/config.yml and changing opt-out to true.


Comments

Posts Quoted:
Reply
Clear All Quotes

About This Project

  • Project ID
    78206
  • Created
    Apr 15, 2014
  • Last Released File
    Jan 12, 2016
  • Total Downloads
    3,391
  • License

Categories

Members

Recent Files