Internal Server Error #93


  • Defect
  • Waiting
Open
Assigned to _ForgeUser7460379
  • _ForgeUser2232722 created this issue Aug 2, 2013

    Are you sure what you want is not in the wiki ?

    Are you sure your bug is not already signaled ?
    Yes

    What steps will reproduce the problem?
    When playing a round of Tribu, randomly during a wave as soon as i attempt to hit a zombie, i am kicked from the server with an Internal Server Error.  It doesn't happen every time however, it seems to be completely random.  Sometimes it's the first zombie, sometimes it a few zombies in.

    What is the expected output? What do you see instead?
    From the console:
    2013-08-03 14:00:44 [WARNING] Failed to handle packet for Kussie/118.208.40.184: java.lang.NullPointerException
    java.lang.NullPointerException
    at graindcafe.tribu.TribuZombie.EntityTribuZombie.damageEntity(EntityTribuZombie.java:527)
    at net.minecraft.server.v1_6_R2.EntityHuman.attack(EntityHuman.java:884)
    at net.minecraft.server.v1_6_R2.PlayerConnection.a(PlayerConnection.java:1121)
    at net.minecraft.server.v1_6_R2.Packet7UseEntity.handle(SourceFile:36)
    at net.minecraft.server.v1_6_R2.NetworkManager.b(NetworkManager.java:296)
    at net.minecraft.server.v1_6_R2.PlayerConnection.e(PlayerConnection.java:116)
    at net.minecraft.server.v1_6_R2.ServerConnection.b(SourceFile:37)
    at net.minecraft.server.v1_6_R2.DedicatedServerConnection.b(SourceFile:30)
    at net.minecraft.server.v1_6_R2.MinecraftServer.t(MinecraftServer.java:590)
    at net.minecraft.server.v1_6_R2.DedicatedServer.t(DedicatedServer.java:226)
    at net.minecraft.server.v1_6_R2.MinecraftServer.s(MinecraftServer.java:486)
    at net.minecraft.server.v1_6_R2.MinecraftServer.run(MinecraftServer.java:419)
    at net.minecraft.server.v1_6_R2.ThreadServerApplication.run(SourceFile:582)
    2013-08-03 14:00:44 [INFO] ┬žeKussie left the game.

    What version of Tribu are you using?
    R: Tribu 0.6.3 for 1.6.2 Jul 29, 2013

    Do you have an error log of what happened?
    2013-08-03 14:00:44 [WARNING] Failed to handle packet for Kussie/118.208.40.184: java.lang.NullPointerException
    java.lang.NullPointerException
    at graindcafe.tribu.TribuZombie.EntityTribuZombie.damageEntity(EntityTribuZombie.java:527)
    at net.minecraft.server.v1_6_R2.EntityHuman.attack(EntityHuman.java:884)
    at net.minecraft.server.v1_6_R2.PlayerConnection.a(PlayerConnection.java:1121)
    at net.minecraft.server.v1_6_R2.Packet7UseEntity.handle(SourceFile:36)
    at net.minecraft.server.v1_6_R2.NetworkManager.b(NetworkManager.java:296)
    at net.minecraft.server.v1_6_R2.PlayerConnection.e(PlayerConnection.java:116)
    at net.minecraft.server.v1_6_R2.ServerConnection.b(SourceFile:37)
    at net.minecraft.server.v1_6_R2.DedicatedServerConnection.b(SourceFile:30)
    at net.minecraft.server.v1_6_R2.MinecraftServer.t(MinecraftServer.java:590)
    at net.minecraft.server.v1_6_R2.DedicatedServer.t(DedicatedServer.java:226)
    at net.minecraft.server.v1_6_R2.MinecraftServer.s(MinecraftServer.java:486)
    at net.minecraft.server.v1_6_R2.MinecraftServer.run(MinecraftServer.java:419)
    at net.minecraft.server.v1_6_R2.ThreadServerApplication.run(SourceFile:582)
    2013-08-03 14:00:44 [INFO] ┬žeKussie left the game.

  • _ForgeUser2232722 added the tags New Defect Aug 2, 2013
  • _ForgeUser2232722 posted a comment Aug 3, 2013

    Okay i think i have figured out what causes this error. If a mob happens to spawn in the lanes that wasn't spawned by tribu. When you shoot it it throws this error and kicks the person who did the damage from the game.

  • _ForgeUser7460379 posted a comment Aug 3, 2013

    So it occurs only with zombies that weren't spawned by Tribu, right ?

  • _ForgeUser7460379 removed a tag New Aug 3, 2013
  • _ForgeUser7460379 added a tag Waiting Aug 3, 2013
  • _ForgeUser2232722 posted a comment Aug 3, 2013

    @graindcafe: Go

    That is what it seems like during my testing. If somehow a zombie that wasn't spawned by Tribu gets into the area of the running Tribu game the error the above happens and the person is kicked out of the game.

  • _ForgeUser2232722 removed a tag Waiting Aug 3, 2013
  • _ForgeUser2232722 added a tag Replied Aug 3, 2013
  • _ForgeUser7460379 posted a comment Aug 3, 2013

    Okay thank you for your report. I'll fix this as soon as possible

  • _ForgeUser7460379 posted a comment Aug 3, 2013

    Sorry I can't reproduce the bug. I manage to hit or be hurted by a zombie or another mob and no bug appears.

    Are you using another plugin ?

  • _ForgeUser7460379 removed a tag Replied Aug 3, 2013
  • _ForgeUser7460379 added a tag Waiting Aug 3, 2013
  • _ForgeUser2232722 posted a comment Aug 3, 2013

    Yes we have some other plugins running. I'll some more testing to see exactly which is causing it and let you know

  • _ForgeUser2232722 removed a tag Waiting Aug 3, 2013
  • _ForgeUser2232722 added a tag Replied Aug 3, 2013
  • _ForgeUser7460379 posted a comment Aug 4, 2013

    Either it's caused by another plugin or give me a way to repeat the bug

  • _ForgeUser7460379 removed a tag Replied Aug 4, 2013
  • _ForgeUser7460379 added a tag Waiting Aug 4, 2013
  • _ForgeUser2232722 posted a comment Aug 4, 2013

    Like i said it is seemingly random, sometimes it will do it pretty quickly, other times not at all and sometimes it is a while in.

    The strange thing i wasn't able to replicate it on my local box with the copy of the world and all of the plugins and configs for them from our server, so i am clueless.

    Our list of plugins though is as follows: ChatManager Citizens2 Sentry Denizen CoreProtect Essentials EssentialsSpawn Gravestone HardcoreDeathBand Heads IP-Check JoinMessage NoCheatPlus NoEnderChest PermissionsEx Playtime PurpleIRC PvPTimer RaceTournaments ServerEvents Tribu 0.6.3 Vault WorldBorder WorldGuard WorldEdit

    In addition to the above issue there is times when the server will crash entirely. Here is the crashlog for that event: http://pastebin.com/WJrgJmW4

    Both of these issues occur on both CraftBukkit (Latest) and Spigot (Latest)

  • _ForgeUser2232722 removed a tag Waiting Aug 4, 2013
  • _ForgeUser2232722 added a tag Replied Aug 4, 2013
  • _ForgeUser7460379 posted a comment Aug 4, 2013

    @Kussie: Go

    Seems to happen while damaging the zombie with an arrow, according to the crash log

  • _ForgeUser2232722 posted a comment Aug 4, 2013

    Yep,

    That is what exactly was happening when the server crashed. They were from a premade package as well (I have it setup to strip the players of their gear when they join).

    So no idea why only sometimes hitting a mob with an arrow can cause it to crash.

  • _ForgeUser7460379 removed a tag Replied Aug 5, 2013
  • _ForgeUser7460379 added a tag Waiting Aug 5, 2013
  • _ForgeUser7460379 posted a comment Aug 10, 2013

    I need more information to solve this bug

  • _ForgeUser7460379 removed a tag Waiting Aug 10, 2013
  • _ForgeUser7460379 added a tag Replied Aug 10, 2013
  • _ForgeUser7460379 removed a tag Replied Aug 29, 2013
  • _ForgeUser7460379 added a tag Waiting Aug 29, 2013

To post a comment, please login or register a new account.