cant filter "joined with:" #15

  • New
  • Other
Assigned to _ForgeUser7441906
  • _ForgeUser9654954 created this issue May 7, 2013

    Ok, the plugin works well with the default filters, however when it comes to set up my own filter i fail badly. I have tried to filter a single line from the log containing "joined with:"

    complete line looks like this:

    2013-04-29 20:01:53 [INFO] FatPap joined with: [CodeChickenCore 0.5.3, MinecraftForge, NotEnoughItems, WorldEditCUI 1.2.5 for Minecraft version 1.2.5, ReiMinimap v3.2_04 [1.2.5], IC2 v1.97, IC2AdvancedMachines v4.0, BuildCraftCore 2.2.14, BuildCraftBuilders 2.2.14, BuildCraftEnergy 2.2.14, BuildCraftFactory 2.2.14, BuildCraftTransport 2.2.14, AdditionalPipes 2.1.3 (Minecraft 1.2.5, Buildcraft 2.2.14, Forge, ComputerCraft 1.33, RedPowerMachine 2.0pr5b2, ccSensors MC1.2.5 Build017pr1, CCTurtle 1.33, EE, EnderStorage 1.1.3, IC2NuclearControl v1.1.10, ImmibisCore 49.1.1, InvTweaks 1.41b (1.2.4), MAtmos_forModLoader r12 for 1.1.x, ModularForceFieldSystem rev7, IC2_ChargingBench 1.95b, CompactSolars 2.3.2, IronChest 3.8, RedPowerCore 2.0pr5b2, NetherOres 1.2.5R1.2.2, PowerConverters 1.2.5R1.3.4, Railcraft 5.3.3, RedPowerControl 2.0pr5b2, RedPowerLighting 2.0pr5b2, RedPowerLogic 2.0pr5b2, RedPowerWiring 2.0pr5b2, RedPowerWorld 2.0pr5b2, TubeStuff 49.1.2, Balkon's WeaponMod 1.2.5 v8.6.0, WirelessRedstoneCore, WirelessRedstoneAddons, WirelessRedstoneRedPower, ImmiChunkLoaders rev3.2]

    i tried this:

    - type: RegexFilter expression: '(.*)joined with:(.*)'  and
    - type: Partialfilter expression: 'joined with'

    and a bunch of other expressions without success
    I tried other log filter plugins and they also werent able to filter the line containing "joined with"
    The only plugin i found so far that is able to filter it is "TekkitRestrict" but its a bit of overkill just to have that installed only for filtering logs.
    However i was able to filter "lost connection" with partial filter with ThisLogMustDie or "connection reset", so the plugin is basically working.

    Thanks in advance

    ThisLogMustDie 1.0.1
    Tekkit 3.1.2

  • _ForgeUser9654954 added the tags New Other May 7, 2013

To post a comment, please login or register a new account.