Simple Sit 1.7 [Spigot/Bukkit 1.8.8 through 1.18]

Details

  • Filename
    SimpleSit.jar
  • Uploaded by
  • Uploaded
    Apr 24, 2022
  • Size
    19.20 KB
  • Downloads
    24,149
  • MD5
    540c76970873d5a8f3a10028cf654199

Supported Bukkit Versions

  • 1.18.2
  • 1.18.1
  • 1.18
  • 1.17
  • 1.16
  • 1.15
  • 1.14
  • 1.13
  • 1.12
  • 1.11
  • 1.10
  • 1.9
  • 1.8.1
  • 1.8

Changelog

It's been awhile... and I have decided that Simple Sit is suppose to be Simple... for now at least.

 

Thank you all for continuing to use Simple Sit despite it's stagnant state. It really means a lot. ♥

 

Removed the lay feature:

- Back in 2017, the lay command is something that I really wanted to add to Simple Sit. However, the actual implementation of the lay feature was a bit rushed; and due to the use of NMS code it required quite a bit of upkeep. Ultimately it caused errors and stress. It's part of the reason I let Simple Sit grow stagnant.

- The lay feature it self isn't complicated, and could probably even be implemented a lot simpler in newer versions of Minecraft. The problem is making a single plugin version work across a large range of Minecraft versions. This would require an abstraction/interface layer that would make Simple Sit a lot less Simple. It doesn't help that the flattening happened during 1.13 and in newer versions of spigot NMS code is obfuscated.

- I do really like the lay feature and would like to attempt it again (possibly make it into it's own plugin, Simple Lay?). However right now, I don't have the energy and the lay feature is doing a lot more harm then good to Simple Sit. So I have decided to remove it for now.

Removed Update Checker:

- I have decided that the update checker really isn't needed. At the time I added it because I thought it was cool.

- The implementation wasn't the best, and it could be done a lot better. Simple Sit is suppose to be Simple and doesn't need a feature like this... for now.

Compatibility:

- Added compatibility with newer Minecraft versions 1.13 through 1.18

- Works with Spigot/Bukkit versions 1.8.8 through 1.18.

- Not compatible with Minecraft versions 1.19 and above (see the update note blew) please use Simple Sit 1.7.1 for Minecraft 1.19 and higher.

 

If you had your hopes set on a updated lay feature and/or would like me to revisit the lay command, please let me know... and I'll see. :)

Until then, you can continue to use the lay feature in Simple Sit version 1.6.3 on the spigot page. However, I'm pretty sure it only works for Spigot versions 1.8.8 through 1.12 and it is unstable at times.

 

Update (May 2nd, 2023)

  • It has been brought to my attention that a severe bug occures when Simple Sit 1.7 is paired with Minecraft versions 1.19. This bug breaks the seat dismounting function and allows players to essentially use their sitting location as a "waypoint" to teleport back to when they use the /sit command to unseat. This bug has been fixed in Simple Sit 1.7.1 so please use newer versions of Simple Sit with Minecraft versions 1.19 and above.