v2.9.1

Details

  • Filename
    Shopkeepers-2.9.1.jar
  • Uploaded by
  • Uploaded
    Jan 22, 2020
  • Size
    872.55 KB
  • Downloads
    10,693
  • MD5
    092a0a330af0afe0ea43aa5bed6702c4

Supported Bukkit Versions

  • 1.15
  • 1.14

Changelog

v2.9.1 for MC 1.15.2, 1.14.4

 

Migration notes: Before updating, make a backup of your save.yml file just in case something goes wrong.

Update for MC 1.15.2:

  • Bumped CraftBukkit dependency for MC 1.15 to 1.15.2.
  • Changed: Replaced the NMS call for setting the CanJoinRaid property on MC 1.15.x with a corresponding Bukkit API call. This fixes compatibility with Spigot 1.15.2, but only works on the very latest versions of MC 1.15.1 and upwards.

Other changes:

  • Added: Warning messages when a trading offer cannot be loaded for some reason.

  • Changed: Trading offer and hire cost items get automatically migrated to the current data version now.

    • This will typically occur with every (even minor) minecraft updates.
    • A warning is logged if an offer can not be migrated.
    • Minecraft may log 'Unable to resolve BlockEntity for ItemStack ...' messages during ItemStack migrations. You can safely ignore these debug messages.
    • Config/Debug: Added debug option 'item-migrations' to log whenever a shopkeeper performs item migrations.

Known potential issues: See here.

Donations

If you like this plugin, consider making a donation.

Thanks!

Thanks to all donations since the last update:

  • EmeraldHaze (Ninjalette)