Can't get my scrolling menu's to scroll or exec... #19

  • Defect
  • Accepted
Assigned to desht_08
  • desht_08 created this issue Feb 5, 2012

    Can't get my scrolling menu's to scroll or execute.

    I'm using CB 1.1-R3, ScrollingMenuSign v1.1.1, Essentials Core, ChopTree, Lift-7, NoLagg, and SignThatChest-1.8. I have the RedPower, Buildcraft, ModLoader MP, and Minecraft Forge Bukkit ported mods.

    Both my girlfriend and are OP's but neither one of us can make the signs do anything beyond being setup. I'm not using a permission plugin and would like to avoid that fiasco for as long as possible.

    I used this plugin a while back and loved how easy and powerful it was, I greatly appreciate any help.

  • desht_08 added the tags Accepted Defect Feb 5, 2012
  • desht_08 posted a comment Feb 6, 2012

    Not able to reproduce the problem at this point.

  • sullytheunusual posted a comment Feb 6, 2012

    I'm having the same problem. Using GroupManager for perms, but won't work for Ops, even when adding the nodes. I tried "/sms debug" and it's telling me allowed=false for scrolling and executing. I've tried adding scrollingmenusign.* and scrollingmenusign.admin. I even set scrollingmenusign.execute and still says allowed=false.

    ::UPDATE:: I updated to the latest GroupManager build, and everything works now! :)

    Edited Feb 8, 2012
  • _ForgeUser953413 posted a comment Feb 7, 2012

    I'll download 1.1.1 again. Something that might be of note that I didn't realize before, we are directly under the spawn point, within the same chunk, and I haven't tried to set up a scrolling sign outside of it yet. I'm gonna test it right now.

    Edit: Would it be better for me to get 1.1.1 or 1.1.3?

    Edit2: Just tried with 1.1.3, moved away from the spawn point by quite a bit. Unable to scroll or execute.

    Edited Feb 7, 2012
  • desht_08 posted a comment Feb 7, 2012

    @rokugin: Go

    Get 1.1.3 - although I don't think it will affect your particular problem, it does contain various other bugfixes which are worth having.

  • desht_08 posted a comment Feb 7, 2012

    @disciple218: Go

    I haven't done any GroupManager testing, but I will do so when I get a chance.

  • _ForgeUser953413 posted a comment Feb 7, 2012

    I setup GroupManager and it's working now, if you can think of anything else I can do to test this with just OP's I'll be glad to pull GM to do so. On that note, it doesn't seem to matter where the sign is, works fine in the spawn chunk.

    If you can't recreate the issue then it's fine, I am using a lot of non-standard crap right now lol. Thanks for the help and the great plugin!

    Edited Feb 7, 2012
  • desht_08 posted a comment Feb 7, 2012

    @rokugin: Go

    Yeah, PEX seems to like doing things its own way. Unfortunately far too many people use it, but I'm still very tempted to just say "PEX is not supported" :) Bukkit itself needs to take part of the blame too, for a way-too-vague specification of how superperms parent-child node relationships work.

    Seriously though, I am considering a complete permissions rewrite for the next major SMS release - it would be less flexible, but hopefully a lot more reliable.

  • sullytheunusual posted a comment Feb 13, 2012

    I am experiencing this phenomenon, too. Signs are becoming unresponsive. I used the "/sms list" command, and it's saying there are 0 views. The text on the sign remains, but it would seem SMS no longer remembers them.

  • desht_08 posted a comment Feb 13, 2012

    @disciple218: Go

    That sounds like a completely unrelated problem, to do with saved view data not reloading properly. Please open a new ticket, and attach a zipped up copy of your plugins/ScrollingMenuSign folder (and let me know which menu(s) aren't working any more). Also check for any errors in the server startup log related to ScrollingMenuSign.

  • _ForgeUser7956475 posted a comment Aug 9, 2012

    Is it still an issue using SMS with Pex?
    I tried SMS today and get the same problem. using CB 1.3.1-R1.0, Pex 1.19.3 and SMS 1.5.0.

    Curious to know if this is the problem before I spend hours converting to GroupManager.

  • _ForgeUser7956475 posted a comment Aug 9, 2012

    Yes, it is still an issue is the answer after a couple of testruns with GM. Time to learn how GM works...

    Edited Aug 9, 2012
  • desht_08 posted a comment Aug 10, 2012

    Switching away from PermissionsEx is probably the right choice :) But if you do have trouble with scrolling/executing etc., the best course action is to enable some debugging, and post the results. Do /sms set log_level fine, and /pex debug, then try to scroll and/or execute something. You can do /sms set log_level info afterwards to disable debugging.

To post a comment, please login or register a new account.