Mo' Creatures incompatibility #49

  • Accepted
  • Defect
Assigned to timvisee
  • _ForgeUser9080536 created this issue Jun 23, 2013

    What steps will reproduce the problem?
    1. Install MCPC-1.5.2
    2. Install Mo' Creatures mod
    3. Install SafeCreeper plugin

    What is the expected output? What do you see instead?
    Lots of exception messages appear in the server log:

    What version of the product are you using?
    SafeCreeper v1.5.0.1
    DrZharks MoCreatures Mod v5.2.3

    Do you have an error log of what happened?

    2013-06-23 11:45:06 [SEVERE] Could not pass event CreatureSpawnEvent to SafeCreeper v1.5.0.1
    	at org.bukkit.plugin.RegisteredListener.callEvent(
    	at org.bukkit.plugin.SimplePluginManager.fireEvent(
    	at org.bukkit.plugin.SimplePluginManager.callEvent(
    	at org.bukkit.craftbukkit.v1_5_R3.event.CraftEventFactory.callCreatureSpawnEvent(
    	at drzhark.customspawner.CustomSpawner.doCustomSpawning(
    	at drzhark.mocreatures.MoCServerTickHandler.onTickInGame(
    	at drzhark.mocreatures.MoCServerTickHandler.tickEnd(
    	at cpw.mods.fml.common.SingleIntervalHandler.tickEnd(
    	at cpw.mods.fml.common.FMLCommonHandler.tickEnd(
    	at cpw.mods.fml.common.FMLCommonHandler.onPostServerTick(
    	at net.minecraft.server.MinecraftServer.func_71217_p(
    Caused by: java.lang.ArrayIndexOutOfBoundsException: 76
    	at com.timvisee.safecreeper.listener.SCEntityListener.onCreatureSpawn(
    	at sun.reflect.GeneratedMethodAccessor28.invoke(Unknown Source)
    	at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
    	at java.lang.reflect.Method.invoke(Unknown Source)
    	... 15 more

    Please provide any additional information below.
    MCPC 1.5.2:
    Mo' Creatures mod:

  • _ForgeUser9080536 added the tags New Defect Jun 23, 2013
  • timvisee posted a comment Jun 28, 2013


    I'm sorry, but MCPC is not supported for Safe Creeper, because it is impossible to support it from a Bukkit plugin. I've tried to solve the issue tough, but I'm not sure if it's working. You should try it out yourself. I've tried to fix this in version 1.5.1 (not!) and I expect to release this version very soon.

    Tim Visée

  • timvisee removed a tag New Jun 28, 2013
  • timvisee added a tag Accepted Jun 28, 2013

To post a comment, please login or register a new account.