How to use password protectton? #107

  • New
  • Defect
  • _ForgeUser12352323 created this issue Oct 9, 2013

    What steps will reproduce the problem?
         1. Create Region
         2. Prevent-entry set to true
         3. set password to test
         4. use password to true

    What is the expected output? What do you see instead?
         1. If another player now trys to get into that region a message shows up: Authentication required! Do /regios auth <password>
         2. The player now types: /regios auth test
         3. A message shows up: You must first try to enter a region before authorising yourself.

    What version of the product are you using?
         Regios Version: 5.9.9
         Craftbukkit Version: 1.6.2

    Do you have an error log of what happened?

    Please provide any additional information below.
         The question is now am i missing some permissions that the player cant use the command /regios auth <password>
         or is this just a bug?

         The other thing i noticed is in the DefaultRegion.config you can change the Messages. I translated them into german.
         All messages have been translated into german but PasswordMessage not.
         It seems that this part of the config is probably not beeing read.
         Anyways i uploaded my DefaultRegion.config

    This plugin is just awesome. Hopefully you can help me or fix this bug as soon as possible =)
    Thank you very much.

  • _ForgeUser12352323 added the tags New Defect Oct 9, 2013
  • _ForgeUser12352323 added an attachment DefaultRegion.config Oct 9, 2013


    <p>My DefaultRegion.config with german messages</p>

  • _ForgeUser12352323 posted a comment Oct 9, 2013

    Damn it, i misspelled protection in the topic.
    maybe you could change that for me ;)

    But there is something more i found out.
    When i set a password for a region, player cant get in because of this error i explained..
    But when i disable password protection player still get the message to login.

    They still get the message after typing /regios reload.
    The only way to make player go into my region again is to reload the server.

    All in all something is really wrong with this password protection :-D

    Edited Oct 9, 2013

To post a comment, please login or register a new account.