[v3.0.0]

Details

  • Filename
    PvPToggle.jar
  • Uploaded by
  • Uploaded
    Nov 20, 2012
  • Size
    46.12 KB
  • Downloads
    65,697
  • MD5
    b9ab3ab629f3aa45a712cb041ed1b8b1

Supported Bukkit Versions

  • CB 1.4.5-R0.1

Changelog

v3.0.0:
- Created PvPCommand architecture
- Broke away command handling into separate classes per command extending PvPCommand class
- Established internal region management, worldguard regions must now be tagged in PvPToggle
- Added global worldguard integration option in configuration file
- Added region command
- Fixed NPE from player with forced or denied PvP not getting added to player pool on log in
- Fixed enter region message and added exit region message
- If a localisation message is blank, the message will no longer be displayed

Citizens integration requires Citizens 2.0 or above.
WorldGuard integration requires WorldGuard 5.2 or above.