OpenInv 4.0.1

Details

  • Filename
    OpenInv.jar
  • Uploaded by
  • Uploaded
    May 18, 2019
  • Size
    125.30 KB
  • Downloads
    2,873
  • MD5
    45bfa87d80bb7c4e899fc98bb02c1970

Supported Bukkit Versions

  • 1.14
  • 1.13
  • 1.8

Changelog

  • Updated to 1.14.1
    • 1.14 is no longer supported

From the 1.14 update issue:

"While going through the update process, it occurred to me at several points that my life would have been made significantly easier by being able to access Java 8 features. I'll be releasing one last version with full backwards compatibility. After that, OpenInv will be dropping support for Java versions <8. With that, I also see no reason to continue to maintain support for such a huge quantity of outdated versions.

 

When I took over maintaining OpenInv, there were enough dupe bugs and longstanding issues to warrant backporting bugfixes to older versions, but at this point it's just a barrier that prevents other developers getting involved. I plan on maintaining only 1.8.8 and whatever happen to be the latest 2 major revisions at the time. In the future, OpenInv will require the current Minecraft release's minimum Java version, despite what older supported versions may allow."

 

If you are using a version of Minecraft other than 1.8.8, 1.13.2, or 1.14.1, the last build supporting all versions can be found here. For 1.14, the primary download from 4.0.0 will work.