$mulitargs spitting out a previously used argument. #157

  • Defect
  • demon2749 created this issue Dec 3, 2017

    According to the MyCommand's example page:

    Make a command shortcut with $multiargs :

    The $multiargs code, gets all arguments typed in a command. If you don't need put "$arg1,ecc"in a specific position, use it.

     command: /s
     type: RUN_COMMAND
     - /say $multiargs

    Eventually, you can put the $multiargs after some $arg's. Example:

     - /myban name:$arg1 reason:$multiargs

    In this way, $multiargs prints only the arguments typed after $arg1.



    Unfortunaly, it still prints out $arg1 in $multiargs, resulting in:

    /myban dragonlord1122 griefing my house


    - "[BAN] $arg1 was banned for $multiargs"


    [BAN] dragonlord1122 was banned for dragonlord1122 griefing my house


    I've tried replacing $multiargs with individual arguments, but if the arguments arn't used, it prints the "$arg#" out...



  • demon2749 added a tag Defect Dec 3, 2017
  • Digital_Beast posted a comment Mar 26, 2019

    Got the same issue, wondering if its solved yet?   Server version 1.12.2Spigot, and Mycommand Version 5.3.4

  • ivanfromitaly posted a comment Apr 24, 2019

    Can post here some examples where this isn't working as intended? Cause in normal circumstance it works fine for me. If you use $multiargs in a TEXT type command or $text$ line, it doen't work, because isn't implemented it here. But, the example here above works fine for me.

To post a comment, please login or register a new account.