HeavySpleef v2.4

Details

  • Filename
    HeavySpleef.jar
  • Uploaded by
  • Uploaded
    Jun 18, 2016
  • Size
    3.77 MB
  • Downloads
    475
  • MD5
    954976be56fe94216bafdd7f18cc1f43

Supported Bukkit Versions

  • 1.10
  • 1.9
  • 1.8

Changelog

HeavySpleef 2.4

HeavySpleef 2.4 is now available and adds full support for Spigot/CraftBukkit 1.10. There are also a bunch of new features and bugfixes which are rolled out by this update.

Changelog:

New features:

  • Adds full support for Minecraft 1.10
  • Players in the lobby are now in adventure gamemode
  • Making the spectator and the lobby mode more configurable: You can now enable pvp and show the scoreboard if the corresponding flag is enabled
  • Added a game status motd for the BungeeMode addon
  • Added configuration options to modify the velocity and cooldown of egg shots (Splegg)
  • Added a warmup mode to prevent invisibility glitches
  • New flag auto-queue: Automatically re-join the queue when the game ends
  • Added a sub-flag for the WinCommand addon win-command:probability which specifies the probability that a win command is being executed for a certain place
  • Added a configuration option to define the sql connection timeout in the database configuration (needs to be resetted to use)

Bugfixes:

  • Fixed an error which sometimes occured on game end (Can't drop air)
  • Prevent crafting of snowblocks when the snowballs flag is enabled
  • Remove players from the queue if they die
  • Fixed a typo in the start sign permission
  • Prevent players in spectate mode to pickup/drop items
  • Fixed a bug which caused the server to crash when adding a lobby-wall
  • Fixed a bug where players which join the game while in countdown are not propertly freezed if the corresponding flag is set
  • Fixed a server crash which happened when removing sub-flags
  • Fixed an annoying exception which occured when removing a podium

Note: This version is compatible with CraftBukkit/Spigot 1.7, 1.8, 1.9 and 1.10 and requires an installation of Java 7 or above. This version does not support servers running on Minecraft 1.6 or below.