GlobalMarket 2.0.0.28 Beta

Details

  • Filename
    GlobalMarket-2.0.0.28.jar
  • Uploaded by
  • Uploaded
    Mar 11, 2016
  • Size
    1.14 MB
  • Downloads
    15,788
  • MD5
    529b4c2e6b30f47aa846b48b678330fb

Supported Bukkit Versions

  • 1.9
  • 1.8
  • CB 1.7.2-R0.1

Changelog

Hopefully the last beta release. This is a quick update to fix listing creation via command.


Please note before installing this version: it does NOT import items from 1.X versions. Delete your config file before installing.


GlobalMarket 2.0.0 and up now requires ProtocolLib to be installed. Please install it before trying to install GlobalMarket.
For 1.8/1.9, use this build. For 1.7.10 (including Cauldron/Thermos) use this build. GlobalMarket no longer supports 1.6.4 or below.


  • General CommandHandler improvements, supports sudo type commands again
  • A listing creation command was added
  • 1.9 fixes
  • Fixed a dupe bug where if a player had, say 120 out of 128 items in a stock slot, inserting more items into a separate slot would not remove the difference from the player's cursor
  • Importing from JSON to Redis
  • Protection against InventoryTweaks bypassing Bukkit events
  • Protection against removing a mod with its items listed on the Market, or save failures in general


It's missing a few things from the 1.X version which will be added again in time:

  • Stalls
  • History and price history
  • Multi-world support
  • Filtering and searching
  • Permission-based restrictions like number of listings or stock slots

Requires Java 7 or later