Unable to use Command Sign due to multiple groups? #120

  • Defect
  • Accepted
Assigned to _ForgeUser9042228
  • _ForgeUser10518432 created this issue Mar 29, 2013

    What steps will reproduce the problem?
    1. Create promotion sign
    2. Make sure you have designated group to be promoted from, and another random group from some other tree. I.E: Ingame rank & Donation rank
    3. Attempt to promote to next ladder in Ingame rank

    What is the expected output? What do you see instead?

    I expect my Ingame rank to progress up to the next level, and keep my Donator and Owner/OP status.
    What I see, I am not allowed to use this sign and no group "promotion"

    What version of the product are you using?


    Do you have an error log of what happened?


    Please provide any additional information below.

    I have set up a Command Sign to promote players from our default group to the next rank in our ingame cash ranks. I made sure that the command would be allowed to be run as an OP as normal players cannot use the add/remove group commands anyway. But I am an OP and attempted to use this sign anyway...

    /cmds 1 @dwarf
    /cmds 2 $1
    /cmds 3 ^/(add group command)
    /cmds 4 ^/(remove oldgroup command)

    (I cannot recall if the ^ is correct or if it's supposed to be before or after the / but I made sure to follow and copy the examples provided. So please dont' tell me those are misplaced on lines 3&4.. I cannot recall where they go.)

  • _ForgeUser10518432 added the tags New Defect Mar 29, 2013
  • _ForgeUser10518432 posted a comment Mar 31, 2013

    Someone please respond? These signs are the only thing completely preventing me from doing our planned big release on the server. Our players have been asking for this for some time now...

    Edited Mar 31, 2013
  • _ForgeUser10518432 posted a comment Apr 2, 2013

    it's been almost a week now, could I at least get a "we're looking into it" or something!?

  • _ForgeUser9042228 posted a comment Apr 4, 2013

    I don't even play Minecraft anymore, chill.

    Is this with PEX? If so, there are promote and demote commands that can help simplifying this.

    Try this:

    /cmds 1 @dwarf
    /cmds 2 $1
    /cmds 3 /*(add group command)
    /cmds 4 /*(remove oldgroup command)
    /cmds 5 --

    Line 5 closes the two restriction blocks.

    If this doesn't work, I'm going to need to see what line 3 and 4 actually are.

  • _ForgeUser10518432 posted a comment Apr 4, 2013

    @CJxD: Go

    This is with PermissionsBukkit... But I will give this a try.

  • _ForgeUser10518432 posted a comment Apr 5, 2013

    I attempted to use this way but I got the same "This sign is not allowed to socialize with people like you"

    /cmds 1 @default
    /cmds 2 $1
    /cmds 3 /*/permissions player addgroup <name> Dwarf
    /cmds 4 /*/permissions player addgroup <name> Default
    /cmds 5 \You have been promoted to Dwarf!
    /cmds 6 --

    I even had a regular player try, as well as one of my donator ranks. I also made sure the permission node to use the signs was there. Even though you mentioned in comments that it was enabled by default. I wanted to make sure I covered my basis. :\

    I know it's not because my players are part of other groups too, because I had someone who was only part of the Default group try it too. x.x

    Since the signs aren't even working as of right now for my players or myself.... When I apply the * to the line, do I continue to write the command with the / like I have above or is that UN-nessassary/will break it?

    Edited Apr 5, 2013
  • _ForgeUser9042228 posted a comment Apr 5, 2013

    @sakura_blades: Go

    Hmm, in which case this is probably an issue with Vault. Update Vault and see if it still happens.

    Also, it's '/*perm...' rather than '/*/perm...'

  • _ForgeUser9042228 unassigned issue from _ForgeUser7307234 Apr 5, 2013
  • _ForgeUser9042228 self-assigned this issue Apr 5, 2013
  • _ForgeUser10518432 posted a comment Apr 5, 2013

    I have looked all over the place for perhaps a Dev Build of Vault since I seem to have the latest approved release... I did not find one, so I am going to assume I have the latest Vault and it cannot be updated... :\

    So, if it's not Vault?

  • _ForgeUser9042228 posted a comment Apr 6, 2013

    @sakura_blades: Go

    Try CommandSigns v1.8.7 - if at all possible - as 1.8.8 had changes to the group permission checks:

    "Group checks now check explicitly as they used to - inherited permission groups will no longer result in a match."

  • _ForgeUser10518432 posted a comment Apr 6, 2013

    @CJxD: Go

    I cant' even find where to get 1.8.7... carried on with these changes? So my mutli-group players aren't working with this? :(

  • _ForgeUser10518432 posted a comment Apr 7, 2013

    So I found 1.8.7 from what looked like some Russian website...

    When I try to use the sign I get a different message now, "You are not in the required group to run this command."

    I have tried with both the * and the ^ in the command lines.

    I am part of Default group still, I also still have the Owner group too though...

    Edited Apr 7, 2013
  • _ForgeUser10518432 posted a comment Apr 7, 2013

    Okay so instead of going with the @group at the top of my command signs, I've switched to the permission node method. &node. I gave a true node to the group I wanted to be able to use it and made it negative for the group above it. Regular players needed the line to be /^command rather than /*command for it to work. And

    This method worked with 1.8.7 so I decided to try it with the latest release of CommandSigns too. All seems to be working fine, however when I tried it with I got a different message after trying it a second time after already progressing to that group.

    1.8.7 CMDS I got "You do not have permission to do that." CMDS I got "This sign is not allowed to socialize with people like you."

    I have made no changes to the sign since I switched the versions back to CMDS and I could change the message I get out of the latest release, but do you have any idea why the change?

    I figured I'd let you know that it is possible to work around the multi-groups in this fashion, for future reference of course.

    Edited Apr 7, 2013
  • _ForgeUser9042228 posted a comment Apr 9, 2013

    @sakura_blades: Go

    Sorry, I've been busy this weekend. The messages were changed to passive-agressive/sarcastic for v1.9.0, thus the change.

    Remember that you can mask permission restriction messages to users by using ?&node and ?@group syntax.

    I'll look out for your particular group issue in CommandIt.

  • _ForgeUser9042228 removed a tag New Apr 9, 2013
  • _ForgeUser9042228 added a tag Accepted Apr 9, 2013
  • _ForgeUser10518432 posted a comment Apr 10, 2013

    @CJxD: Go

    Okay, thank you CJ!

    All seems to be running just fine now, so I think I can handle it from here. If something goes wrong and I can't find a way to to fix it I'll write another ticket.

To post a comment, please login or register a new account.