Barriers don't work (1.8) #262


  • Defect
  • Replied
Open
Assigned to xsmethsx
  • _ForgeUser23118253 created this issue Apr 12, 2016

    What steps will reproduce the problem? 1. Set up an arena with spawn points for zombies 2. Make a 2x2 barrier and select the spawn point behind it 3. Enable and play the arena.

    What is the expected output? What do you see instead? Zombie(s) should break the entire barrier down, but instead only break down one block.

    What version of the product are you using? v1.2.6 (1.8.4 & 1.8.6) Server is running server is running 1.8.8 Spigot.

    Do you have an error log of what happened? No error logs

    Please provide any additional information below.

    I have the arena setup and the zombies refuse to break the barriers I set. I've tried glass and fence. 99% of the time, nothing happens. But the 1% of the time, they'll break 1 block of the barricade then stop.

  • _ForgeUser23118253 added the tags New Defect Apr 12, 2016
  • xsmethsx posted a comment Apr 13, 2016

    Can you confirm this is still an issue in V1.2.7 once it is approved, thankyou :)

  • xsmethsx removed a tag New Apr 13, 2016
  • xsmethsx added a tag Waiting Apr 13, 2016
  • _ForgeUser23118253 posted a comment Apr 13, 2016

    @smeths: Go

    I tried installing your new update, and it claims it's 1.2.6 still and not 1.2.7. I've tried the jar from here (BukkitDev) and the link in the console. Each time, it claims it's 1.2.6, and /plugman info COM_Zombies tells me the same thing. Here's the console output after a restart with the "updated" jar:

    [Server] INFO [Zombies] You currently have version: 1.2.6 and the current version fro COM:Z is verion: 1.2.7
    [Server] INFO [Zombies] Get the latest version of COM:Z here: http://servermods.cursecdn.com/files/915/311/comz.jar
    

    Also now apparently I'm getting kicked with a java.lang.IndexOutOfBoundsException. I don't know if it's related to the plugin or not, but it only happens once the zombies begin spawning. I'll see if I can track it down.

  • _ForgeUser23118253 removed a tag Waiting Apr 13, 2016
  • _ForgeUser23118253 added a tag Replied Apr 13, 2016
  • xsmethsx posted a comment Apr 13, 2016

    @alexahmae: Go

    I must've made a mistake somewhere, I'll take another look through the code today and see what I can do about it. also, as to the version number, I must have forgot to change it in the plugin.yml :P


To post a comment, please login or register a new account.