v2.9.16

Details

  • Filename
    bpermissions.jar
  • Uploaded by
  • Uploaded
    Aug 23, 2012
  • Size
    151.77 KB
  • Downloads
    319
  • MD5
    bfe55214845d3ceb1fc89981a1a5e578

Supported Bukkit Versions

  • CB 1.3.1-R2.0

Changelog

Shifted updating to a sync task in order to avoid concurrent modification exceptions

Lots more reflection and hackery in order to get superperms to observe expected behaviour while still being fast!
PLEASE TEST FOR ME

Added config.yml switch for more restrictive promotion tracks (and added dinosaurs) for @Kainzo

Fix for issue of players not updating permission set on setting groups

Fix for issue 374 - removed setupPlayer call from calculatedEffectivePermissions to prevent stackOverflow on rare occasions. http://dev.bukkit.org/server-mods/bpermissions/tickets/374-stack-overflow-when-making-changes/

Fix new APILayer method not calculating effective values correctly (sorry folks)

Fix for bukkit bug on PlayerLoginEvent

Fix for issue 370 - http://dev.bukkit.org/server-mods/bpermissions/tickets/370-crazy-multigroup-issue-again/#comments

Fix for issue 369 - http://dev.bukkit.org/server-mods/bpermissions/tickets/369-multiple-groups-seem-not-to-act-properly/

Included a console (/permissions debugperms) and a hopeful fix for the horrific issue in previous versions

A fix for the issue of permissions not being applied correctly (hopefully) please test and report - it works on my system ;)

** 15/07/2012 2.9.9 ** multigroup queries are now ordered by priority

YamlPreparser upgrade

New exec commands documented on main page (dead simple 1 line commands for common operations, yay!)

Added custom_nodes.yml for providing custom permission nodes!

Groupmanager importing added

A few NPE's fixed

(a fix for 2.9.7 upload not working)

(a hopeful fix for the replicatig ^ node issue)

BACKUP ALL PERMISSIONS FILES BEFORE UPGRADING YOUR BPERMISSIONS!
"/permissions backup" command does this for you
THERE MAY BE A BUG WE DID NOT FIND IN OUR TESTING, IF THIS IS THE CASE, REPORT IT AND WE WILL FIX IT FOR YOU!

THIS RELEASE WILL BREAK PLUGINS THAT RELY ON THE OLD BPERMISSIONS API

THIS RELEASE WILL NO LONGER SUPPORT THE PERMISSIONS 2 BRIDGE

THIS RELEASE WILL NOT WORK WITH PLUGINS THAT RELY ON THE OLD BPERMISSIONS API

DO NOT UPDATE UNLESS YOU ARE SURE ALL YOURS PLUGINS ARE UP TO DATE

THIS RELEASE MAY BREAK YOUR EXISTING PLUGINS

THIS RELEASE REMOVES ALL LEGACY API SUPPOR