WarpSigns is a simple that I made and allows you to create a sign that when is right clicked teleports you to the warp. This works with any plugin that use /warp.

I will now only be taking issue's via the TICKET SYSTEM ONLY! If there is already a ticket with the same issue then UPVOTE it!

  • New Update Now Supports 1.6.4 and below*

Per Sign Permissions:

The latest version allows you to have per sign permissions, for example you want some players to access some signs but not other simply add {<Permission>} on the 4th line of your sign and it then requires them to have the permission WarpSigns.use.<Permission> or WarpSigns.use.*. You are not required to use per sign permission, simply dont add it and use it like normal.


WarpSigns.create - Allows players to create a Warp Sign
WarpSigns.use - Allows players to use a Warp Sign
WarpSigns.use.* - Allows players to use all signs with per player permission

Creating WarpSigns

Line 1: [Warp]
Line 2: [WarpName]
Line 3: [Blank]
Line 4: {<Permission>} - Not Required, Read the per sign permission section.

Example Sign

This example sign will teleport them to /warp AdminHouse
Line 1: [Warp]
Line 2: AdminHouse
Line 3: [Blank]
Line 4: {AdminHouse}
To use this sign users will require WarpSigns.use & WarpSigns.use.AdminHouse

Video: Installing & Usage


If you have any issues or bugs here is how you can resolve them:

  • PM me on BukkitDev or the Forums
  • Use the issue tracker up the top of this page

You must login to post a comment. Don't have an account? Register to get one!

  • Avatar of ActuallyTex ActuallyTex Oct 22, 2016 at 18:25 UTC - 0 likes

    @Zombomb333: Go

    Use wand and right click + click the block that the sign is placed on and then do set air.

    This should remove the sign. You probably are long far from already either figuring this out or just have stopped creating your server entirely. Here's the response if anyone else is having this issue/question.

  • Avatar of Zombomb333 Zombomb333 Feb 06, 2016 at 07:05 UTC - 0 likes


  • Avatar of Davis2009 Davis2009 Jun 27, 2015 at 05:02 UTC - 0 likes

    No matter what I do I it says I don't have permission! Only works if im op. Im using pex and tried all different ways.

  • Avatar of GeminiJupiter GeminiJupiter May 29, 2015 at 20:12 UTC - 0 likes

    @KristinaP1101: Go

    Hey Kristina, have you added the actual permission? If not here it is


    Owner of the GeminiJupiter Minecraft Server mc.geminijupiter.com

  • Avatar of phentop phentop May 18, 2015 at 16:28 UTC - 0 likes

    Is there a way to set a warp point if I don't use essentials? I don't see it listed as a required plugin.

  • Avatar of ConstipadedNinja ConstipadedNinja Apr 17, 2015 at 02:33 UTC - 0 likes

    hi I need help I can use the warp sign when im op but when im not op I cant use it I hit it and it says nothing im on 1.8.3 please respond my server is ready to go i just need help with this plugin thanks

  • Avatar of KristinaP1101 KristinaP1101 Apr 05, 2015 at 20:11 UTC - 0 likes

    Hello, I recently got this plugin for my 1.8 server and it works great. There were no problems up until a member tried to make a regular sign, with no [Warp] or other commands from other plugins on the sign. I believe the only thing it said on it was "R.I.P." When they tried to write the sign, it gave them an error that read "[WarpSigns] You don't have permission to do that!" I searched all over, but no one else seems to be having this problem. Please respond ASAP! -Kristina

  • Avatar of NerfedToStone NerfedToStone Nov 22, 2014 at 20:46 UTC - 0 likes

    I got a problem with permission on the signs. I got AreaGuard as my area protect plugin but my warp signs dont work. When i only write [Warp] Spawn

    It works for owners in the area+mods. But if i add the {<Permission>} no one can click it. I dont know if its a bug or AreaGuard dont support WarpSigns but if anyone know anything please let me know.

  • Avatar of JayServers JayServers Oct 14, 2014 at 20:27 UTC - 0 likes

    Can U please update this plugin til 1.7.9 as It very useful but its dosn't work for 1.7.10 servers

  • Avatar of porpeak42 porpeak42 Sep 13, 2014 at 09:29 UTC - 0 likes



Date created
Jul 03, 2012
Last update
Dec 10, 2013
Development stage
  • enUS
GNU General Public License version 3 (GPLv3)
Curse link
Recent files