Why can't people build?

    #1 Dec 11, 2012 at 22:57 UTC - 0 likes

    I have a server that and I am working on the permissions, at the moment people can't build and I can't figure our why.Here is my yml file.Please help.

    #2 Dec 12, 2012 at 02:21 UTC - 0 likes

    I too am having with PEX and building not being able to build, its like the modifyworld is just not working at all, people cant break, build, eat, interact with mobs, and they cant take damage or talk either, but i have all the right permission nodes, it broke shortly after bukkit 1.4.5

    Last edited Dec 12, 2012 by zarakh01
    #3 Dec 12, 2012 at 02:24 UTC - 0 likes

    Also it has to be the permissionEX plugin, because i removed all my plugins to find out what it was, then slowly started installing them again, i installed worldedit, then worldguard, and when i got to PEX everything stopped working, no chat, no opening doors, or breaking blocks.. Here is my permissions YML file.

    It has permissions for other plugins because they were the ones i had on before i removed them all.

    Last edited Dec 12, 2012 by zarakh01
    #4 Dec 19, 2012 at 19:34 UTC - 0 likes

    Jordan, in your case, I'm betting that it's essentials blocking things. You might want to look into adding a build: true line to your permissions like what zarakh01 has

    Zarakh01, I don't see any problems with your permissions at a quick scan. What errors, if any, are showing up when a player tries to place a block?


    #5 Mar 05, 2013 at 20:12 UTC - 0 likes

    I'm having the same problem, i added build: true nothing happened? This is quite annoying now, how do you make a single person build on the server?!

    #6 Mar 10, 2013 at 19:12 UTC - 1 like

    Same with me my server is fine and all the permissions are sorted out but players cat build or brake or pick up or interact which is sooooo annoying for me

    yay i added a build: true/false and now it works gusy when you do it don't put a capital b and after bui: put a space then true hope this help xxx =)

    Last edited Mar 11, 2013 by natashashugnasta
    #7 Mar 10, 2013 at 22:31 UTC - 0 likes

    @bacon_avenger: Go

    I tried this, i tried everything permissions was going perfect, this is actually making me and my server very mad. My players can't pick up items talk or build or break and there build is on true i checked the essentials folder and i did all the build permissions, I just really need some answers or i'm going to find a new rank plugin. thanks.

    #8 Mar 17, 2013 at 03:04 UTC - 0 likes

    My Solution

    (Assuming your using Essentials)

    The permission node*

    #9 Mar 20, 2013 at 21:36 UTC - 0 likes

    @zarakh01: Go

    Okay everyone, I am having trouble with people breaking blocks on my server. When people are not op, they cannot break blocks nor build. It says they can't interact with blocks or "You do not have permission to interact with Stone Pickaxe" or something. I am also having trouble with Group Manager. I put everything I want in the groups.yml and the gloabalgroups.yml but when I promote someone, or demote, it doesn't say anything like this: [Owner]MrHappySmiley: and then what I want to say. Please help me.

    #10 Mar 20, 2013 at 21:37 UTC - 0 likes

    Man, this is frustrating. All I need is some help. Key word: help.

    #11 Mar 30, 2013 at 07:56 UTC - 0 likes

    Next time, post in the Permissions Section. That is where I usually roam nowadays to try and help people.
    Now on to fixing your permissions. I will need to see your permissions file before I can fix it.
    So if you can upload that, than it would be great.

    Before you upload on here, some questions.
    Do you have ModifyWorld installed with PEX. If so, then make sure your groups have "modifyworld.*" in their permissions.
    Do you have GroupManager and PermissionsEx installed at the same time? If so, STOP! They don't work well at the same time together. They break one another and have a fight over who gets to handle permissions. And then once they finish fighting, they both drop the issue and don't even bother with permissions of your server.

    Was my post helpful, informative, or something worth liking? Click the like button please :D

    #12 Jun 01, 2013 at 22:01 UTC - 0 likes

    I have the same problem. The players on my server are set as members. Even in game it shows me that they have the members tag. When I do /pex user [name] it shows me all their permissions. They are what I set them too, but when they try to do things in world they cant do anything.

    My plugins:


    My Permissions.yml

        default: true
        prefix: '[Guest] '
        build: false
        - essentials.rules
        - essentials.motd
        default: false
        prefix: '&2[Member]&7 '
        build: true
        - modifyworld.*
        - essentials.rules
        - essentials.motd
        - essentials.afk
        - essentials.back
        - essentials.back.ondeath
        - essentials.depth
        - essentials.delhome
        - essentials.home
        - essentials.kit
        - essentials.list
        - essentials.mail
        - essentials.mail.send
        - essentials.motd
        - essentials.msg
        - essentials.r
        - essentials.rules
        - essentials.seen
        - essentials.sethome
        - essentials.signs.use.disposal
        - essentials.spawn
        - essentials.suicide
        - essentials.tpa
        - essentials.tpaccept
        - essentials.tpahere
        - essentials.tpdeny
        - xp.create
        - xp.quickstore
        default: false
        prefix: '&6[VIP]&7 '
        - Guest
        - Member
        build: true
        - essentials.rules
        - essentials.motd
        default: false
        prefix: '&1[Mod]&f '
        - VIP
        - Member
        - Guest
        build: true
        - essentials.sethome.multiple.staff
        - essentials.helpop
        - essentials.home.others
        - essentials.nick
        - essentials.warp
        - essentials.warp.list
        default: false
        prefix: '&9[Admin]&f '
        - Mod
        - VIP
        - Member
        - Guest
        build: true
        - '*'
        - Admin
        - Member
        - Member

    If you could figure the problem out that would be awesome!!

    #13 Jun 01, 2013 at 22:13 UTC - 0 likes

    @Echochrome3: Go

    First of all, I would appreciate if you would make your own thread in the future for any other problems.

    Anyways, I am going to automatically assume it is Essentials AntiBuild and Modify World conflicting with each other.
    The way you described your situation, I assume they can do commands, but can't build.

    I am also going to assume your users get the message, "You are not allowed to build / do this"
    Or something along those lines. If you do get a message similar to that, it is Essentials AntiBuild. Remove that plugin. ModifyWorld already covers that part of the server.

    Last edited Jun 01, 2013 by Unknown_Mage
    #14 Jun 01, 2013 at 22:22 UTC - 0 likes

    @Unknown_Mage: Go

    Ok I removed Essentials AntiBuild and now they can interact, but if they try and put an item in their hand it gets thrown on the ground and they cant pick it back up. What is causing that, and how can I fix it?

    #15 Jun 01, 2013 at 22:28 UTC - 0 likes

    I do not know what is causing it with so little information. I can only assume based on past experience with similar errors.

    Check your configuration file for ModifyWorld.
    Check to make sure these options are set to their respective values. Leave every other configuration option you see alone and do NOT delete or change them.

    item-restrictions: false
    drop-restricted-item: false
    item-use-check: false
    #16 Jun 02, 2013 at 12:32 UTC - 0 likes

    @Unknown_Mage: Go

    Ok attached is a little video of what is actually happening.

    I went in a found the settings you said tho change and they were already like that. In the video you see me trying to scroll with my mouse wheel through my inventory. When I do this the items either get thrown on the ground or back into my inventory and you cant pick them up when they get thrown out. The first time I look into the command prompt it says:

    08:28:34 [INFO] User LegoMan0926 checked for "modifyworld.items.hold.ironsword",
     no permission found
    08:28:34 [INFO] User LegoMan0926 checked for "modifyworld.items.hold.ironaxe", n
    o permission found
    08:28:34 [INFO] User LegoMan0926 checked for "modifyworld.items.hold.ironspade",
     no permission found

    I don't know why it is doing that because later in the video I go and point out that I have modifyworld.* in. So shouldn't it be working because the error is a modifyworld? If you need any other info just ask.

    Name Size MD5
    Minecraft.mp4 2.8 MiB 8a8264de486b...
    #17 Jun 02, 2013 at 19:58 UTC - 0 likes

    @Echochrome3: Go

    Ok have done alittle more testing and players also cant pick up drops if they break things, and if they try and take things from chests it doesn't let them. They cant even move it from its slot it is in.

    #18 Jun 02, 2013 at 20:28 UTC - 0 likes

    Video doesn't work for me. Getting a text page.
    Upload to something like youtube?

    #19 Jun 03, 2013 at 13:21 UTC - 0 likes

    @Unknown_Mage: Go

    #20 Jun 04, 2013 at 00:18 UTC - 0 likes

    Try replacing this:


    with this:


You must login to post a comment. Don't have an account? Register to get one!