Modify world block bottle o enchanting or exp in a world

  • 10 posts
    #1 Mar 15, 2012 at 21:52 UTC - 0 likes

    My players are abusing bottle of enchant for free exp in our creative world.

    We have seperate inventories for survival/creative but exp,health,food etc is carried over.

    Worldguard only blocks the bottle from being thrown at any block other than air.

    And these these nodes don't work either:
    - -modifyworld.mobtarget.experienceorb
    - -modifyworld.interact.experienceorb
    - -modifyworld.items.have.384
    - -modifyworld.item.use.384.on.block.*
    - modifyworld.*


    Last edited Mar 15, 2012 by StuckingFoned

    24/7 Survival & Creative - Ballz of Steel

    • Survival & Creative • Multi-World • Nether PvP • No Whitelist •
    • 99.5%+ Uptime • Small community • Forums • Online map • Professional Staff •
    • IP: •

    Click here to view plugins released by me

    #2 Mar 16, 2012 at 11:01 UTC - 0 likes

    @StuckingFoned: Go

    Per the thread in the old bukkit forum, this may be a bukkit problem, but ticket has been opened.

    Of course, if anyone else has any ideas, by all means, chime in. :)


    #3 Mar 16, 2012 at 12:07 UTC - 0 likes

    For me modify world does not remove the item at all, even after switching slots in the hot bar :(

    #4 Mar 17, 2012 at 06:59 UTC - 0 likes

    If modifyworld isn't removing the forbidden item, then my next thought it that the permissions are off and/or modifyworld isn't configured right as I've never had it fail to remove an item unless a typo was made in the permission node.

    #5 Mar 17, 2012 at 13:10 UTC - 0 likes

    I'm pretty sure the permissions are right? Please try the ones in OP.

    My config:

    enable: true
    itemRestrictions: true
    informPlayers: false
    whitelist: false
    whitelistMessage: You are not on the server whitelist! Good bye!
    prohibitedItem: You have prohibited item "%s".
    permissionDenied: Sorry, you don't have enough permissions
    use-material-names: true
    check-metadata: true
    drop-restricted-item: false
    item-use-check: true

    I've tried use-material-names: false but no luck
    Also no idea what check-metadata does since it isn't documented

    Last edited Mar 17, 2012 by StuckingFoned
    #6 Mar 18, 2012 at 03:37 UTC - 0 likes

    Unfortunately, a portion of your permissions isn't going to quite work, the entire thing needs to be seen to make sure everything is formatted right.

    As for check-metadata, it's documented in the wiki as of 2 days ago according to the page history for modifyworld (it was missed when it was redone about a week ago).

    #7 Mar 18, 2012 at 11:19 UTC - 0 likes

    My permissions are pretty complex..

    #8 Mar 18, 2012 at 23:32 UTC - 0 likes

    Hmm. I tried to reproduce this but was unable to.

    I imported your permissions into my test server, created a new world named creative2 and logged in, which should have put me in the default group.

    I was able to pull a exp bottle out, but as soon as I used it/switched inventory slots, it was ejected (I have drop items on). Unfortunately, I was able to pick it back up and keep on throwing it around. :(

    And it looks like the on-acquire function of worldguard is not working correctly, as I wasn't able to block those bottles either in my testing using it.

    What are you using for your multiworld management? If it's multiverse, I'd suggest looking at multiverse-inventories as it does have the ability to keep experience separate from each world.

    #9 Mar 20, 2012 at 11:36 UTC - 0 likes

    Hi we use multiverse and multiinv. Multiverse-inv was still in dev last time I checked so we usually go for the more stable/older plugins.

    Also what happens if you disable drop items?

    #10 Mar 21, 2012 at 08:38 UTC - 0 likes

    @StuckingFoned: Go

    True, multiverse is still dev for 1.2, but the current dev builds have been pretty stable in my testing, not to mention they have said they aren't going to release an AB until bukkit goes RB.

    As for disabling drops, the forbidden item just goes away instead of being ejected from the players inventory.

  • 10 posts

You must login to post a comment. Don't have an account? Register to get one!