KingKits - By KingFaris10

KingKits Banner


There are 'extras' on the Spigot page with KingKits versions optimised for Java 8, or unsupported KingKits versions that are for 1.8 and 1.7. Click here

What is KingKits?

KingKits is not the ordinary kit plugins that allows players to use kits in PvP. This plugin is special as it has in-game commands that allows you to create kits and delete kits. You can also use /pvpkit <kit> or a sign to choose a kit.


  • Multi-world support
  • Kit command
  • Sign kits
  • Creating/deleting/renaming kits in-game
  • Disabling/enabling commands
  • QuickSoup to refill your health/hunger
  • A refill command to refill your bowl(s)
  • Economy: Cost per kits, money per kill, losing money per death.
  • Easy configuration
  • In-game configuration editing
  • Killstreaks and scores
  • Developer friendly (Open source code and hooks)

There are many more features so try out KingKits!


If economy is enabled in the config, Vault is required.

Creating KingKits signs

1. Place down a sign.
2. On the first line type "[Kit]" (configurable).
3. On the second line type the kit name.
4. On the other lines you can type whatever you like.
5. Right click on the sign to activate it.

Note - If your kit sign in the config is set to "[Kit]", you must disable Essentials kits for KingKits signs to work.


English tutorial by me -

Commands and Permissions



Kits Configuration:


Above v5.0.0: Dutch (thanks to Sammeeh):

Below v5.0.0: Italian:


You can modify the source code in any way as long as you don't claim this as your code and/or plugin.

You can use the source code from this plugin as long as you give credit to KingFaris10. You cannot just copy the whole plugin.

KingKits also has an API class that allows you to do many things, such as get player kits, create kits, delete kits, etc.


This plugin utilises Hidendra's plugin metrics system, which means that the following information is collected and sent to

  • A unique identifier
  • The server's version of Java
  • Whether the server is in offline or online mode
  • The plugin's version
  • The server's version
  • The OS version/name and architecture
  • The core count for the CPU
  • The number of players online
  • The Metrics version

You can opt out of this service by editing plugins/PluginMetrics/config.yml and changing opt-out to true.

MCStats - KingKits


This plugin utilizes Gravity's plugin updater to check for updates.

To disable update checking for KingKits only, set 'Updater.Enabled' in '/plugins/KingKits/config.yml' to false. To disable update checking for all plugins, set 'disable' to 'true' in 'plugins/Updater/config.yml'.


Feel free to post suggestions in the comments box! I'm always looking for new cool ideas so go ahead! I will read them ;)

Other plugins by KingFaris10

Check out all my other cool plugins!

AdminFun: | Let your admins have fun using awesome trolling/broadcast commands!

ItemRenamer: | Rename items (Supports colour codes) without the use of anvils! Also, you can add lores to your item.

EasyPermissionsEx: | Make all the commands easier and shorter for PermissionsEx and make life 100x times more easier =)

CommandPortals: | Link locations with commands and run commands when a player steps in a specific location.


The purpose of this plugin was to help PvP servers get a kit plugin that allows players to use kits with enchantments, lores and custom names. Also, if you do have a developer or you are one, you can make your own special abilities.


Q: My scoreboard's stuck when I deleted the plugin!

A: /scoreboard objectives remove KingKits

Q: It's saying I don't have permissions to use that kit even if I give them kingkits.kit.use!

A: Have you given them the permission node for the actual kit? kingkits.kits.<kit>.

Q: It's saying I don't have permission to use the command even if I give them kingkits.kits.<kit>!

A: Same as the previous answer, but give them kingkits.kits.use.

Q: I keep getting the error: "Could not load 'plugins/KingKits.jar' in folder 'plugins' org.bukkit.plugin.InvalidPluginException: java.lang.UnsupportedClassVersionError: me/faris/kingkits/KingKits : Unsupported major.minor version 51.0 at "

A: Calm down, you require Java 7, and running the server on Java 7. This is not much of a problem since most other plugins are built against Java 7. If you have Java 7 installed and it still comes up with this error, it means you have a previous version of Java installed (e.g. Java 6) as well as Java 7. Make sure to run your server on Java 7 by either changing the start-up script or contacting your host.

You must login to post a comment. Don't have an account? Register to get one!

  • Avatar of SoulHeaterGhost SoulHeaterGhost Sep 29, 2016 at 14:26 UTC - 0 likes

    the cost isn't working for me. what i did is this and i just reload kingkits and /pvpkit to click on kit and it just previews the kits i need help

    Command alias: true

    Description: []

    Cost: 50.0

    Cooldown: 0.0

    Max health: 20.0

    Walk speed: 0.2

    Auto-unlock score: -1

    Breakable items: true

    Commands: []

    Last edited Sep 29, 2016 by SoulHeaterGhost
  • Avatar of KingFaris10 KingFaris10 Sep 07, 2016 at 14:17 UTC - 0 likes

    @Creativepro9654: Go

    Domain expired, no one supported the plugin.

    New link:


  • Avatar of Creativepro9654 Creativepro9654 Sep 03, 2016 at 06:16 UTC - 0 likes

    the link for the permissions arn't working!

  • Avatar of KingFaris10 KingFaris10 Aug 31, 2016 at 16:49 UTC - 0 likes

    @JPAK9901: Go

    Because you're using an unsupported Minecraft server version, check your console. The only way to get KingKits for MC 1.7 or 1.8 is to go on the Spigot resource page.

  • Avatar of JPAK9901 JPAK9901 Aug 24, 2016 at 15:09 UTC - 0 likes

    i have a problem. for some reason, everytime i reload my server the plugin disables itself and i have to uninstall and reinstall the plugin for it to work again. Anyone know why this is happening?

  • Avatar of Captain104 Captain104 Jul 02, 2016 at 08:50 UTC - 0 likes

    i have an problem the multi inventories is not working at me it doesnt clear when changing from world. im using mc version 1.10. im sure everything its fine in the config. and also the ecomony isn't working. when kills a players works and at death also but when uying an kit does not take money from your balance. maybe because im using 1.10? if so could you maybe update the plugin?

  • Avatar of KingFaris10 KingFaris10 Jun 27, 2016 at 11:37 UTC - 0 likes

    @DARNIC92: Go

    Your lack of config knowledge has caused you many bugs. All these things are configurable.

  • Avatar of DARNIC92 DARNIC92 Jun 24, 2016 at 23:53 UTC - 0 likes

    Your plugin caused me many bugs (and got 3 h to figure it out) : - on each deconnection, players lost their stuff when login again - hunger bar not consumming anymore - colliding with skillapi plugin about health

    i got it deleted sorry

  • Avatar of KingFaris10 KingFaris10 Jun 17, 2016 at 21:29 UTC - 0 likes

    @ElfinHarasi: Go

    Weird, what editor are you using? Try adding the Japanese to the config itself rather than using in-game. Maybe UTF-8 isn't the default with Java's file writer.

    Last edited Jun 17, 2016 by KingFaris10
  • Avatar of ElfinHarasi ElfinHarasi Jun 14, 2016 at 11:18 UTC - 0 likes

    @KingFaris10: Go

    Sorry...I don't know how to save kit to UTF-8 in game.

    I saved my kit, but the writing is garbled. XD My language is japanese.

    Last edited Jun 14, 2016 by ElfinHarasi


Date created
Apr 24, 2013
Last update
Aug 20, 2016
Development stage
  • enUS
GNU General Public License version 3 (GPLv3)
Curse link
Recent files