Give Anything Listener

Give Anything Listener




This is a plugin that works with Votifier 1.8 or higher, and as such should be placed inside the plugins folder NOT the listeners one.
This plugin listens to voting events passed from Votifier and allows you to reward players with anything when they vote for your server.
If you can type it as a command you can use it to in this plugin!
The Plugin works like a lot of the other listeners, but gives the user a detailed Configuration, on how to setup the broadcast message, and the colour / control codes they can use, Like {BOLD} etc...
This Plugin REQUIRES Votifier 1.8 or above!
When installing you must place the GAListener.jar into your /plugins folder.
It will then create a config.yml inside of the folder which you can edit to your liking!


Configuration information (Including Lucky Voters can be found) Configuration Page!

Here's a video tutorial thanks to Koz4Christ!


This plugin utilizes Hidendra's plugin metrics system, which means that the following information is collected and sent to

  • A unique identifier
  • The server's version of Java
  • Whether the server is in offline or online mode
  • The plugin's version
  • The server's version
  • The OS version/name and architecture
  • The core count for the CPU
  • The number of players online
  • The Metrics version

You can disable the stat collection via /plugins/PluginMetrics/config.yml if you wish.


Sponsored by MC-Index! For all your voting needs!

Please create a ticket with any issues you are having and we would be happy to help, don't post it on the front page!

You must login to post a comment. Don't have an account? Register to get one!

  • Avatar of Cop_Derp_SSundee Cop_Derp_SSundee Oct 17, 2016 at 00:06 UTC - 0 likes

    @Gunnerrrrr: Go

    UUID support will never happen as names can be changed for instance

    my name was Bl4ckscor3_ I change my name to IHaxx Someone else comes along and uses Bl4ckscor3_

  • Avatar of alek123222 alek123222 Oct 09, 2016 at 15:47 UTC - 0 likes

    What are the service name for each thing?

  • Avatar of BornToCode BornToCode Sep 01, 2016 at 18:58 UTC - 0 likes

    How do I configure this plugin to ignore votes for offline players?

    When a player mistypes their playername while voting, it seems like my two choices are: 1) queue up the vote indefinitely because a player with the mistyped name is unlikely to ever join. 2) initiate the rewards with a mistyped playername which unfortunately tends to produce a lot of errors in the logs and surprisingly frequently finds another similarly named, but different player on a busy server to give the rewards to.

  • Avatar of lagnat lagnat Aug 31, 2016 at 02:26 UTC - 0 likes

    Is source code available?

  • Avatar of Gunnerrrrr Gunnerrrrr Aug 30, 2016 at 20:56 UTC - 0 likes

    Works on 1.10. Needs UUID support.

  • Avatar of ssamjh ssamjh Aug 16, 2016 at 00:34 UTC - 0 likes

    Does version 1.3.2 have support for UUID's? As you conveniently abandoned the Spigot version that I paid for :(

  • Avatar of Rocologo Rocologo Jun 30, 2016 at 10:41 UTC - 0 likes

    I have today tested GAL1.3.2 on my SpigotMC 1.10.2 server ( everything works fine.

    I have tested /vote and offline votes it works perfect. :-)

    My newest plugin: MobHunting


  • Avatar of CielRound CielRound Jun 20, 2016 at 14:03 UTC - 0 likes

    Hi I don't know why butt every time I try to change something in de config file, /vote does not work. Can somebody pls help me.


  • Avatar of HeroCC HeroCC Jun 20, 2016 at 00:12 UTC - 0 likes

    Anybody know of a replacement for this plugin? It is now a premium plugin on spigot

    HeroiCraft Banner

    HeroiCraft - Survival / Creative / SkyBlock \ Mini Games \ Tons More!

  • Avatar of Bubbbaaa Bubbbaaa Jun 08, 2016 at 18:24 UTC - 0 likes

    I found: if you update votifier to the latest, votifier v1.9 for CB 1.7.9-R0.2, the newest GALISTENER works on spigot MC1.9


Date created
Oct 16, 2012
Last update
Mar 02, 2016
Development stage
  • enUS
All Rights Reserved
Curse link
Give Anything Listener
Recent files



Required dependency