dtlTraders

dtlTraders Logo (Mre30 Project)

https://www.spigotmc.org/attachments/dtltraders1-png.13144/

dtlTraders was created to easily setup admin shops for your sever.

It's the ONE COMMAND plugin! Seriously, that's all you need to know ;)

https://www.spigotmc.org/attachments/cooltext1858499025-png.14185/https://www.spigotmc.org/attachments/1111cooltext1858509556-png.14188/https://www.spigotmc.org/attachments/22222-png.14187/

https://www.spigotmc.org/attachments/cooltext1858486842-png.14177/

  • Download dtlTraders jar file.
  • Place it into your plugins folder.
  • Download Citizens and place that into your plugins folder as well.
  • You also need Vault and ANY economy plugin.
  • Start your server
  • No configuration needed for basic usage (which will be 99% of you)

Dependencies

As with version 3.4.0 this plugin needs the dtlCore plugin to work. Be sure you got it before using this version. Also remember this is still a BETA build so there may be bugs and it might make loose your data so make a backup copy before using this version.

https://www.spigotmc.org/attachments/cooltext1858476665-png.14173/
Have a problem?
-> Read the Guide.
Have errors or other problems?
-> Open a ticket.

https://www.spigotmc.org/attachments/cooltext1858480537-png.14174/
Click here to send your donation. It's not required, but it is helpful. Think of it as a motivational cookie. Or think of it as a, "thanks for this amazing plugin, dinners on me tonight".

https://www.spigotmc.org/attachments/cooltext1858481507-png.14175/

  • Mre30 For this new awesome project page! You are awesome! :D
  • Lethe, chasingcode, Wreyth, Instinx, silentassasin, Gizmoholm, tehbeard

You must login to post a comment. Don't have an account? Register to get one!

  • Avatar of papakosmas papakosmas Aug 19, 2016 at 15:13 UTC - 0 likes

    Good evening ladies and gentlemen! I have a question, I already installed the dtl traders plugin and it seems not to be a problem with the plugin. I am trying to add items to my shop but I can not open the shop meanwhile I am holding Items. When i drop the Items I can open the shop but it is stupid to open the shop without having any items to place in the shop

    Please help me!

  • Avatar of Z3dd7 Z3dd7 Aug 08, 2016 at 11:49 UTC - 0 likes

    @Paaattiii: Go

    Hey Paaattiii, thanks for keeping this plugin alive !

    Don't forget to change the version string in plugin.yml tho :p

    ZBDH5f1966a5e1000dbe7bcdc11c9b8fed5d

  • Avatar of Sparclen Sparclen Jul 31, 2016 at 23:18 UTC - 1 like

    The Issue tickets are being ignored so I'll post this here.

    The issue.

    1.10 features are NOT all supported. Any item with modified attributes (like attack damage) or a 'hide attributes' flag will fail to load on server bootup. This makes the plugin useless to those trying to sell or buy complex items.

    What steps will reproduce the problem?

    1. Create an item with modified attributes, such as attack damage. 2.Place the item in a shop. 3.Reset the server.

    What is the expected output? What do you see instead?

    Expected the shop to load up correctly. It did not.

    What version of the product are you using?

    3.4.6

    Please provide any additional information below.

    Lore, custom name etc. work fine. Modified attributes and the 'hide' flag do not. This is REQUIRED for full 1.10 compatability.

    Example of what works in the saves.yml:

    - diamond_sword p:2.00 a:1 s:19 d:83 n:&fDonut .lore .unbreakable:

    - ^eA plain donut.

    Example of what won't work:

    - diamond_sword p:2.00 a:1 s:20 d:83 g.dmg:generic.attackDamage/1,00/0 n:&fDonut .lore .unbreakable:

    - ^eA plain donut.

    or

    - diamond_sword p:2.00 a:1 s:20 d:83 n:&fDonut .hidef:6 .lore .unbreakable:

    - ^eA plain donut.

    Please fix this, the user interface of the plugin is great, and it would be such a shame if I had to switch to a crappy plugin just because this one doesn't support attribute modifiers.

    Last edited Jul 31, 2016 by Sparclen
  • Avatar of Paaattiii Paaattiii Jul 30, 2016 at 07:29 UTC - 0 likes
    Last edited Jul 30, 2016 by Paaattiii
  • Avatar of pinoylifecraft727 pinoylifecraft727 Jul 30, 2016 at 00:23 UTC - 0 likes

    @Paaattiii: Go

    Thanks for Posting it on Bukkit

    Ahm give me the link if DEVBUKKIT approved it Please :)

  • Avatar of Paaattiii Paaattiii Jul 29, 2016 at 16:37 UTC - 0 likes

    @pinoylifecraft727: Go

    waiting for approval :) i have now access to the bukkit site as author

    Last edited Jul 29, 2016 by Paaattiii
  • Avatar of pinoylifecraft727 pinoylifecraft727 Jul 29, 2016 at 06:31 UTC - 0 likes

    @Paaattiii: Go

    This is what I encounter -> http://imgur.com/eAuoJb9

    What is the Problem of it? Can you post it on DropBox.com ?

    DTLTrader

  • Avatar of Paaattiii Paaattiii Jul 28, 2016 at 16:28 UTC - 0 likes
    Last edited Jul 28, 2016 by Paaattiii
  • Avatar of pinoylifecraft727 pinoylifecraft727 Jul 28, 2016 at 07:43 UTC - 0 likes

    @Paaattiii: Go

    I can't Download your Recompile DTLTrader for 1.10 ?

  • Avatar of rayblon rayblon Jul 25, 2016 at 20:17 UTC - 0 likes

    @Paaattiii: Go

    Do you plan on carrying out long-term updates for this, or will this be more of a one-time thing? I'd rather just find another plugin for shops if it's the latter.

    Frienderman!

Are you using patterns?

  1. Choice:

  1. Results
  2. 6 comments

Table of contents

  1. 1 Dependencies

Facts

Date created
Aug 19, 2012
Categories
Last update
Jul 29, 2016
Development stage
Release
Language
  • enUS
  • plPL
License
MIT License
Curse link
dtlTraders
Downloads
93,685
Recent files

Authors