WorldWarp


If you are using the 3.4 beta build for 1.5.1 the plugin will say that there is a new version available - This is because you are currently not using the recommended version of WorldWarp.
WorldWarp is a basic, Yet effective way of managing your worlds. The plugin lets you Create, Import, Delete, List & Warp to different worlds just by typing some easy commands. WorldWarp features a powerful world creating system which lets you choose between Normal, Nether & The End - And lets you specify the seed you want to use.

Commands

CommandPermissionDefaults toDescription
/wwarp [Name]WorldWarp.wwarpAllWarps to desired world.
/wbackWorldWarp.wbackAllReturns to previous world.
/wlistWorldWarp.wlistAllLists active worlds.
/wcreate [Name] [Environment] <seed> -flagsWorldWarp.wcreateOPCreates world.
/wimport [Name]WorldWarp.wimportOPImports currently non-active worlds.
/wdelete [Name] -flags WorldWarp.wdeleteOPDeletes desired world, adding -h deletes world folder.
/wflag [Name] -flags WorldWarp.wflagOPFlags world, see below.

Command Flags

FlagEffectWorks with
-pvpSets world to PVP Enabled/wflag /wcreate
-nopvpSets world to PVP Disabled/wflag /wcreate
-peacefulSets world to peaceful/wflag /wcreate
-easySets world to easy/wflag /wcreate
-normalSets world to normal/wflag /wcreate
-hardSets world to hard/wflag /wcreate
-hDelets world folder/wdelete

Configuration

ItemPathDefaultDescription
Permissionssettings.permissions.useTRUEEnables/Disables permissions.

Environments

NameDescriptionCode
NormalNormal worldNORMAL
NetherThe NetherNETHER
The EndThe endTHE_END
Flatlands16 Block high FlatlandsFLATLANDS
Forum Thread

You must login to post a comment. Don't have an account? Register to get one!

  • Avatar of Fodermester Fodermester May 25, 2014 at 21:47 UTC - 0 likes

    Just found out that WorldWarp and Protocollib cant work together. Which one is not working according to standards?

  • Avatar of Fodermester Fodermester May 25, 2014 at 18:31 UTC - 0 likes

    Monster error - WorldWarp does not work here:

    20:23:57 [INFO] [WARNING]: There is a new version of WorldWarp available at dev.bukkit.org 20:23:57 [INFO] [WorldWarp] Enabled! Running 3.6 20:23:57 [INFO] _ _ _ _ _ _ _ _ 20:23:57 [INFO] | || || | | | | | || || | 20:23:57 [INFO] | || || | _ | | _ | | || || | 20:23:57 [INFO] | ||_|| |/ _ \ / _) |/ || | ||_|| |/ _ |/ _) _ 20:23:57 [INFO] | |_| | |_| | | | ( (_| | |_| ( ( | | | | | | | 20:23:57 [INFO] \|\_/|_| |_|\|\|\_||_|_| | ||_/ 20:23:57 [INFO] |_| 20:23:57 [SEVERE] Error occurred while enabling WorldWarp v3.6 (Is it up to date?) 20:23:57 java.lang.NoSuchMethodError: org.mcstats.Metrics.addCustomData(Lorg/mcstats/Metrics$Plotter;)V 20:23:57 at org.mcstats.WWTrack.init(WWTrack.java:17) [?:?] 20:23:57 at Raz.WorldWarp.WorldWarp.onEnable(WorldWarp.java:63) [?:?] 20:23:57 at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:250) [craftbukkit-1.7.9-R0.1-20140418.182938-15.jar:git-Bukkit-1.7.2-R0.3-56-g3779cff-b3072jnks] 20:23:57 at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:324) [craftbukkit-1.7.9-R0.1-20140418.182938-15.jar:git-Bukkit-1.7.2-R0.3-56-g3779cff-b3072jnks] 20:23:57 at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:404) [craftbukkit-1.7.9-R0.1-20140418.182938-15.jar:git-Bukkit-1.7.2-R0.3-56-g3779cff-b3072jnks] 20:23:57 at org.bukkit.craftbukkit.v1_7_R3.CraftServer.loadPlugin(CraftServer.java:448) [craftbukkit-1.7.9-R0.1-20140418.182938-15.jar:git-Bukkit-1.7.2-R0.3-56-g3779cff-b3072jnks] 20:23:57 at org.bukkit.craftbukkit.v1_7_R3.CraftServer.enablePlugins(CraftServer.java:382) [craftbukkit-1.7.9-R0.1-20140418.182938-15.jar:git-Bukkit-1.7.2-R0.3-56-g3779cff-b3072jnks] 20:23:57 at net.minecraft.server.v1_7_R3.MinecraftServer.n(MinecraftServer.java:352) [craftbukkit-1.7.9-R0.1-20140418.182938-15.jar:git-Bukkit-1.7.2-R0.3-56-g3779cff-b3072jnks] 20:23:57 at net.minecraft.server.v1_7_R3.MinecraftServer.g(MinecraftServer.java:326) [craftbukkit-1.7.9-R0.1-20140418.182938-15.jar:git-Bukkit-1.7.2-R0.3-56-g3779cff-b3072jnks] 20:23:57 at net.minecraft.server.v1_7_R3.MinecraftServer.a(MinecraftServer.java:282) [craftbukkit-1.7.9-R0.1-20140418.182938-15.jar:git-Bukkit-1.7.2-R0.3-56-g3779cff-b3072jnks] 20:23:57 at net.minecraft.server.v1_7_R3.DedicatedServer.init(DedicatedServer.java:182) [craftbukkit-1.7.9-R0.1-20140418.182938-15.jar:git-Bukkit-1.7.2-R0.3-56-g3779cff-b3072jnks] 20:23:57 at net.minecraft.server.v1_7_R3.MinecraftServer.run(MinecraftServer.java:436) [craftbukkit-1.7.9-R0.1-20140418.182938-15.jar:git-Bukkit-1.7.2-R0.3-56-g3779cff-b3072jnks] 20:23:57 at net.minecraft.server.v1_7_R3.ThreadServerApplication.run(SourceFile:628) [craftbukkit-1.7.9-R0.1-20140418.182938-15.jar:git-Bukkit-1.7.2-R0.3-56-g3779cff-b3072jnks]

  • Avatar of TheRaz94 TheRaz94 Mar 04, 2014 at 13:51 UTC - 1 like

    Hey guys!

    I'm sorry about the inactivity but there is a 1.7.2-r0.3 version ready, sadly I'm not allowed to release it due to bukkitdev not allowing me to make version checks to my own server.

    I'm not sure yet if I'm gonna implement the bukkitforge api and release the new version, you'll just have to wait and see.

    BFAK:Raz,2159,3f28f98629445db0f16fcd8d0ba78b210c4461ba3cef8f68a0398fa31fd64200

  • Avatar of Annepyr Annepyr Feb 17, 2014 at 07:20 UTC - 0 likes

    Sounds like a great plugin, but I'll wait for 1.7.4 compatible version before I use this... I don't want to break anything. ^^;

  • Avatar of RetroCharles RetroCharles Dec 28, 2013 at 05:56 UTC - 1 like

    I'm having a internal error as well. Same situation with wiiboy123.

    Below is the text that comes up when doing a world warp command:

    [21:57:28 INFO]: ReTrOChArLeS issued server command: /wwarp [21:57:28 ERROR]: null org.bukkit.command.CommandException: Unhandled exception executing command 'wwar p' in plugin WorldWarp v3.6 at org.bukkit.command.PluginCommand.execute(PluginCommand.java:46) [cra ftbukkit.jar:git-Bukkit-1.7.2-R0.2-b2974jnks] at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:19 6) [craftbukkit.jar:git-Bukkit-1.7.2-R0.2-b2974jnks] at org.bukkit.craftbukkit.v1_7_R1.CraftServer.dispatchCommand(CraftServe r.java:542) [craftbukkit.jar:git-Bukkit-1.7.2-R0.2-b2974jnks] at net.minecraft.server.v1_7_R1.PlayerConnection.handleCommand(PlayerCon nection.java:932) [craftbukkit.jar:git-Bukkit-1.7.2-R0.2-b2974jnks] at net.minecraft.server.v1_7_R1.PlayerConnection.a(PlayerConnection.java :814) [craftbukkit.jar:git-Bukkit-1.7.2-R0.2-b2974jnks] at net.minecraft.server.v1_7_R1.PacketPlayInChat.a(PacketPlayInChat.java :28) [craftbukkit.jar:git-Bukkit-1.7.2-R0.2-b2974jnks] at net.minecraft.server.v1_7_R1.PacketPlayInChat.handle(PacketPlayInChat .java:47) [craftbukkit.jar:git-Bukkit-1.7.2-R0.2-b2974jnks] at net.minecraft.server.v1_7_R1.NetworkManager.a(NetworkManager.java:146 ) [craftbukkit.jar:git-Bukkit-1.7.2-R0.2-b2974jnks] at net.minecraft.server.v1_7_R1.ServerConnection.c(SourceFile:134) [craf tbukkit.jar:git-Bukkit-1.7.2-R0.2-b2974jnks] at net.minecraft.server.v1_7_R1.MinecraftServer.u(MinecraftServer.java:6 55) [craftbukkit.jar:git-Bukkit-1.7.2-R0.2-b2974jnks] at net.minecraft.server.v1_7_R1.DedicatedServer.u(DedicatedServer.java:2 50) [craftbukkit.jar:git-Bukkit-1.7.2-R0.2-b2974jnks] at net.minecraft.server.v1_7_R1.MinecraftServer.t(MinecraftServer.java:5 45) [craftbukkit.jar:git-Bukkit-1.7.2-R0.2-b2974jnks] at net.minecraft.server.v1_7_R1.MinecraftServer.run(MinecraftServer.java :457) [craftbukkit.jar:git-Bukkit-1.7.2-R0.2-b2974jnks] at net.minecraft.server.v1_7_R1.ThreadServerApplication.run(SourceFile:6 17) [craftbukkit.jar:git-Bukkit-1.7.2-R0.2-b2974jnks] Caused by: java.lang.NullPointerException at Raz.WorldWarp.WorldWarp.hasPerm(WorldWarp.java:125) [?:?] at Raz.WorldWarp.WorldWarp.onCommand(WorldWarp.java:92) [?:?] at org.bukkit.command.PluginCommand.execute(PluginCommand.java:44) [cra ftbukkit.jar:git-Bukkit-1.7.2-R0.2-b2974jnks] ... 13 more

    Last edited Dec 28, 2013 by RetroCharles
  • Avatar of wiiboy123 wiiboy123 Oct 18, 2013 at 01:24 UTC - 0 likes

    Hi, I have an "Internal Error" with WorldWarp. Every time I try to create a world, It says: "An internal error occurred while trying to perform this command"

    What do I do?

    Thank you.

  • Avatar of TheRaz94 TheRaz94 Sep 20, 2013 at 15:39 UTC - 0 likes

    @Airwick_: Go

    Sorry, i recently switched server provider and forgot to forward the domain used for WorldWarp version checking to the new server, i made the changes now and it should be resolved within 24 hours

  • Avatar of Airwick_ Airwick_ Sep 20, 2013 at 12:24 UTC - 0 likes

    Hi,

    Just want to ask why it keeps telling me there is a new version of World Warp when there is not. I am using version 3.5 and working fine besides that.

    Just thought I would tell you because I feel its a problem.

  • Avatar of boswelja boswelja Aug 28, 2013 at 03:23 UTC - 0 likes

    @KR1dude: Go

    I think so, I get the same error

  • Avatar of TheErryK TheErryK Aug 18, 2013 at 10:28 UTC - 0 likes

    @TheRaz94: Go

    He means CraftBukkit Build for Minecraft version 1.6.2, not the Java Runtime version. My friend is also experiencing an issue with using worldwarp commands but it works fine on my server with 1.6.2, but I had the plugin on 1.5.2 before updating 1.6.2.

Facts

Date created
Oct 01, 2011
Categories
Last update
Oct 08, 2013
Development stage
Release
License
All Rights Reserved
Curse link
WorldWarp
Downloads
40,720
Recent files

Authors