VoxelSniper

VoxelSniper Splash

Lead Design & Programming

przerwap, MikeMatrix

Additional Programming

Gavjenks, Giltwist, psanker, DivineRage

Development Builds

Development builds of this project can be acquired at the provided continuous integration server. These builds have not been approved by the BukkitDev staff. Use them at your own risk.

Development Builds are available here: Development Builds

Overview

VoxelSniper is the premier long range map editing tool for Minecraft SMP. This mod allows you to edit any block that you can see using an arrow (for replacing) and a gunpowder (for adding). It is best used by those with a strong attention to detail and fits a wide array of applications, from making detailed edits to structures with the snipe brush, to making massive terraforming jobs a breeze with some of the earth shattering soft selection tools.

VoxelSniper 5 introduces significant under-the-hood improvements, streamlining the number of brushes while increasing the number of brush options. Better documentation means it's never been easier to learn to use VoxelSniper.

Media

Metrics

This plugin utilises Hidendra's plugin metrics system, which means that the following information is collected and sent to mcstats.org:

  • A unique identifier
  • The server's version of Java
  • Whether the server is in offline or online mode
  • The plugin's version
  • The server's version
  • The OS version/name and architecture
  • The core count for the CPU
  • The number of players online
  • The Metrics version
  • The number of Snipers/LiteSnipers online
  • The number of times Brushes are used

Opting out of this service can be done by editing plugins/Plugin Metrics/config.yml and changing opt-out to true.

About us

The Voxel Box is a community-driven creative play server that consistently push the limits of what the Minecraft client and server can deliver to builders and to players. Over the past year and a half, it's blossomed into a place where some very talented people have built some of the most impressive Minecraft-related structures, software and concepts.

The VoxelBox

VoxelPlugins

VoxelPlugins: A suite of plugins for Minecraft servers running Bukkit

Homepage: thevoxelbox.com

VoxelWiki: voxelwiki.com

Twitter: @voxelbox

YouTube: youtube.com/voxelboxvideos

IRC: irc.esper.net #voxelbox #voxeldev

http://mcstats.org/signature/voxelsniper.png

You must login to post a comment. Don't have an account? Register to get one!

  • Avatar of ALittleBitOfMatter ALittleBitOfMatter Jul 28, 2014 at 17:43 UTC - 0 likes

    Why does this take 20 minutes to update on my server? It's not updating with my client! (Multicraft)

  • Avatar of Roven2121 Roven2121 Jul 27, 2014 at 15:14 UTC - 0 likes

    @GodsDead: Go

    As I already said to lwitrag, you need to have craftbukkit R0.1 for the newest version of voxelsniper, otherwise it wouldnt work

  • Avatar of Roven2121 Roven2121 Jul 27, 2014 at 12:05 UTC - 0 likes

    @Iwitrag: Go

    Because you need the version: 1.7.9 R0.1 Otherwise it dont work

  • Avatar of Chrisco23 Chrisco23 Jul 09, 2014 at 18:17 UTC - 0 likes

    Help! I Am Working On A New Server And Im Going To Use Voxel For Tereforming. But Whenever I Try To Do A Command From Voxel, It Says, "An internal error occurred while attempting to perform this command." I Updated Voxel From 1.7.2, to 1.7.9. If You Can Contact Me, Use My twitter Account. Twitter: @Chrisco231

  • Avatar of Iwitrag Iwitrag Jul 08, 2014 at 18:53 UTC - 0 likes

    Doesn't work with 1.7.9 R0.3 (tried even dev build #318) It says internal error, using Spigot, here is the error log from console:

    http://pastebin.com/1LjzZnfX

  • Avatar of Snhnry Snhnry Jul 07, 2014 at 23:12 UTC - 0 likes

    When trying to update from the 5.168.9 version to 5.170, all users except for ops lose the ability to use VS. When trying to select a brush, it simply outputs "No brush selected". Server is Spigot 1.7.9.

    Last edited Jul 07, 2014 by Snhnry
  • Avatar of super16mm super16mm Jul 05, 2014 at 22:47 UTC - 0 likes

    @Seadrakon: Go

    The "Temporary Page that should be gone within 24H" on the former Wiki has been there for about a month now.

  • Avatar of ZtheCdr ZtheCdr Jun 29, 2014 at 01:52 UTC - 0 likes

    My craftbukkit is for 1.7.2 R0.3. What version should i use? The reason i ask this is because when I type /v 1, it says to type /v to change your voxel Example: /v 1, even though I already typed that. The other versions I tried just dont even load or create the config file. Help!!!!

    Last edited Jun 29, 2014 by ZtheCdr
  • Avatar of Nadoomi Nadoomi Jun 28, 2014 at 21:42 UTC - 0 likes

    How do I give someone the permission to use VoxelSniper with GroupManager?

  • Avatar of Lolmewn Lolmewn Jun 23, 2014 at 19:20 UTC - 0 likes

    @GodsDead: Go

    Incompatible minecraft version. I'm waiting for 1.7.9 too ;)

    Priorities list: Stats, Achievements, Highscores, Skillz, Sortal, rest.

Facts

Date created
Dec 08, 2011
Categories
Last update
Jun 25, 2014
Development stage
Mature
Language
  • enUS
License
Creative Commons Attribution-NonCommercial-NoDerivs 3.0 Unported
Curse link
VoxelSniper
Downloads
531,202
Recent files

Authors