ValidServ

logo

EagleEye: a good and simply plugin that records what happend on a server. No configuration, no MySQL, no problems. Click here !


THIS PROJECT IS CURRENTLY OUT OF DATE AND UNUSFUL because I didn't work on it since a very very long time

You must login to post a comment. Don't have an account? Register to get one!

  • Avatar of ElectronGuigui ElectronGuigui Oct 18, 2012 at 19:23 UTC - 0 likes

    I don't work on this project since a too long time. Don't know if I will continue this one

    Last edited Mar 17, 2014 by ElectronGuigui
  • Avatar of ElectronGuigui ElectronGuigui Jun 08, 2012 at 06:41 UTC - 0 likes

    @amsedal: Go

    Yes. It make an error report in a new file and explain where is the error (class and line), why this error exists and a solution (not for all errors).

  • Avatar of amsedal amsedal Jun 05, 2012 at 02:26 UTC - 0 likes

    so say I get an error in my logs... any error:

    i.e.; ------ 2012-05-30 11:47:00 [SEVERE] null org.bukkit.command.CommandException: Unhandled exception executing command 'itbegin' in plugin InfinaTime v1.0.1 at org.bukkit.command.PluginCommand.execute(PluginCommand.java:42) at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:166) at org.bukkit.craftbukkit.CraftServer.dispatchCommand(CraftServer.java:479) at net.minecraft.server.NetServerHandler.handleCommand(NetServerHandler.java:821) at net.minecraft.server.NetServerHandler.chat(NetServerHandler.java:781) at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:764) at net.minecraft.server.Packet3Chat.handle(Packet3Chat.java:34) at net.minecraft.server.NetworkManager.b(NetworkManager.java:229) at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:113) at net.minecraft.server.NetworkListenThread.a(NetworkListenThread.java:78) at net.minecraft.server.MinecraftServer.w(MinecraftServer.java:567) at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:459) at net.minecraft.server.ThreadServerApplication.run(SourceFile:492) Caused by: java.lang.ArrayIndexOutOfBoundsException: 0 at me.docredstone.infina.Main.onCommand(Main.java:104) at org.bukkit.command.PluginCommand.execute(PluginCommand.java:40) ... 12 more -------- it ll explain that as best it can and help me figure out the issue?

    -Ams

  • Avatar of ElectronGuigui ElectronGuigui Jun 04, 2012 at 20:27 UTC - 0 likes

    The new version of the plugin can explain many errors ! Actually, you must put the text of the error in a new file in a new folder "ValidServ" in your plugin's folder and do the command /explain <file with the error's text>

  • Avatar of amsedal amsedal Jun 03, 2012 at 10:00 UTC - 0 likes

    ahh gotcha .. I have the latest version of PEX.. I was just using it to see what happens .. wasnt sure if I needed this mod or not .. it sounds useful though. Right now I m putting alot of mods together so I though maybe at least the error message explanations would help me alot!

    -Ams

  • Avatar of ElectronGuigui ElectronGuigui Jun 01, 2012 at 11:25 UTC - 0 likes

    That means that the permissions file doesn't exist. This command actually only works with PermissionsEX

  • Avatar of amsedal amsedal May 31, 2012 at 04:33 UTC - 0 likes

    Whats it mean when I put in /fixperms and system responds "[validServ]Error 01-1!" ?

  • Avatar of ElectronGuigui ElectronGuigui May 22, 2012 at 17:35 UTC - 0 likes

    @AltuniR5: Go

    Ok :)

  • Avatar of AltuniR5 AltuniR5 May 22, 2012 at 17:25 UTC - 0 likes

    Aucun problèmes, c'était juste pour faire remonté s'il y avait un bug pour que tu le coriges ;)

    www.choco-craft.com Owner, a french server can contain 35 players in the same time !

  • Avatar of ElectronGuigui ElectronGuigui May 22, 2012 at 17:10 UTC - 0 likes

    @AltuniR5: Go

    Déjà, ValidServ ne connaît pas tous les plugins. Ensuite, il vérifie seulement des dépendances et incompatibilités entre plugins ainsi que si ils sont abandonnés. Il ne vérifie pas du tout si tu utilise la dernière version d'un plugin comme CraftBukkit UpToDate (en tous cas pas encore).

    Désolé, c'est vrai que je n'aurai pas dû mettre "Chack that the plugins are up to date".

    Last edited May 22, 2012 by ElectronGuigui

Facts

Date created
Apr 17, 2012
Categories
Last update
Jun 08, 2012
Development stage
Beta
Language
  • enUS
  • frFR
License
Attribution-NonCommercial-ShareAlike 3.0 (Creative Commons) - english & french versions
Curse link
ValidServ
Downloads
2,621
Recent files

Authors