RPGItem

The plugin is not going to be continued on it's own, you'll find a rewritten and much better version in

At the moment the plugin is in alpha state and I just created the armor-part yet.
Basicially it creates items and armor with unlimited durability.

Actually you dont need any commands yet and there is no config.
I'm planning to add a config to decided which items are unlimited.
Also there is the idea to let the items (or only the armor) lose durability
on dead.

Note: I'm (G4meM0ment) student and need money to finish my driving license. So if you want I would add special features and ideas for you to the plugin for a little donation. PM me!

Features:

  • unlimted items
  • unlimited armor
  • supported by CraftBukkituptoDate

Commands:

  • /rpgitem reload | Reloads the config

Permissions:

  • rpgitem.reload | Allows to reload the config via command
  • rpgitem.admin | Full access to rpgitem

Thanks to kumpelblase2 for helping me with the variable code ;)

Source: https://github.com/G4meM0ment/RPGItem

Other plugins I'm working on:
http://dev.bukkit.org/server-mods/chaintrain-permissions/
http://dev.bukkit.org/server-mods/whokilledme-permissions
http://dev.bukkit.org/server-mods/Death-and-Rebirth/

You can donate to G4meM0ment via paypal to the email [email protected]

You must login to post a comment. Don't have an account? Register to get one!

  • Avatar of oulack oulack Sep 11, 2014 at 15:40 UTC - 0 likes

    thanks

    Last edited Sep 11, 2014 by oulack
  • Avatar of ozanalp200 ozanalp200 Sep 07, 2014 at 00:59 UTC - 0 likes

    Thanks

  • Avatar of redrabbit348 redrabbit348 Dec 04, 2013 at 13:16 UTC - 0 likes

    Okay thank you

  • Avatar of G4meM0ment G4meM0ment Dec 03, 2013 at 16:33 UTC - 0 likes

    @redrabbit348: Go

    No, RPGessentials contains it, you can enable it in the config while every other subplugins is disabled, won't affect performance.

    https://dl.dropboxusercontent.com/u/96045686/Finerien/Bilder/banner02.jpg

  • Avatar of redrabbit348 redrabbit348 Dec 03, 2013 at 03:20 UTC - 0 likes

    Well all I really need is RPGitems. Is there a way to just install it alone?

  • Avatar of G4meM0ment G4meM0ment Dec 01, 2013 at 20:59 UTC - 0 likes

    @redrabbit348: Go

    Did you mean this one or it's dead clone? Have a look at rpgessentials, it will be 1.7.2 yes!

  • Avatar of redrabbit348 redrabbit348 Dec 01, 2013 at 20:57 UTC - 0 likes

    Will this plugin ever be 1.7.2? I just updated and it broke, my server relies on this plugin pretty heavily.

  • Avatar of lanceryy lanceryy Oct 31, 2013 at 09:18 UTC - 0 likes

    This is a bug when the player who use the PRGitem with ice. The player use the ice skill on his stand position then he can destroy the block no matter which is in the protect area.

  • Avatar of G4meM0ment G4meM0ment Sep 28, 2013 at 19:27 UTC - 0 likes

    @teyjiarong1: Go

    Please always go to RPGEssentials page... Yes it will support EpicBoss in the future, may you could use cmds for now to reward players with an rpgitem.

  • Avatar of teyjiarong1 teyjiarong1 Sep 28, 2013 at 16:49 UTC - 0 likes

    Can This Plugin Support EpicBoss?

    Drops rpgitem

Facts

Date created
May 08, 2012
Categories
Last update
Jun 25, 2013
Development stage
Beta
Language
  • deDE
  • enUS
License
Public Domain
Curse link
RPGItem
Downloads
8,734
Recent files

Authors