RpgEssentials

Splash

RpgEssentials 2.0 DEV

Look at the pretty views!

http://rpgessentials.lynxdragon.com/plugin/previews/separator.png

Wiki

http://rpgessentials.lynxdragon.com/plugin/previews/separator.png

Screenshots

http://rpgessentials.lynxdragon.com/plugin/previews/separator.png

Textures

Textures are hosted at http:dl.Lynxdragon.com, Simply click the 'RPG Essentials' Category, Then click texturepack.zip from the drop-down menu. And your download will begin shortly!

http://rpgessentials.lynxdragon.com/plugin/previews/separator.png

Help pages

(Please read those before posting problems)

http://rpgessentials.lynxdragon.com/plugin/previews/separator.png

Videos

http://rpgessentials.lynxdragon.com/plugin/previews/separator.png

Download

http://rpgessentials.lynxdragon.com/plugin/previews/separator.png

Thanks to

  • Lynxdragon for hosting the files
  • Samkio for the anvil design
  • Kaynide for some designs

http://rpgessentials.lynxdragon.com/plugin/previews/separator.png

Change log

http://rpgessentials.lynxdragon.com/plugin/previews/separator.png

Other

http://cdn.spout.org/img/icon/twitter_48x48.png http://rpgessentials.lynxdragon.com/plugin/previews/git.png http://cdn.spout.org/img/icon/youtube_48x48.png

http://rpgessentials.lynxdragon.com/plugin/previews/separator.png

Please donate if you appreciate my work :D

https://www.paypalobjects.com/en_US/NL/i/btn/btn_donateCC_LG.gif

You must login to post a comment. Don't have an account? Register to get one!

  • Avatar of Marza004 Marza004 Mar 22, 2015 at 13:28 UTC - 0 likes

    It would be really cool if you can interrogate wool wars as the territory plugin. https://www.youtube.com/watch?v=Jzv48eleCcQ#t=313 I am also wondering would this work for minecraft 1.8 as im very interested in this plug, and if you can make it compatible with spigot 1.8 or craft bukkit 1.8. Thx loving the plugin BTW may donate

  • Avatar of optibytesmedia optibytesmedia Mar 21, 2015 at 16:28 UTC - 0 likes

    Heya ! its me again lol , just wondered the pre cached texture pack http://rpgessentials.lynxdragon.com/plugin/textures/XXMrPiggyCompanyXX.zip is offline for a while now and i was wondering if you could give me a temp link so that i can download it and reupload it to my own server so that im not dependent of outside problems related to the texture pack hosting going offline please ? thanks

  • Avatar of duckdoom5 duckdoom5 Feb 22, 2015 at 19:27 UTC - 0 likes

    @optibytesmedia: Go

    That's a spoutcraft bug, can't do anything about that.. sorry :/

  • Avatar of optibytesmedia optibytesmedia Feb 22, 2015 at 18:30 UTC - 0 likes

    Just a quick question : about the when inventory is full and pick up custom items dosent appear on inventory and lost , is this fixable ?

  • Avatar of optibytesmedia optibytesmedia Feb 21, 2015 at 18:02 UTC - 0 likes

    @duckdoom5: Go

    Altighty, thanks for the support!

  • Avatar of duckdoom5 duckdoom5 Feb 20, 2015 at 23:13 UTC - 0 likes

    @optibytesmedia: Go

    No you don't, spoutcraft has build in texture resizing.

    If they appear but don't appear right, you can't do anything about it I guess. It's probably a spout bug if it worked before.

    I did see something about fixing a texture/rendering bug in the builds above 31 but as you already know, the plugin for that build is not available.

    Last edited Feb 20, 2015 by duckdoom5
  • Avatar of optibytesmedia optibytesmedia Feb 20, 2015 at 22:32 UTC - 0 likes

    Woah like magic it worked ., Strange i was sure i had tested out that before. Huge thanks i can finally finish working on the server now ! last thing my textures of the custom items are ok but fuzzy a bit and dosent appear rendered right do i still need mcpatcher ?

  • Avatar of optibytesmedia optibytesmedia Feb 20, 2015 at 14:30 UTC - 0 likes

    @duckdoom5: Go

    Right, i guess i overlooked something ok thanks ill test it out once i get back from work

  • Avatar of duckdoom5 duckdoom5 Feb 20, 2015 at 12:10 UTC - 0 likes

    @optibytesmedia: Go

    Found out why: You've got SpoutPlugin build 4 and you need build 7, but that build is not available anymore

    (https://spoutcraft.org/threads/spoutcraft-change-log.8666/) Build 32 - 33 -> [This build requires SpoutcraftPlugin update on your server]

    You have to use Spoutcraft build 31 or below.

    Last edited Feb 20, 2015 by duckdoom5
  • Avatar of optibytesmedia optibytesmedia Feb 20, 2015 at 10:27 UTC - 0 likes

    Well my friend i did *Everything posssible to test it out and i dont know whats wrong. Heres what ive tried so far :

    1: removing all plugins and leaving spout and rpgessentials 2: disable all possible modules and kept the rpgessentials.jar core 3: make a separate server with a brand new map created on the spot 4: trying several versions of spoutcraftclient (technicLauncher) * there is lots of 1.6.4 versions 5: rebooting the router 6: re-open port for server 7: tried adding the packets manually with protocolLib (alltho each time its a different bad packet ID) 8: the software you were talking about (Minecraft-Region-Fixer-0.1.3) the world file came out clean with no errors (even tho i tried with a freshly generated map)

    Their might be a problem in the version of rpgessentials ( maybe its not all 1.6.4 releases compatible ?or maybe something wrong with the custom item ID?)

    My versions are : Spoutcraft client 1.6.4 b33 - Spoutcraftplugin lastest 1.6.4 - Craftbukkit1.6.4

    When it works : removing rpgessentials makes the server joinable again but when i add it the problem gets back. ( with my normal server and the new created server and map)

    So in conclusion i really dont know whats the problem sorry to bother you with all those problems but im really eager to make it work as i need this to *release the server and i really dont want to disappoint my players.

    Heres the logs of the normal server (essentially the same as the new server): https://dl.dropboxusercontent.com/u/66628004/duckdoom5/NormalServer.log

What should be added in 1.5?

  1. Choice:

  1. Results
  2. 10 comments

Facts

Date created
Feb 04, 2012
Categories
Last update
Feb 09, 2015
Development stage
Beta
Language
  • enUS
License
GNU General Public License version 3 (GPLv3)
Curse link
RpgEssentials
Downloads
65,678
Recent files

Authors

Relationships

Required dependency
SpoutPlugin
Optional dependency
Vault
WorldGuard