Ranged Wolves

4 - New version isn't compatible with MobArena

With either the DevBuild or latest release of MobArena, RangedWolves latest version throws up errors:

2012-01-07 03:13:24 [WARNING] [MobArena] Invalid monster type 'humans' in arenas.default.waves.recurrent.spec1
2012-01-07 03:13:24 [WARNING] [MobArena] Wave 'spec1' in arenas.default.waves.recurrent was not added!
2012-01-07 03:13:24 [INFO] [MobArena] v0.94.4.5 enabled.
2012-01-07 03:13:24 [SEVERE] Error occurred while enabling RangedWolves v0.8.6 (Is it up to date?): Found class com.garbagemule.MobArena.ArenaMaster but interface was expected
java.lang.IncompatibleClassChangeError Found class com.garbagemule.MobArena.ArenaMaster but interface was expected
    at com.ACStache.RangedWolves.RWConfig.loadConfig(RWConfig.java:37)
    at com.ACStache.RangedWolves.RangedWolves.onEnable(RangedWolves.java:55)
    at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:188)
    at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:968)
    at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:280)
    at org.bukkit.craftbukkit.CraftServer.loadPlugin(CraftServer.java:186)
    at org.bukkit.craftbukkit.CraftServer.enablePlugins(CraftServer.java:169)
    at net.minecraft.server.MinecraftServer.t(MinecraftServer.java:348)
    at net.minecraft.server.MinecraftServer.a(MinecraftServer.java:335)
    at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:165)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:399)
    at net.minecraft.server.ThreadServerApplication.run(SourceFile:457)

User When Change
dasbreen Jan 11, 2012 at 23:22 UTC
dasbreen Jan 09, 2012 at 05:58 UTC
doggyroc Jan 08, 2012 at 01:13 UTC
dasbreen Jan 07, 2012 at 19:05 UTC
spydercanopus Jan 07, 2012 at 09:16 UTC Create

You must login to post a comment. Don't have an account? Register to get one!

  • 5 comments
  • Avatar of dasbreen dasbreen Jan 09, 2012 at 06:00 UTC - 0 likes

    For anyone having this issue, you can either update MobArena to the latest Bleeding Dev build OR you can update RangedWolves to 0.8.7 - OldMA.

    For anyone else having this issue, please refer to my first post here. The link provided is where the Bleeding Development build of MobArena is. It is 1.0.1 compatible, but since it is a Dev version, it is not without it's bugs. Report any bugs (preferably to the correct plugin lol) found please!

    Also, if for whatever reason you do not want to try the latest Dev version of MobArena, the last version of RangedWolves that should still work is v0.8.5 (see the files tab for all the old files)

    Last edited Jan 11, 2012 by dasbreen

    ACStache from Bukkit Forums.
    Check out my plugins!
    Ranged Wolves, ArenaGodPlus, InstaBreak
    BFAK:72059,04761c3f43c01333ab2ea735aad3b9a8b86d3ced8d0671c2c0de722185ea5524

  • Avatar of fireblade518 fireblade518 Jan 08, 2012 at 21:32 UTC - 0 likes

    @dasbreen: Go

    Yea that new version of MobArena fixed it for me, thanks.

  • Avatar of dasbreen dasbreen Jan 08, 2012 at 17:36 UTC - 0 likes

    What version of mob arena, ranged wolves, and craft bukkit are you using doggyroc?

  • Avatar of doggyroc doggyroc Jan 08, 2012 at 01:13 UTC - 0 likes

    I have that same problem!

  • Avatar of dasbreen dasbreen Jan 07, 2012 at 19:05 UTC - 0 likes

    Could you try this build of MobArena for me? http://tinyurl.com/mableeding

    I'm not sure why you're having that issue, but let me know if it continues with this build.

  • 5 comments

Facts

Last updated
Mar 30, 2012
Reported
Jan 07, 2012
Status
Fixed - Developer made requested changes. QA should verify.
Type
Defect - A shortcoming, fault, or imperfection
Priority
Medium - Normal priority.
Votes
2

Reported by

Possible assignees