PigZapAlert

PZA_small

Version: 0.7

Now with the Mobs from Minecraft 1.2!

This plugin will print out a chat message, if a pig gets striked by lightning. You can configure the message, which the users receive and with permissions you can handle, if a group/user should see the message.

Since version 0.6 you can choose a mob, which should spawn instead of the pig-zombie. If you don't want that, just leave this free :)

Features

  • Prints a message, if a pig gets striked by lightning
  • Configure the message
  • Permissions Support
  • Replace the pigzombie with any other mob

Planned features

  • Disable Command

Permissions

  • pza.msg: The player receives the entire message.
  • pza.nocoord: The player receives the configured message, but not the coordinates
  • pza.coord: The player receives the coordinates, but not the configured message.
  • Normally, all permissions are set to false

Installation

Place PigZapAlert.jar in plugins folder. Have Fun!

Requirements

You need the RB or the 1.2 Dev Build.

Could be possible, that this plugin works with older versions too.
No support for older versions.

You must login to post a comment. Don't have an account? Register to get one!

  • 6 comments
  • Avatar of danielboyz danielboyz Mar 03, 2012 at 09:51 UTC - 1 like

    Yay replaced pigzombie with enderdragon!

  • Avatar of manniL manniL Feb 10, 2012 at 06:18 UTC - 0 likes

    @danielboyz: Go

    In Version 0.5 which i'll release today, the permissions will be normal :)

    @RoyalSoda: Go

    No problem, its your opinion. I think, that especially the little and New Plugins helping to get better. And maybe, someone searching for e.G. a kind of this Plugin :D

    Last edited Feb 10, 2012 by manniL
  • Avatar of RoyalSoda RoyalSoda Feb 09, 2012 at 22:19 UTC - 0 likes

    @manniL: Go

    Uhh.. pointless? Sorry for the unnecessary comment.. but this kind of thing simply spams our dev page.

    Try signing up for Dropbox here, you and I get extra space!

  • Avatar of danielboyz danielboyz Feb 09, 2012 at 21:35 UTC - 0 likes

    Nice plugin!!! But why the reversed permissions? I want my OPs to be able to use this too! Maybe you could add an option for this in the config

  • Avatar of manniL manniL Feb 09, 2012 at 17:41 UTC - 0 likes

    @Endimmion: Go I think, because only pigs become zombiepigmans, if they got zapped.

    :D

    But thats a good Idea...

  • Avatar of Endimmion Endimmion Feb 09, 2012 at 17:09 UTC - 0 likes

    Why only limit to pig?

  • 6 comments

Facts

Date created
Feb 07, 2012
Categories
Last update
Mar 02, 2012
Development stage
Release
Language
  • enUS
License
GNU General Public License version 3 (GPLv3)
Curse link
PigZapAlert
Downloads
3,469
Recent files

Authors