PermissionsEx

With Modifyworld, how do I let people place some blocks?

  • 6 posts
    #1 Mar 26, 2012 at 05:47 UTC - 0 likes

    I need to let people be able to open chests, and edit what's in them. I also need them to be able to place signs. How would I do that? Also, how do you allow them to use the bow? I am completely new to this plugin.

    Last edited Mar 26, 2012 by Kingdombanned
    #2 Mar 26, 2012 at 07:55 UTC - 1 like

    If you are using modifyworld (it's set to enabled: yes in it's config), you just need to give them the permission nodes.

    The wiki page https://github.com/PEXPlugins/PermissionsEx/wiki/Modifyworld covers most everything, but in a nutshell, giving a group modifyworld.* allows access to pretty much everything.

    As for your specific examples, modifyworld can't block taking or adding things to chests, but you can block players or groups from opening/interacting/placing or breaking them.

    Same deal with signs. Bows you can keep them from picking one up or having one, but using it isn't exposed by bukkit, so it can't be limited by PEX.

    If something is blocking signs and bow usage, there is something else going on.

    BFAK:77260,46822c9a5c20d9b0e5f016b060b3a4bc72965f1f3adadb7f2632a535738381a3

    #3 Mar 26, 2012 at 16:41 UTC - 0 likes

    @bacon_avenger: Go

    Okay, one final question,

    To be able to place signs would this be the correct configuration?

    - modifyworld.blocks.place.sign - modifyworld.blocks.place.323 - modifyworld.blocks.interact.323

    Because it is not working, I still can't place or interact with signs. Oh, also what would be the permission for using swords/fists? I don't know why I can't wrap my head around this, I keep trying the same permissions over and over again by what it says on the tutorials, but I still can't do shit.

    Last edited Mar 26, 2012 by Kingdombanned
    #4 Mar 27, 2012 at 02:24 UTC - 0 likes

    @Kingdombanned: Go

    Well, signs are kind of weird...

    Here is the debug output of me having a sign in my inventory, placing it and destroying it on the side of a block:

    (BTW, check into the debug command, it's a lifesaver when trying to debug permission issues :) ):

    18:59:58 [INFO] User bacon_avenger checked for "modifyworld.items.have.323", "*" found
    18:59:58 [INFO] User bacon_avenger checked for "modifyworld.blocks.interact.24", "*" found
    18:59:58 [INFO] User bacon_avenger checked for "modifyworld.blocks.place.68:2", "*" found
    19:04:16 [INFO] User bacon_avenger checked for "modifyworld.blocks.interact.68:2", "*" found
    19:04:16 [INFO] User bacon_avenger checked for "modifyworld.blocks.destroy.68:2", "*" found
    

    Here is the breakdown:

    1. Can I have the sign? (modifyworld.items.have.323)
    2. Can I place the sign on a piece of sandstone? (modifyworld.blocks.interact.24)
    3. Can I place the sign at all? (modifyworld.blocks.place.68:2)
    4. Can I touch the sign at all? (modifyworld.blocks.interact.68:2)
    5. Can I destroy the sign? (modifyworld.blocks.destroy.68:2)

    I know, this is strange.

    Minecraft has separate ID's for a sign in the player's inventory, a sign that is being used, and a sign that is already placed (check http://www.minecraftwiki.net/images/8/8c/DataValuesBeta.png for a list), and that's for one kind of sign (there are two, one placed on the wall and one placed on the ground). The :2 bit is the metadata, which is currently being looked into by the PEX devs:

    https://github.com/PEXPlugins/Modifyworld/issues/20 https://github.com/PEXPlugins/Modifyworld/issues/23

    Here is my config for modifyworld:

    informPlayers: true
    enable: true
    itemRestrictions: true
    messages:
      prohibitedItem: You can't have "%s".
      whitelistMessage: You are not allowed to join
      permissionDenied: You are not a special snowflake
    whitelist: false
    use-material-names: false
    item-use-check: false
    drop-restricted-item: true
    

    As you can see, I'm not using the material names, so any nodes I have would use numbers.

    As for the nodes, you can do this: For ground signs:

    • modifyworld.blocks.place.63:*
    • modifyworld.blocks.interact.63:*
    • modifyworld.blocks.destroy.63:*

    For wall signs:

    • modifyworld.blocks.place.68:*
    • modifyworld.blocks.interact.68:*
    • modifyworld.blocks.destroy.68:*

    Or, make use of the regex support (listed in the wiki and definitely worth reading) and make it a single line: modifyworld.blocks.(place|interact|destroy).(63|68):*

    Now, using swords/fists, bukkit doesn't expose anything to prevent someone from swinging a sword/punching, so what you can do is negate the node that allows damage to be caused for mobs and players, and for blocks/tems, block the interact/destroy nodes.

    Does this help out? :)

    #5 Feb 10, 2013 at 20:25 UTC - 0 likes

    For some reason, there is not an 'enable' option in my modifyworld config. Could someone help me with this??

    #6 Feb 11, 2013 at 08:29 UTC - 0 likes

    @noahband: Go

    I had the same problem and so I manually added it! :D Try doing that. Should Work

    - Clovis Dreadcraft Banner BFAK:90611323,c5e6289ab4ce05c7bc38a8621e5047b530f79f9d3635cdaa748d9af25a89c8d0

  • 6 posts

You must login to post a comment. Don't have an account? Register to get one!