Multiworld

148 - Item exploit: Throwing items into supposedly unlinked portals still transports them

What steps will reproduce the problem?
    1. Set up a standard array of survival worlds (world/nether/end)
    2. Set up a creative world alongside, with no linkages to any nether/end
    2. Build a nether/end portal in that creative world
    3. Throw any entity into it (such as items)

What is the expected output? What do you see instead?
    I expected the items to ignore the portal the way Players do, instead they are transported to your default survival nether/end

What version of the product are you using?
    4.7.2

What version of the craftbukkit/bukkit are you using?
    This server is running CraftBukkit version git-Bukkit-1.6.4-R2.0-37-g4857595-b2951jnks (MC:1.7.2) (Implementing API version 1.7.2-R0.1-SNAPSHOT)

Do you have an error log of what happened?
    no, no error

Please provide the result of /mw debug below:

    False False False - WorldSpawnHandler
    False False False - NetherPortalHandler
    False False False - GameModeChancer
    False False False - EnderChestBlokker
    False False False - EndPortalHandler
    False False False - WorldChatSeperatorPlugin

Note: Running MultiInv to handle player inventories and enderchests

User When Change
ferrybig Jan 15, 2014 at 18:21 UTC Changed status from Accepted to New
ferrybig Jan 15, 2014 at 18:21 UTC Changed status from Waiting to Accepted
ferrybig Jan 15, 2014 at 18:13 UTC Changed status from Fixed to Waiting
ferrybig Dec 16, 2013 at 10:09 UTC Changed status from Waiting to Fixed
ferrybig Dec 16, 2013 at 10:05 UTC Changed priority from Medium to Critical
ferrybig Dec 16, 2013 at 10:02 UTC Changed status from New to Waiting
Cultist_O Dec 15, 2013 at 01:34 UTC Create

You must login to post a comment. Don't have an account? Register to get one!

  • 4 comments
  • Avatar of ryanthemagi ryanthemagi May 18, 2014 at 14:38 UTC - 0 likes

    I am having this issue as well. Any update for a resolution?

  • Avatar of Cultist_O Cultist_O Feb 02, 2014 at 23:14 UTC - 0 likes

    still having the problem with 5.1.0,

    This is what the debug looks like now:

    [MultiWorld] Now printing debug information [MultiWorld] Multiworld version 5.1.0 [MultiWorld] Bukkit version: [MultiWorld] git-Bukkit-1.6.4-R2.0-37-g4857595-b2951jnks [MultiWorld] (MC: 1.7.2) [MultiWorld] [MultiWorld] <[Modules]> [MultiWorld] [State, pluginName] [MultiWorld] [Unloaded, WorldSpawnHandler] [MultiWorld] [Unloaded, NetherPortalHandler] [MultiWorld] [Unloaded, GameModeChancer] [MultiWorld] [Unloaded, EnderChestBlokker] [MultiWorld] [Unloaded, EndPortalHandler] [MultiWorld] [Unloaded, WorldChatSeperatorPlugin] [MultiWorld] [MultiWorld] <[CommandStacks]> [MultiWorld] multiworld.command,DefaultCommandStack [MultiWorld] - /mw [] [MultiWorld] multiworld.command.DefaultCommandStack [MultiWorld] - /mw [debug]

    Thanks for your time, I'm not posting this to rush you, only in case it can be some diagnostic help

    BFAK:Cultist O,51738,f3b0409af20e16df339c4956cf117df969a37a2f632f2e1c37726b647ecf7f08

  • Avatar of Cultist_O Cultist_O Jan 07, 2014 at 22:53 UTC - 0 likes

    I am still having this problem with 5.0.1

    This is my world set up: - "The_New_World" "The_New_World_nether" and "The_New_World_the_end" (default set from 1.6) - "Xeradan_amp" and "Xeradan _nor" overworlds generated in 1.7 (amplified and normal respectively) -"Redstone" is the only creative world

    my config is as follows:

    # # options.debug: must the debug output be printed?
    # # options.difficulty: what is the server diffeculty?
    # # options.locale: what set of lang files must be used, supported: en_US, nl_NL, de_DE, it_IT
    # # spawnGroup: used to set withs worlds have what spawn, difficult to use. see official site for details
    options:
      debug: false
      difficulty: 2
      locale: en_US
      usecreativemode: false
      usecreativemodeinv: true
      blockEnderChestInCrea: false
      useEndPortalHandler: false
      useportalhandler: false
      useWorldSpawnHandler: false
      useWorldChatSeperator: false
    worlds:
      The_New_World_the_end:
        seed: -7715943627271499491
        worldgen: The_End
        options: ''
        difficulty: 2
        autoload: true
      Xeradan_amp:
        seed: 2872673246919529363
        worldgen: NORMAL
        options: ''
        difficulty: 2
        autoload: true
      Xeradan_nor:
        seed: 4488877091835009741
        worldgen: NORMAL
        options: ''
        difficulty: 2
        autoload: true
      The_New_World:
        seed: 1431000893497583968
        worldgen: Normal
        options: ''
        difficulty: 2
        autoload: true
      Xeradan:
        seed: 2037916381300322516
        worldgen: Normal
        options: ''
        difficulty: 2
        autoload: false
      The_New_World_nether:
        seed: 1431000893497583968
        worldgen: Nether
        options: ''
        difficulty: 2
        autoload: true
      Redstone:
        seed: -8975151004363550210
        worldgen: Normal
        options: ''
        difficulty: 2
        autoload: true
    
    Last edited Jan 07, 2014 by Cultist_O
  • Avatar of ferrybig ferrybig Dec 16, 2013 at 10:02 UTC - 0 likes

    How did you setup your worlds?

    Somewhat like this:

    • world
    • world_nether
    • world_the_end
    • other_creative_world

    or a other methode?

    http://forums.bukkit.org/threads/request-saying-its-broke-doesnt-help-solve-the-issue.839/page-2 I also host an server that is dutch/english, ip: mctnt.gamemc.nl

  • 4 comments

Facts

Last updated
Jan 15, 2014
Reported
Dec 15, 2013
Status
New - Issue has not had initial review yet.
Type
Defect - A shortcoming, fault, or imperfection
Priority
Critical - Must resolve in the specified milestone.
Votes
0

Reported by

Possible assignees