Multiverse-Core

Forum > Help

World Names Not Showing

  • 2 posts
    #1 Jan 01, 2014 at 02:14 UTC - 0 likes

    I have looked everywhere, however all the help I have found was on how to DISABLE world names/aliases. My config file for essentials is:

    ############

    1. +----------+ #
    2. | EssentialsChat | #
    3. +----------+ #

    chat:

    1. If EssentialsChat is installed, this will define how far a player's voice travels, in blocks. Set to 0 to make all chat global.
    2. Note that users with the "essentials.chat.spy" permission will hear everything, regardless of this setting.
    3. Users with essentials.chat.shout can override this by prefixing text with an exclamation mark (!)
    4. Users with essentials.chat.question can override this by prefixing text with a question mark (?)
    5. You can add command costs for shout/question by adding chat-shout and chat-question to the command costs section." radius: 0
    1. Chat formatting can be done in two ways, you can either define a standard format for all chat.
    2. Or you can give a group specific chat format, to give some extra variation.
    3. If set to the default chat format which "should" be compatible with ichat.
    4. For more information of chat formatting, check out the wiki: http://wiki.ess3.net/wiki/Chat_Formatting
    1. ormat: '[faction_tag]<{DISPLAYNAME}>:{MESSAGE}'
    2. format: '&7[{FACTON_TAG}]&r {DISPLAYNAME}&7:&r {MESSAGE}'

    group-formats:

    1. Default: '{WORLDNAME} {DISPLAYNAME}&7:&r {MESSAGE}'
    2. Admins: '{WORLDNAME} &c[{GROUP}]&r {DISPLAYNAME}&7:&c {MESSAGE}'
    1. If you are using group formats make sure to remove the '#' to allow the setting to be read.

    And for multiverse multiverse

    -configuration:

    : com.onarandombox.MultiverseCore.MultiverseCoreConfiguration

    enforceaccess: 'false' prefixchat: 'true' teleportintercept: 'true' firstspawnoverride: 'true' displaypermerrors: 'true' globaldebug: '0' messagecooldown: '5000' version: '2.9' firstspawnworld: world teleportcooldown: '1000'

    Thanks in advance.

    #2 Feb 18, 2014 at 03:42 UTC - 0 likes

    You see how it says "Default: '{WORLDNAME} {DISPLAYNAME}&7:&r {MESSAGE}' "? See the "{WORLDNAME}"? That's what's missing from your "2. format: '[faction_tag]<{DISPLAYNAME}>:{MESSAGE}' ". You need to change it to " '[faction_tag] {WORLDNAME} <{DISPLAYNAME}>: {MESSAGE}' ". This is really late, but I'm just replying to all these problems I know the answer to while I search for the answer to my own problem.

    PowerCraft Banner

    Check out my server website! (Click the picture!)

    JOIN POWER CRAFT AT MCPOWERCRAFT.COM

  • 2 posts

You must login to post a comment. Don't have an account? Register to get one!