MoneyDrop

32 - Could not pass event on player death

What steps will reproduce the problem?
1. Smite someone to death

What is the expected output? What do you see instead?
They should drop money and die, instead there are errors and nothing is dropped.

What version of the product are you using?
MoneyDrop 2.1.1 on Bukkit 1.5.1-R0.2 (b2754jnks)

Do you have an error log of what happened?
2013-04-15 21:04:01 [INFO] Smiting ~Dr_Glute
2013-04-15 21:04:01 [SEVERE] Could not pass event PlayerDeathEvent to MoneyDrop v2.1.1
org.bukkit.event.EventException
    at org.bukkit.plugin.java.JavaPluginLoader$1.execute(JavaPluginLoader.java:427)
    at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.java:62)
    at org.bukkit.plugin.SimplePluginManager.fireEvent(SimplePluginManager.java:477)
    at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.java:462)
    at org.bukkit.craftbukkit.v1_5_R2.event.CraftEventFactory.callPlayerDeathEvent(CraftEventFactory.java:339)
    at net.minecraft.server.v1_5_R2.EntityPlayer.die(EntityPlayer.java:282)
    at net.minecraft.server.v1_5_R2.EntityLiving.damageEntity(EntityLiving.java:750)
    at net.minecraft.server.v1_5_R2.EntityHuman.damageEntity(EntityHuman.java:684)
    at net.minecraft.server.v1_5_R2.EntityPlayer.damageEntity(EntityPlayer.java:347)
    at org.bukkit.craftbukkit.v1_5_R2.entity.CraftLivingEntity.damage(CraftLivingEntity.java:195)
    at com.earth2me.essentials.commands.Commandlightning.run(Commandlightning.java:55)
    at com.earth2me.essentials.commands.EssentialsCommand.run(EssentialsCommand.java:117)
    at com.earth2me.essentials.Essentials.onCommandEssentials(Essentials.java:427)
    at com.earth2me.essentials.Essentials.onCommand(Essentials.java:320)
    at org.bukkit.command.PluginCommand.execute(PluginCommand.java:44)
    at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:189)
    at org.bukkit.craftbukkit.v1_5_R2.CraftServer.dispatchCommand(CraftServer.java:523)
    at org.bukkit.craftbukkit.v1_5_R2.CraftServer.dispatchServerCommand(CraftServer.java:512)
    at net.minecraft.server.v1_5_R2.DedicatedServer.am(DedicatedServer.java:261)
    at net.minecraft.server.v1_5_R2.DedicatedServer.r(DedicatedServer.java:226)
    at net.minecraft.server.v1_5_R2.MinecraftServer.q(MinecraftServer.java:476)
    at net.minecraft.server.v1_5_R2.MinecraftServer.run(MinecraftServer.java:409)
    at net.minecraft.server.v1_5_R2.ThreadServerApplication.run(SourceFile:573)
Caused by: java.lang.NullPointerException
    at me.drakespirit.plugins.moneydrop.EventListener.onPlayerDeath(EventListener.java:99)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
    at java.lang.reflect.Method.invoke(Unknown Source)
    at org.bukkit.plugin.java.JavaPluginLoader$1.execute(JavaPluginLoader.java:425)
    ... 22 more
2013-04-15 21:04:01 [INFO] GluteusMax died

Please provide any additional information below.

User When Change
spydercanopus Apr 16, 2013 at 03:12 UTC
spydercanopus Apr 16, 2013 at 02:07 UTC Create

You must login to post a comment. Don't have an account? Register to get one!

  • 1 comment
  • Avatar of spydercanopus spydercanopus Apr 16, 2013 at 02:12 UTC - 0 likes

    Nevermind. This was conflicting with a worldguard flag for invincibility.

    Last edited Apr 16, 2013 by spydercanopus
  • 1 comment

Facts

Last updated
Apr 16, 2013
Reported
Apr 16, 2013
Status
Invalid - This was not a valid report.
Type
Defect - A shortcoming, fault, or imperfection
Priority
Medium - Normal priority.
Votes
0

Reported by

Possible assignees