MobCatcher

130 - Horse loosing data after Restart or on throw-Release

What steps will reproduce the problem?
1. Find a horse.
2. Optional: Tame it, saddle it, put armor on it.
3. Remember it's state. (Saddled, Tamed, got I/G/D Armor, color)
4. Capture the horse
5. Rename the egg in a anvil or THROW to release.
6. Release the horse
7. There you go!

What is the expected output? What do you see instead?
I expected to see my horse like it was before. Instead, a random normal Horse was created, like if the egg had no data.

What versions MobCatcher, CraftBukkit, and Spout (if any) are you using?

Mobcatcher: 3.12, Bukkit: git-Bukkit-1.6.2-R0.1-b2838jnks (MC: 1.6.2) (Implementing API version 1.6.2-R0.1), Spout: Not using.

Have you previously had any older versions of MobCatcher on your server?
No.

Do you have an error log of what happened?
After rename I get this sometimes: http://pastebin.com/Ukm1xGRP

Please provide any additional information below.
I am able to reproduce this in survival and only throwing to release or anvil renaming seem to cause this Bug.

User When Change
Malikk65 Mar 23, 2014 at 09:11 UTC Changed status from Started to Declined
Malikk65 Aug 15, 2013 at 15:58 UTC
Fayti1703 Aug 14, 2013 at 17:35 UTC Changed description:
  No.

  Do you have an error log of what happened?
- No.
+ After rename I get this sometimes: http://pastebin.com/Ukm1xGRP

  Please provide any additional information below.
  I am able to reproduce this in survival and only throwing to release or anvil renaming seem to cause this Bug.
Fayti1703 Aug 14, 2013 at 17:30 UTC Changed name from Horse loosing data after Restart or Rename to Horse loosing data after Restart or on throw-Release
Fayti1703 Aug 14, 2013 at 17:19 UTC Changed description:
  2. Optional: Tame it, saddle it, put armor on it.
  3. Remember it's state. (Saddled, Tamed, got I/G/D Armor, color)
  4. Capture the horse
- 5. Rename the egg in a anvil or restart the server(sometimes restart doesn't cause it).
+ 5. Rename the egg in a anvil or THROW to release.
  6. Release the horse
  7. There you go!
----------------------------------------
  No.

  Please provide any additional information below.
- I am able to reproduce this in survival and only server restart(but not all the time) or anvil renaming seem to cause this Bug.
+ I am able to reproduce this in survival and only throwing to release or anvil renaming seem to cause this Bug.
Fayti1703 Aug 14, 2013 at 17:18 UTC
Malikk65 Aug 14, 2013 at 16:07 UTC
Fayti1703 Aug 14, 2013 at 09:43 UTC Changed description:
  2. Optional: Tame it, saddle it, put armor on it.
  3. Remember it's state. (Saddled, Tamed, got I/G/D Armor, color)
  4. Capture the horse
- 5. Rename the egg in a anvil or restart the server.
+ 5. Rename the egg in a anvil or restart the server(sometimes restart doesn't cause it).
  6. Release the horse
  7. There you go!
----------------------------------------
  No.

  Please provide any additional information below.
- I am able to reproduce this in survival and only server restart or anvil renaming seem to cause this Bug.
+ I am able to reproduce this in survival and only server restart(but not all the time) or anvil renaming seem to cause this Bug.
Fayti1703 Aug 14, 2013 at 09:35 UTC Create

You must login to post a comment. Don't have an account? Register to get one!

  • 5 comments
  • Avatar of Fayti1703 Fayti1703 Aug 15, 2013 at 17:05 UTC - 0 likes

    @Malikk65: Go

    Thanks, I wanted to see if the throw thing only works after Server Restart, but good it's fixed anyway.

  • Avatar of Malikk65 Malikk65 Aug 15, 2013 at 15:58 UTC - 0 likes

    I've fixed this for the next release.

    Thanks for the report :)

    My Plugins: MobCatcher, EpicGlass, Shield
    Donate!

  • Avatar of Fayti1703 Fayti1703 Aug 14, 2013 at 17:18 UTC - 0 likes

    @Malikk65: Go

    I'll continoue testing and I noticed something new. Updated Discription.

  • Avatar of Malikk65 Malikk65 Aug 14, 2013 at 16:07 UTC - 0 likes

    Its just for horses?

    I know I've set it up to save things over an anvil rename and I can't think of why horses would be acting differently than anything else.

    Knowing if it's a horse specific problem would help me narrow it down a lot. I'd test it myself but unfortunately I can't atm.

  • Avatar of Fayti1703 Fayti1703 Aug 14, 2013 at 09:44 UTC - 0 likes

    Okay, I'm not able to reproduce this anymore after server restart, anvil rename does still cause it however.

  • 5 comments

Facts

Last updated
Mar 23, 2014
Reported
Aug 14, 2013
Status
Declined - We decided not to take action on this ticket.
Type
Defect - A shortcoming, fault, or imperfection
Priority
Medium - Normal priority.
Votes
0

Reported by

Possible assignees