Minecraft Market

http://minecraftmarket.com/static/img/main_logo.png
The free donation alternative

What is Minecraft Market?

Minecraft Market is a web based shopping system which will allow you to sell just about anything that can be executed via a command. This allows just about anything to be sold via your web store.

What makes Minecraft Market different?

Minecraft Market was designed around the idea of being flexible and able to adapt to whatever situation it needs to be, so customization is a priority for us. However we also wanted to release something that was for everyone and not just big servers so our service is FREE with no limitations.

Features include: ==

  • Multiple Markets
  • Multiple Servers
  • Market themes
  • Subdomain/CNAME system
  • Paypal integration
  • Currency support
  • Cart system
  • Changeable Logo & Market covers
  • Recent purchases module
  • Monthly goal module
  • Module configuration
  • Banning system
  • Server Status Module
  • Force check command
  • Configurable purchase check interval
  • CKEditor for Item,Category & server text areas for easy formatting.
  • Purchase details page
  • Able to resend commands
  • Track users previous payments
  • Premium System
  • Add manual payments
  • Required items
  • Integration(Basic Iframe)
  • In-game shop
  • Discount settings
  • Live support if you ever need help
  • Custom CSS
  • Item images
  • Expiry, Chargeback, Renewal & Refund commands
  • Additional payment settings
  • Text box, Top Donor, Featured item modules
  • Custom variables
  • Server activity
  • Changeable ingame GUI Icons
  • Global Commands
  • Free carts
  • Market sales
  • Recent donator signs.

Features to be added: ==

  • Stripe gateway
  • Changeable fee per gateway
  • Integration (Advanced API Based.)
  • In-game recent donor list
  • Subscription payments
  • Language Translation
  • Email notifications
  • Create you own item
  • More soon... (Got a idea we dont have tell us!)

Example Market: ==

http://donate.minehaze.com
http://store.mcsimplegaming.com

So how do we start using Minecraft Market?

How to use recent donator signs ==

Place a sign putting [recent] on the top line and then a donation number you want to show most recent donation.
Once the sign has been place you can then place a head above the sign and it will update automatically.

  • Sign up at http://www.minecraftmarket.com
  • Create your first market and add your server to generate a API-KEY.
  • Create some items and make sure your server is enabled on them items.
  • Download the plugin and install onto your server then restart.
  • After the server restart edit the plugin config.yml and enter your servers API-KEY.
  • Reload the plugin using the /mmreload command.
  • DONE!

Tutorial Video:

Commands and Permissions: ==

CommandFunctionPermission
/mm reloadReloads pluginJust OP
/mm checkForces the plugin to check for purchasesJust OP
/shopOpens in-game GUIEveryone
/mm apikeyChange API-KEYJust OP

One you have install and setup your account/market on the website you can then link your users to your online webstore and allow them to purchase your items.

Support:

If you have any issues or questions about MinecraftMarket, please either open a ticker here or email [email protected]

Also we have Live support on the website for a even faster response now to!

Images: ==

http://i.imgur.com/dOlsLbM.png

Statistics:

http://api.mcstats.org/signature/MinecraftMarket.png

We use metrics to track the growth of the project and to see how popular the project is becoming, if you don't wish to become part of the statistics you can disable this in the plugin configuration.

As well as metrics we also use the curse API to allow users to get automatic updates instead of having to consistently check back for the latest version, if you would prefer not for the plugin to download updates you can once again disable this in the config file.

You must login to post a comment. Don't have an account? Register to get one!

  • Avatar of Robeatt Robeatt Apr 23, 2014 at 03:07 UTC - 0 likes

    @xXxKillDogxXx: Go

    Yes but it doesn't work, can you try it by you ? Or try to Buy from my Shop (mineplay.minecraftmarket.com) the "Wilkommenspaket" 2 times. In the Controlpanel is the Userlimit to 2 Years actually.

    And If you are Interested that i make a German Translation send me your Skype name per PM

  • Avatar of xXxKillDogxXx xXxKillDogxXx Apr 22, 2014 at 23:24 UTC - 0 likes

    @Robeatt: Go

    Let me take a look a this and ill get back to you as that option as you correctly said should work how you want it.

  • Avatar of Robeatt Robeatt Apr 22, 2014 at 23:02 UTC - 0 likes

    OK, Have installed to an another PC. It works fine!

    But one Problem i Have , in the Controlpanel i will make a Starterkit that People can Buy 1 Time, how i can set that? Have set the User limit to 2 Years but i can buy with my Account more than 1 Starterkit :/

    Edit: Do you need someone to make a German Translation? Have many German Server Friends that use your Plugin and a German Version isn't bad :)

    Last edited Apr 22, 2014 by Robeatt
  • Avatar of xXxKillDogxXx xXxKillDogxXx Apr 22, 2014 at 18:59 UTC - 0 likes

    @Robeatt: Go

    If i remember correctly the plugin is compiled against Java 7 and i run this plugin on a server that uses Java 7 so you still must be using a older version.

    Thats what that error indicates.

  • Avatar of Robeatt Robeatt Apr 22, 2014 at 15:08 UTC - 0 likes

    So now i have the newest Version of Java and thats the new Log in the Console I Use on my Computer Java 7 - Update 55

    Did the Plugin is made for Java 6?

    [17:05:30 ERROR]: Could not load 'plugins/MinecraftMarket.jar' in folder 'plugins' org.bukkit.plugin.InvalidPluginException: java.lang.UnsupportedClassVersionError: com/minecraftmarket/Market : Unsupported major.minor version 51.0 at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:131) [craftbukkit.jar:git-Bukkit-1.7.2-R0.3-56-g3779cff-b3072jnks] at org.bukkit.plugin.SimplePluginManager.loadPlugin(SimplePluginManager.java:328) [craftbukkit.jar:git-Bukkit-1.7.2-R0.3-56-g3779cff-b3072jnks] at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:251) [craftbukkit.jar:git-Bukkit-1.7.2-R0.3-56-g3779cff-b3072jnks] at org.bukkit.craftbukkit.v1_7_R3.CraftServer.loadPlugins(CraftServer.java:357) [craftbukkit.jar:git-Bukkit-1.7.2-R0.3-56-g3779cff-b3072jnks] at org.bukkit.craftbukkit.v1_7_R3.CraftServer.<init>(CraftServer.java:319) [craftbukkit.jar:git-Bukkit-1.7.2-R0.3-56-g3779cff-b3072jnks] at net.minecraft.server.v1_7_R3.PlayerList.<init>(PlayerList.java:68) [craftbukkit.jar:git-Bukkit-1.7.2-R0.3-56-g3779cff-b3072jnks] at net.minecraft.server.v1_7_R3.DedicatedPlayerList.<init>(SourceFile:14) [craftbukkit.jar:git-Bukkit-1.7.2-R0.3-56-g3779cff-b3072jnks] at net.minecraft.server.v1_7_R3.DedicatedServer.init(DedicatedServer.java:126) [craftbukkit.jar:git-Bukkit-1.7.2-R0.3-56-g3779cff-b3072jnks] at net.minecraft.server.v1_7_R3.MinecraftServer.run(MinecraftServer.java:436) [craftbukkit.jar:git-Bukkit-1.7.2-R0.3-56-g3779cff-b3072jnks] at net.minecraft.server.v1_7_R3.ThreadServerApplication.run(SourceFile:628) [craftbukkit.jar:git-Bukkit-1.7.2-R0.3-56-g3779cff-b3072jnks] Caused by: java.lang.UnsupportedClassVersionError: com/minecraftmarket/Market : Unsupported major.minor version 51.0 at java.lang.ClassLoader.defineClass1(Native Method) [?:1.6.0_65] at java.lang.ClassLoader.defineClassCond(ClassLoader.java:637) [?:1.6.0_65] at java.lang.ClassLoader.defineClass(ClassLoader.java:621) [?:1.6.0_65] at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:141) [?:1.6.0_65] at java.net.URLClassLoader.defineClass(URLClassLoader.java:283) [?:1.6.0_65] at java.net.URLClassLoader.access$000(URLClassLoader.java:58) [?:1.6.0_65] at java.net.URLClassLoader$1.run(URLClassLoader.java:197) [?:1.6.0_65] at java.security.AccessController.doPrivileged(Native Method) [?:1.6.0_65] at java.net.URLClassLoader.findClass(URLClassLoader.java:190) [?:1.6.0_65] at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:77) [craftbukkit.jar:git-Bukkit-1.7.2-R0.3-56-g3779cff-b3072jnks] at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:62) [craftbukkit.jar:git-Bukkit-1.7.2-R0.3-56-g3779cff-b3072jnks] at java.lang.ClassLoader.loadClass(ClassLoader.java:306) [?:1.6.0_65] at java.lang.ClassLoader.loadClass(ClassLoader.java:247) [?:1.6.0_65] at java.lang.Class.forName0(Native Method) [?:1.6.0_65] at java.lang.Class.forName(Class.java:249) [?:1.6.0_65] at org.bukkit.plugin.java.PluginClassLoader.<init>(PluginClassLoader.java:40) [craftbukkit.jar:git-Bukkit-1.7.2-R0.3-56-g3779cff-b3072jnks] at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:127) [craftbukkit.jar:git-Bukkit-1.7.2-R0.3-56-g3779cff-b3072jnks] ... 9 more

    Last edited Apr 22, 2014 by Robeatt
  • Avatar of xXxKillDogxXx xXxKillDogxXx Apr 22, 2014 at 12:29 UTC - 0 likes

    @Robeatt: Go @PoopinSprinklez: Go The reason why you are gettting this error for is because you are using a old version of java you need to update.

    Not only will MM work but also you should improve the speed of you server more than likely.

  • Avatar of Robeatt Robeatt Apr 22, 2014 at 01:08 UTC - 0 likes

    Doesn't Work for me. Im Using Bukkit 1.7.9 it is possible the Version of MinecraftMarket with 1.7.9?

    Get the same Problem in Console that PoopinSprinklez have

    Please help :S

  • Avatar of xXxKillDogxXx xXxKillDogxXx Apr 21, 2014 at 18:43 UTC - 0 likes

    @ReeferX7: Go

    can you pass me the ip so i can test the module with it? as we now support all server versions and there should not be a problem at all.

  • Avatar of TheOnlyRealTGS TheOnlyRealTGS Apr 21, 2014 at 16:54 UTC - 0 likes

    @lila135: Go

    It's already there ;)

    Owner of MC-Simple Gaming! Hope to see you there :)
    Need a free BuyCraft alternative? Try MinecraftMarket! | Need a great Spleef plugin? Try HeavySpleef!

    http://minecraft-mp.com/regular-banner-17943-3.png

  • Avatar of ReeferX7 ReeferX7 Apr 21, 2014 at 14:19 UTC - 0 likes

    hey xXxKillDogxXx very good plugin, is there a way to integration the module server status in my website?

    Edit: Server status dont work with Bungee Cord?

    Last edited Apr 21, 2014 by ReeferX7

Facts

Date created
Aug 27, 2013
Categories
Last update
Apr 11, 2014
Development stage
Release
Language
  • enUS
License
All Rights Reserved
Curse link
Minecraft Market
Downloads
8,986
Recent files

Authors