iConomy

iConomy iCon

Latest Stable: 6.0.8b

Latest Edge: 7.0

A simple, and easy to use economic core. It provides an easy to use API / service for other plugins to utilize to create innovative and new creations like lottery systems, card games, shops, and more. Your imagination is the limit, and iConomy is just plugging in.

Features

Coming Soon.

Support?

This is never checked, if you need help, email me at: [email protected] (I probably won't help you about older versions though as I don't remember much about them, if you have a feature request though, let me know.)

Permission nodes?

Please see the FAQ

Before asking questions

Before you ask any questions, any questions at all, read the FAQ.


Say hello to iConomy 7.0!

iConomy 7.0, now with multiworld, multiple currencies, and more~

You must login to post a comment. Don't have an account? Register to get one!

  • Avatar of skyshiny99 skyshiny99 Jul 28, 2014 at 17:21 UTC - 0 likes

    @GoleoLP: Go

    Wer Englisch kann, ist halt klar im Vorteil ;)

    iConomy ist seit Monaten (Jahren) inaktiv, es wird dir hier empfohlen, MySQL zu nutzen oder das Geldplugin zu wechseln. Das Geld kann auf zwei Arten gespeichert werden, nämlich in Dateien (Flatfiles) oder in einer Datenbank. Du verwendest die Speicherung in Dateien, allerdings hat deine iConomy-Version einen Bug, der alle iConomy-Daten löschen kann, falls sie in Dateien gespeichert werden.

    Fazit: Speicherung in einer MySQL-Datenbank oder anderes Eco-Plugin!

  • Avatar of GoleoLP GoleoLP Jul 24, 2014 at 20:59 UTC - 0 likes

    @Goldzora:

    Danke :) Aber ich hab das grad mal,mit Google übersetzt,weil die Fehlermeldungen nicht weg gehen :(

    Zeile 50: [22.37.43] [Server-Thread / WARN]: Es wird dringend empfohlen, mit SQL iCo6 zu verwenden oder eine alternative Wirtschaft Plugin nutzen zu können! - Zeile 49: [22.37.43] [Server-Thread / WARN]: wenn Sie Votifier, oder andere Plugin, das Wirtschaft-Daten in einem Gewinde Weise verarbeitet sind Ihr Server ist in Gefahr! - Zeile 48: [22.37.43] [Server-Thread / WARN]: iConomy - Wenn Sie Flatfile Lagerung sind sich bewusst, dass die Versionen 6, 7 und 8 haben einen kritischen Fehler, die alle Daten iconomy wischen kann.

    Kann ich nix tun,damit die Fehlermeldungen nicht mehr erscheinen?

  • Avatar of Goldzora Goldzora Jul 23, 2014 at 19:53 UTC - 1 like

    @GoleoLP: Go

    Das ist nichts Schlimmes, es warnt dich lediglich, dass es zu Datenverlusten kommen kann, wenn du bestimmte Plugins oder Versionen von diesen benutzt.

  • Avatar of GoleoLP GoleoLP Jul 21, 2014 at 07:07 UTC - 0 likes

    Zeile 52: [08:35:46] [Server thread/WARN]: it is highly suggested to use SQL with iCo6 or to use an alternative economy plugin! Zeile 51: [08:35:46] [Server thread/WARN]: if you're using Votifier, or any other plugin which handles economy data in a threaded manner your server is at risk! Zeile 50: [08:35:46] [Server thread/WARN]: iConomy - If you are using Flatfile storage be aware that versions 6, 7 and 8 have a CRITICAL bug which can wipe ALL iconomy data.

    Was ist das Problem??? Kann mir einer helfen???

  • Avatar of Camshaft1217 Camshaft1217 Jul 21, 2014 at 02:51 UTC - 0 likes

    Hello iConomy 7.0!

  • Avatar of kkround kkround Jul 18, 2014 at 02:57 UTC - 0 likes

    @tingeel: Go

    This link is not working

  • Avatar of kkround kkround Jul 16, 2014 at 14:08 UTC - 0 likes

    Is this work with mc 1.7.10 (UUID)? I don't know if the new UUID will work.

  • Avatar of madtomic madtomic Jul 16, 2014 at 11:40 UTC - 0 likes

    This project work with cb1.7.2-r0.3?

  • Avatar of Pixeloweed Pixeloweed Jul 10, 2014 at 21:39 UTC - 1 like

    Hello , please can you update the plugins , he is very usefull and simple and practice for people like me so it can be very cool to update it for 1.7+

  • Avatar of tingeel tingeel Jul 05, 2014 at 08:18 UTC - 0 likes

    @easys01: Go

    ansver of yours

    for (Player all : Bukkit.getOnlinePlayers()) { 
         chuj.GetHoldings(all).add(amount#doubleValue()); 
    };
    

Facts

Date created
Aug 24, 2011
Categories
Last update
Apr 02, 2012
Development stage
Beta
Language
  • enUS
License
GNU General Public License version 2 (GPLv2)
Curse link
iConomy
Downloads
2,111,650
Recent files
  • B: 7.0 for CB 1.2.4-R1.0 Apr 02, 2012
  • B: 6.0.9b for CB 1.2.3-R0.1 Feb 21, 2012
  • B: 6.0.8b for CB 1337 Nov 15, 2011
  • B: 6.0.5b for CB 1060 Sep 20, 2011
  • B: 6.0.4b for CB 1060 Sep 17, 2011

Authors