Grenader

Version: 1.9

Description:

Grenades is a plugin that make eggs exploding.

Commands:

/gl - Grenade Launching on your eye location
/ac130 - Firing to your eye location and it shoots 4 missiles.(Dangerous)

Permissions:

grenades.use - Allow to use grenades.
grenades.use.gl - Allow to use Grenade Launcher
grenades.use.ac130 - Allow to use AC-130
Ops can bypass permissions.

Configuration:

You can change the damage of grenade by config.yml
(config.yml can be found on /plugins/Grenader/)

Installation:

Download the latest version of grenader.jar
Place it to your bukkit plugins' file
(Re)Start your server
Successfully installed!

Video:

http://www.youtube.com/watch?v=xvhDvyFkY9Q

Change-log:

V.1 Release!
V.1.1 *Fixed a bug with file
V.1.2 *Fixed a bug with JRE6(A lot thanks to Reptar_ for found this)
+ Added Grenade Launcher
V.1.3 + Added BlockDamage on config.yml(set it to true if you want damage)
V.1.4 * Fixed a ton of bugs.
V.1.5 + Added AC-130
+ Added CB Version 1.3.1
V.1.6 * Fixed a bug with permissions
V.1.7 + Added Vault support!
* Fixed permissions
V.1.8 + CB Version 1.4.2
* Fixed a bug with config
V.1.8 + CB Version 1.4.7
+ Vault version 1.4.7

Requirements:

Vault

You must login to post a comment. Don't have an account? Register to get one!

  • Avatar of thesealsglobe thesealsglobe Aug 21, 2013 at 14:34 UTC - 0 likes

    y cant u turn block damage off

  • Avatar of Nerdfuryz Nerdfuryz Aug 12, 2013 at 06:54 UTC - 0 likes

    I looked inside the code and

    if (l.equalsIgnoreCase("gl")) {

    if ((!p.isOp()) || (!Permissions.has(p, "grenades.use.gl"))) {

    p.sendMessage(Permissions.noperm);

    } else {

    will make it so they HAVE to be op in order to perform the command. Switching the || operator to && should fix it.

    Last edited Aug 12, 2013 by Nerdfuryz

    BFAK:90687307,7db25c5d53dc8358361d8202ab55ce07dbf04e6b75da0cdd040cce4747bcb666

  • Avatar of Nerdfuryz Nerdfuryz Aug 12, 2013 at 06:44 UTC - 0 likes

    Permissions don't work

  • Avatar of theodossis theodossis Feb 22, 2013 at 13:14 UTC - 0 likes

    @hunajameloni: Go

    Updated ;)

  • Avatar of hunajameloni hunajameloni Jan 20, 2013 at 15:49 UTC - 0 likes

    Oh and Vault is not updated to 1.4.7

  • Avatar of hunajameloni hunajameloni Jan 20, 2013 at 15:47 UTC - 0 likes

    Egg do only damage when there is BLOCKDAMAGE. I want create grenadecraft wich won't break my map with explosion. SO can you add different config . Like PvPDamage: (number) BlockDamage: (number)

  • Avatar of theodossis theodossis Oct 29, 2012 at 05:58 UTC - 0 likes

    New version Released! Waiting approval!

  • Avatar of theodossis theodossis Oct 26, 2012 at 15:31 UTC - 0 likes

    Bug fixed. Waiting new Bukkit Version.

  • Avatar of theodossis theodossis Sep 21, 2012 at 19:05 UTC - 0 likes

    @agentplay: Go

    Making a lot of new things! :D

    Last edited Sep 21, 2012 by theodossis
  • Avatar of agentplay agentplay Sep 16, 2012 at 19:52 UTC - 0 likes

    @theodossis: Go

    Hey! How's the update going?? I kinda can't use the plugin until it's fixed, lol.

    Thanks,

    Agentplay.

Facts

Date created
Jul 14, 2012
Categories
Last update
Feb 17, 2013
Development stage
Release
Language
  • enUS
License
GNU General Public License version 3 (GPLv3)
Curse link
Grenader
Downloads
8,356
Recent files

Authors